Modify

Opened 7 years ago

Closed 7 years ago

#8211 closed enhancement (fixed)

Unresolved Dependencys for Package qos in Trunk

Reported by: Ernesto Owned by: developers
Priority: normal Milestone:
Component: packages Version: Trunk
Keywords: QOS TRUNK DEPENDENCYS Cc:

Description

When the Package "qos" is selected, some missing Modules/other Packages are not selected. I got this Error on Logfile after starting up:

# ./qos start
Cannot find device "imq0"
Cannot find device "imq0"
Cannot find device "imq0"
Cannot find device "imq0"
Cannot find device "imq0"
Cannot find device "imq0"
Cannot find device "imq0"
Cannot find device "imq0"
iptables: Input/output error.
iptables: Input/output error.
iptables v1.4.9.1: unknown option `--save-mark'
Try `iptables -h' or 'iptables --help' for more information.
iptables v1.4.9.1: unknown option `--restore-mark'
Try `iptables -h' or 'iptables --help' for more information.
iptables v1.4.9.1: unknown option `--todev'
Try `iptables -h' or 'iptables --help' for more information.

Attachments (0)

Change History (11)

comment:1 Changed 7 years ago by Ernesto

Sorry, was Basic-package "qos-scripts"

comment:2 Changed 7 years ago by Ernesto

I checked the package "iptables-mod-imq" and it is EMPTY! It is just an "empty" .ipk Package build. So in trunk no loadable module was build. No wondering why imq0 device not found ;-)

By the way. I have this problem with Orion and Kernel 2.6.35.8 and 2.6.36 for now

On Kernel 2.6.34.7 the module "libxt_imq.so" is build and packaged inside the resulting .ipk-Package.

comment:3 Changed 7 years ago by acoul

  • Resolution set to fixed
  • Status changed from new to closed

should be fixed in r23970. thank you for reporting

comment:4 Changed 7 years ago by Ernesto

  • Resolution fixed deleted
  • Status changed from closed to reopened

qos-scripts is still nit finaly fixed :(

There are still modules missing on 2.6.36. Just booth IMQ Modules are loaded, but there is no interface imq0 after bootup.

Please check again. It still works only 2.6.34.7

comment:5 Changed 7 years ago by buildster

Appreciate your efforts!

Just to confirm: I built kirkwood/dockstar (on kernel 2.6.35.8) using r23984. Even though qos-scripts and iptables-mod-imq were selected to be built (M) and did get built, kmod-ipt-imq was nowhere to be found in the packages directory.

comment:6 Changed 7 years ago by buildster

Before figuring out why kmod-ipt-imq was not built for me, I grabbed it from the snapshots dated on Nov. 13. opkg install it first and then qos-scripts. After a reboot, last several lines of dmesg complain about unknown symbols:

ip_tables: (C) 2000-2006 Netfilter Core Team
nf_conntrack version 0.5.0 (1985 buckets, 7940 max)
CONFIG_NF_CT_ACCT is deprecated and will be removed soon. Please use
nf_conntrack.acct=1 kernel parameter, acct=1 nf_conntrack module option or
sysctl net.netfilter.nf_conntrack_acct=1 to enable it.
xt_time: kernel timezone is -0000
imq: Unknown symbol skb_restore_cb (err 0)
imq: Unknown symbol dev_pick_tx (err 0)
imq: Unknown symbol nf_unregister_queue_imq_handler (err 0)
imq: Unknown symbol nf_queue_entry_release_refs (err 0)
imq: Unknown symbol nf_register_queue_imq_handler (err 0)
imq: Unknown symbol skb_save_cb (err 0)

Which module is supposed to provide those symbols?

comment:7 Changed 7 years ago by buildster

There is some progress, but not quite getting it.

I made a *clean* build of r23987 (practically as same as r23984 for this issue) for kirkwood/dockstar (on kernel 2.6.35.8). No more unknown symbols, ifconfig shows imq0 is loaded. Even though iptables-mod-conntrack-extra is installed and loaded, qos still complains:

root@OpenWrt:~# /etc/init.d/qos start
iptables: Input/output error.
iptables: Input/output error.
iptables v1.4.9.1: unknown option `--save-mark'
Try `iptables -h' or 'iptables --help' for more information.
iptables v1.4.9.1: unknown option `--restore-mark'
Try `iptables -h' or 'iptables --help' for more information.

comment:8 Changed 7 years ago by ddxx0n

This seems to be related to the problem in https://forum.openwrt.org/viewtopic.php?id=27602 and occurs in newer kernel versions:

I am using Backfire trunk (r24246) with kernel 2.6.36.1 on a WNDR3700.

Unfortunately, I cannot get layer7 matching to work: even a simple 'iptables -A FORWARD -m layer7 --l7proto irc -j REJECT' creates the respnse 'iptables: Input/output error.'. I am unable to find anything useful through Google. The error stays the same with all -A or -j variants I have tried.

... the problem is NOT a missing layer7 kernel module (or the error would be 'iptables v1.4.9.1: Couldn't load match `layer7':File not found')

... the problem is NOT a missing pattern file /etc/l7-protocols/irc.pat (or the error would be 'iptables v1.4.9.1: Couldn't find a pattern definition file for irc.')

comment:9 Changed 7 years ago by ddxx0n

I created a seperate ticket for the layer7 problem: /ticket/8366.html

comment:10 Changed 7 years ago by Ernesto

The Layer7/imq0 Interface Problems are Back since the libtool changes in Trunk, or maybe newer Kernels > 2.6.35!

comment:11 Changed 7 years ago by nbd

  • Resolution set to fixed
  • Status changed from reopened to closed

IMQ is no more, ifb is used now.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.