Modify

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#8210 closed defect (fixed)

jffs2/squashfs extremly unstable on Orion/2.6.36

Reported by: Ernesto Owned by: acoul
Priority: high Milestone:
Component: kernel Version: Trunk
Keywords: ORION JFFS2 INODE ERROR SQUASHFS KERNEL 2.6.36 Cc: maddes

Description

I got this type Problem of Problem continous:

Nov 10 19:29:39 OpenWrt user.crit kernel: kernel BUG at fs/inode.c:1244!
Nov 10 19:29:39 OpenWrt user.alert kernel: Unable to handle kernel NULL pointer dereference at virtual address 00000000
Nov 10 19:29:39 OpenWrt user.alert kernel: pgd = c0014000
Nov 10 19:29:39 OpenWrt user.alert kernel: [00000000] *pgd=0085a031, *pte=00000000, *ppte=00000000
Nov 10 19:29:39 OpenWrt user.emerg kernel: Internal error: Oops: 817 [#1]
Nov 10 19:29:39 OpenWrt user.emerg kernel: last sysfs file: /sys/devices/platform/leds-gpio/leds/wrt350nv2:green:wireless/mode
Nov 10 19:29:39 OpenWrt user.warn kernel: Modules linked in: usb_storage ohci_hcd ip_queue nf_nat_snmp_basic nf_nat_sip nf_conntrack_sip nf_nat_rtsp nf_conntrack_rtsp nf_nat_pptp nf_conntrack_pptp nf_nat_h323 nf_conntrack_h323 nf_nat_proto_gre nf_conntrack_proto_gre nf
Nov 10 19:29:39 OpenWrt user.warn kernel: CPU: 0    Not tainted  (2.6.36 #1)
Nov 10 19:29:39 OpenWrt user.warn kernel: pc : [<c002411c>]    lr : [<c0030ab4>]    psr: 20000013
Nov 10 19:29:39 OpenWrt user.warn kernel: sp : c0933ee8  ip : c0933e18  fp : c0933ef4
Nov 10 19:29:39 OpenWrt user.warn kernel: r10: 00b38030  r9 : c0932000  r8 : c0020f84
Nov 10 19:29:39 OpenWrt user.emerg kernel: 3fa0: c0020e00 c0097d24 00000ec4 00b1be18 00b1be18 00000028 ffffffc9 00000001
Nov 10 19:29:39 OpenWrt user.emerg kernel: 3fc0: 00000ec4 00b1be18 00000001 0000000a 00000065 00000000 00b38030 00000000
Nov 10 19:29:39 OpenWrt user.emerg kernel: 3fe0: 400e0f34 bedc9af0 0004d32c 400e0f40 20000010 00b1be18 01ffe031 01ffe431
Nov 10 19:29:39 OpenWrt user.warn kernel: Backtrace:
Nov 10 19:29:39 OpenWrt user.warn kernel: Function entered at [<c00240fc>] from [<c00a0518>]
Nov 10 19:29:39 OpenWrt user.warn kernel: Function entered at [<c00a02ec>] from [<c0097c84>]
Nov 10 19:29:39 OpenWrt user.warn kernel:  r7:c09b79c8 r6:c0933f1c r5:c0b0a240 r4:00000000
Nov 10 19:29:39 OpenWrt user.warn kernel: Function entered at [<c0097b88>] from [<c0097d2c>]
Nov 10 19:29:39 OpenWrt user.warn kernel:  r7:0000000a r6:00000001 r5:00b1be18 r4:00000ec4
Nov 10 19:29:39 OpenWrt user.warn kernel: Function entered at [<c0097d14>] from [<c0020e00>]
Nov 10 19:29:39 OpenWrt user.emerg kernel: Code: e1a01000 e59f000c eb07c58a e3a03000 (e5833000)
Nov 10 19:29:39 OpenWrt user.warn kernel: ---[ end trace 6e538aabdbe52005 ]---
Nov 10 19:29:46 OpenWrt user.info dropbear[3741]: exit after auth (root): Exited normally
Nov 10 19:31:57 OpenWrt user.info dropbear[6606]: Child connection from 192.168.1.3:2258

Every time when i save a changed file on a squashfs image i got some sort of backtraces. This happens only after the change to 2.6.36 today on Orion/WART350Nv2. with 2.6.35.8 this problem never comes up.

Needs more investigations.

Attachments (2)

989-pcie_fix_revert.patch (1.5 KB) - added by acoul 7 years ago.
217-mini_fo_2.6.36_fixes.patch (1.4 KB) - added by acoul 7 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 7 years ago by anonymous

seems to be mini_fo issue

comment:2 Changed 7 years ago by maddes

Could reproduce a segmentation fault on 2.6.36 too. Happened when installing packages.
Was using r23950 with Linux 2.6.36 on Orion platform.
Fortunately I always compile with symbols, which needs a bigger kernel mtd partiton of 1088KB, see #8183 ;)

The last segmentation fault in the wifi drivers was fixed by nbd and was due to an alignment error with ARM which has a 8-byte alignment. See #5815 and r19387.

Hope this additional info helps to resolve the bug.

Installing sudo (1.7.2p6-1) to root...
Downloading http://downloads.openwrt.org/snapshots/trunk/orion/packages/sudo_1.7.2p6-1_orion.ipk.
kernel BUG at fs/inode.c:1244!
Unable to handle kernel NULL pointer dereference at virtual address 00000000
pgd = c0d80000
[00000000] *pgd=01a5f031, *pte=00000000, *ppte=00000000
Internal error: Oops: 817 [#1]
last sysfs file: /sys/kernel/uevent_seqnum
Modules linked in: tun xt_recent xt_helper xt_conntrack xt_connmark xt_connbytes nf_nat_tftp nf_conntrack_tftp nf_nat_irc nf_conntrack_irc nf_nat_ftp nf_conntrack_ftp ipt_MASQUERADE iptable_nat nf_nat xt_NOTRACK iptable_raw xt_state nf_conntrack_ipv4 nf_defrag_ipv4 nf_conntrack pppoe pppox ipt_REJECT xt_TCPMSS ipt_LOG xt_comment xt_multiport xt_mac xt_limit iptable_mangle iptable_filter ip_tables xt_tcpudp x_tables ppp_async ppp_generic slhc ath9k ath9k_common ath9k_hw ath mac80211 crc_ccitt cfg80211 compat arc4 deflate ecb cbc
CPU: 0    Not tainted  (2.6.36 #1)
PC is at __bug+0x20/0x2c
LR is at release_console_sem+0x180/0x1c8
pc : [<c0025148>]    lr : [<c0031b00>]    psr: 20000013
sp : c0e47ee8  ip : c0e47e18  fp : c0e47ef4
r10: 00eecad8  r9 : c0e46000  r8 : c0021f84
r7 : c1ad4c00  r6 : c02dd908  r5 : c15a6650  r4 : 00000000
r3 : 00000000  r2 : 00000001  r1 : 60000013  r0 : 00000025
Flags: nzCv  IRQs on  FIQs on  Mode SVC_32  ISA ARM  Segment user
Control: a005317f  Table: 00d80000  DAC: 00000015
Process opkg (pid: 2447, stack limit = 0xc0e46270)
Stack: (0xc0e47ee8 to 0xc0e48000)
7ee0:                   c0e47f14 c0e47ef8 c00a47dc c0025138 00000000 c15a81d8
7f00: c0e47f1c c15a6650 c0e47f94 c0e47f18 c009becc c00a45c0 c0e47f40 c180ada0
7f20: c14fd9b8 38dce73a 00000007 c1b07005 00000000 c14fa318 00000000 00000000
7f40: 00000000 00000000 0000000e 000081a4 00000001 00000000 00000000 00000000
7f60: 0000031e 00000000 4c37168f 00000000 4a323fb2 c1b07000 00000000 00000000
7f80: 00000000 0000000a c0e47fa4 c0e47f98 c009bf74 c009bde0 00000000 c0e47fa8
7fa0: c0021e00 c009bf6c 00000000 00000000 00eecad8 00000001 00000000 00008000
7fc0: 00000000 00000000 00000000 0000000a 00eec600 00000270 00eecad8 00eec7a8
7fe0: 0002a1d0 bed18c28 0001a61c 400c2f40 20000010 00eecad8 00000000 00000000
Backtrace:
[<c0025128>] (__bug+0x0/0x2c) from [<c00a47dc>] (iput+0x22c/0x258)
[<c00a45b0>] (iput+0x0/0x258) from [<c009becc>] (do_unlinkat+0xfc/0x18c)
 r7:c15a6650 r6:c0e47f1c r5:c15a81d8 r4:00000000
[<c009bdd0>] (do_unlinkat+0x0/0x18c) from [<c009bf74>] (sys_unlink+0x18/0x1c)
 r7:0000000a r6:00000000 r5:00000000 r4:00000000
[<c009bf5c>] (sys_unlink+0x0/0x1c) from [<c0021e00>] (ret_fast_syscall+0x0/0x2c)
Code: e1a01000 e59f000c eb0828ce e3a03000 (e5833000)
---[ end trace f5567a6ac75dd67d ]---
Segmentation fault

comment:3 Changed 7 years ago by maddes

  • Cc maddes added

comment:4 Changed 7 years ago by maddes

Another error that occured later with firstboot. Maybe just a sequence error.

root@router:~# firstboot
firstboot has already been run
jffs2 partition is mounted, only resetting files
mini_fo_lookup: ERR from storage dentry, lookup failed.
mini_fo_d_delete: negative dentry passed.
mini_fo_d_release: no private data.

Changed 7 years ago by acoul

comment:5 Changed 7 years ago by acoul

try to replace the target/linux/generic/patches-2.6.36/989-kirkwood_pcie_reset_fixup.patch with the attached one: 989-pcie_fix_revert.patch

comment:6 follow-up: Changed 7 years ago by anonymous

acoul: it seems you did the mini_fo changes for 2.6.36. it's clear this is a bug in it

comment:7 in reply to: ↑ 6 Changed 7 years ago by acoul

Replying to anonymous:

acoul: it seems you did the mini_fo changes for 2.6.36. it's clear this is a bug in it

you can try to replace & test the generic/patches-2.6.36/217-mini_fo_2.6.36_fixes.patch with the attached one here.

Changed 7 years ago by acoul

comment:8 Changed 7 years ago by acoul

  • Owner changed from developers to acoul
  • Status changed from new to accepted

comment:9 Changed 7 years ago by acoul

  • Resolution set to fixed
  • Status changed from accepted to closed

should be fixed in r23956. thank you for reporting.

comment:10 Changed 7 years ago by maddes

Was able to install all my typical packages with any oops.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.