Modify

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#8196 closed defect (invalid)

luci-app-openvpn error loading module 'luci.controller.openvpn'

Reported by: sniperpr@… Owned by:
Priority: high Milestone: Bugs Paradise
Component: luci Version: Backfire 10.03
Keywords: openvpn luci Cc:

Description (last modified by jow)

error loading module 'luci.controller.openvpn' from file '/usr/lib/lua/luci/controller/openvpn.lua':
	/usr/lib/lua/luci/controller/openvpn.lua: bad header in precompiled chunk
stack traceback:
	[C]: ?
	[C]: in function 'require'
	?: in function 'createindex_plain'
	?: in function 'createindex'
	?: in function 'createtree'
	?: in function 'dispatch'
	?: in function <?:128>

Attachments (0)

Change History (4)

comment:1 Changed 7 years ago by jow

  • Description modified (diff)
  • Resolution set to worksforme
  • Status changed from new to closed

Bad Lua <-> bytecode combination. If you upgraded Lua, recompile LuCI.

comment:2 Changed 7 years ago by jazz@…

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I'm getting this now on a fresh install.

Flashed 10.03.1-rc4, setup WAN and installed luci-app-openvpn and I get the above reported error.

comment:3 follow-up: Changed 7 years ago by jow

  • Resolution set to invalid
  • Status changed from reopened to closed

Then you used the wrong packages for your fresh install, probably an outdated, restored opkg.conf - there is nothing I can do here as a simple recompilation or usage of the right repo would fix this already.

comment:4 in reply to: ↑ 3 Changed 7 years ago by anonymous

Replying to jow:

Then you used the wrong packages for your fresh install, probably an outdated, restored opkg.conf - there is nothing I can do here as a simple recompilation or usage of the right repo would fix this already.

Umm... If I'd restored the opkg.conf file, then it wouldn't be a 'fresh install' would it? /end_rhetorical_question

If I do a fresh install, then issue opkg update and opkg install luci-app-openvpn and it fucks the whole WebUI, then it's a bug don't ya think? Maybe the default repos are screwed? I don't know, I'm just reporting an obvious bug.

Rolling back to a 'fresh install' of 10.03.1-rc3 fixed the problem. So unless the version of this plugin used is different between rc3 and rc4, then I think it's safe to say that whatever is in the repos is NOT compatible with OpenWRT 10.03.1-rc4.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.