Modify

Opened 7 years ago

Last modified 4 years ago

#8168 new defect

Get Loop-aes working with util-linug-ng -> wrong patches...

Reported by: p91@… Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: loop-aes, encryption, util-linug-ng Cc:

Description

Hi,

I am trying to get loop-aes to work on my OpenWRT setup.
Problem is:
loop-aes version is 3.4b
util-linux-ng is version 2.13.1 (or something like that)
The patch contained in loop-aes is for util-linux-ng 2.18 and so I cannot patch mount etc to get it working.
So by now I see 4 possible solutions:

  1. update util-linux-ng -> many problems (like fdisk stops working but besides that I havent found other problems yet)
  2. downgrade loop-aes to 3.2b -> tried that but compile fails with "incompatible pointer types"
  3. get a new patch so loop-aes 3.4b will work with utils 2.13

I have no Idea how to do this but may be the best option

  1. make a new package for the patched utils or at least the needed programms.

As I am not so a good programmer I hope someone could take care of this. Maybe Florian can say something to this as he has done most of the work on this package.

Attachments (0)

Change History (1)

comment:1 Changed 4 years ago by jow

  • Milestone changed from Backfire 10.03.2 to Chaos Calmer (trunk)

Milestone Backfire 10.03.2 deleted

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.