Modify

Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#8133 closed defect (fixed)

[DG834Gv2] Not booting, crash upon cpmac_open()

Reported by: Oliver Winker <oliverml1@…> Owned by: florian
Priority: normal Milestone: Barrier Breaker 14.07
Component: kernel Version: Trunk
Keywords: DG834Gv2, crash, cpmac, boot Cc:

Description

Hello,

Using trunk, rev 23595, with my DG834Gv2 the kernel crashes during boot in initialization of cpmac in cpmac_open(), see details below.

Reverting the patches in target/linux/ar7/patches-2.6.32 back to rev 21691 lets cpmac successfully initialize and the device boot.

Best Regards, Oliver

* Crash: OpenWRT, svn://svn.openwrt.org/openwrt/trunk, Revision: 23595

---
ADAM2 Revision 0.18.01
(C) Copyright 1996-2003 Texas Instruments Inc. All Rights Reserved.
(C) Copyright 2003 Telogy Networks, Inc.
Usage: setmfreq [-d] [-s sys_freq, in MHz] [cpu_freq, in MHz]
Memory optimization Complete!

DGB34 > 
Press any key to abort OS load, or wait 3 seconds for OS to boot...
checksum error
Linux version 2.6.32.24 (oliver@gamix) (gcc version 4.3.3 (GCC) ) #1 Tue Oct 26 18:42:53 CEST 2010
bootconsole [early0] enabled
CPU revision is: 00018448 (MIPS 4KEc)
TI AR7 (TNETD7300), ID: 0x0005, Revision: 0x02
Determined physical RAM map:
 memory: 01000000 @ 14000000 (usable)
Initrd not found or empty - disabling initrd
Zone PFN ranges:
  Normal   0x00014000 -> 0x00015000
Movable zone start PFN for each node
early_node_map[1] active PFN ranges
    0: 0x00014000 -> 0x00015000
Built 1 zonelists in Zone order, mobility grouping off.  Total pages: 4064
Kernel command line: rootfstype=squashfs,jffs2 console=ttyS0,115200n8
PID hash table entries: 64 (order: -4, 256 bytes)
Dentry cache hash table entries: 2048 (order: 1, 8192 bytes)
Inode-cache hash table entries: 1024 (order: 0, 4096 bytes)
Primary instruction cache 16kB, VIPT, 4-way, linesize 16 bytes.
Primary data cache 16kB, 4-way, VIPT, no aliases, linesize 16 bytes
Memory: 12280k/16384k available (2213k kernel code, 4104k reserved, 473k data, 136k init, 0k highmem)
Hierarchical RCU implementation.
NR_IRQS:256
Calibrating delay loop... 149.50 BogoMIPS (lpj=747520)
Mount-cache hash table entries: 512
NET: Registered protocol family 16
bio: create slab <bio-0> at 0
Switching to clocksource MIPS
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 512 (order: 0, 4096 bytes)
TCP bind hash table entries: 512 (order: -1, 2048 bytes)
TCP: Hash tables configured (established 512 bind 512)
TCP reno registered
NET: Registered protocol family 1
squashfs: version 4.0 (2009/01/31) Phillip Lougher
Registering mini_fo version $Id$
JFFS2 version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
msgmni has been set to 23
io scheduler noop registered
io scheduler deadline registered (default)
Serial: 8250/16550 driver, 2 ports, IRQ sharing disabled
serial8250: ttyS0 at MMIO 0x8610e00 (irq = 15) is a TI-AR7
console [ttyS0] enabled, bootconsole disabled
console [ttyS0] enabled, bootconsole disabled
serial8250: ttyS1 at MMIO 0x8610f00 (irq = 16) is a TI-AR7
physmap platform flash device: 00800000 at 10000000
physmap-flash.0: Found 1 x16 devices at 0x0 in 16-bit bank
 CFI mfr 0x00000004
 CFI id  0x0000227e
 Amd/Fujitsu Extended Query Table at 0x0040
  Amd/Fujitsu Extended Query version 1.3.
number of CFI chips: 1
cfi_cmdset_0002: Disabling erase-suspend-program due to code brokenness.
cmdlinepart partition parsing not available
RedBoot partition parsing not available
4 ar7part partitions found on MTD device physmap-flash.0
Creating 4 MTD partitions on "physmap-flash.0":
0x000000000000-0x000000010000 : "loader"
0x0000003f0000-0x000000400000 : "config"
0x000000020000-0x0000003f0000 : "linux"
0x000000110000-0x0000003f0000 : "rootfs"
mtd: partition "rootfs" set to be root filesystem
mtd: partition "rootfs_data" created automatically, ofs=2D0000, len=120000 
0x0000002d0000-0x0000003f0000 : "rootfs_data"
Fixed MDIO Bus: probed
cpmac-mii: probed
eth%d: Marvell 88E6060 PHY driver attached.
cpmac: device eth0 (regs: 08612800, irq: -1, phy: 1:10, mac: 00:0f:b5:50:00:00)
cpmac: device eth1 (regs: 08610000, irq: 27, phy: 1:1f, mac: 00:0f:b5:50:00:00)
Registered led device: ppp
Registered led device: status
Registered led device: adsl
Registered led device: wifi
Registered led device: power
vlynq0: regs 0x08611800, irq 29, mem 0x04000000
Found a VLYNQ device: 00000009
vlynq1: regs 0x08611c00, irq 33, mem 0x0c000000
TCP westwood registered
NET: Registered protocol family 17
802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>
All bugs added by David S. Miller <davem@redhat.com>
VFS: Mounted root (squashfs filesystem) readonly on device 31:3.
Freeing unused kernel memory: 136k freed
Please be patient, while OpenWrt loads ...
- preinit -
Press the [f] key and hit [enter] to enter failsafe mode
- regular preinit -
jffs2 not ready yet; using ramdisk
mini_fo: using base directory: /
mini_fo: using storage directory: /tmp/root
- init -

Please press Enter to activate this console. eth0: failed to obtain irq
Kernel bug detected[#1]:
Cpu 0
$ 0   : 00000000 10008400 00000001 0041eca0
$ 4   : 947f8ca0 943da000 000005f2 00000002
$ 8   : 94fdd800 94fdd000 94fde800 94fde000
$12   : 94fef800 9439f3c8 94803410 94fef000
$16   : 00000900 00000041 948312c0 94831200
$20   : 10008401 b4f65000 00002000 9438e8f0
$24   : 00000000 9425b574                  
$28   : 94d00000 94d01d28 94390000 9428865c
Hi    : 00000000
Lo    : 00000000
epc   : 9418e31c kfree+0xac/0x1c8
    Not tainted
ra    : 9428865c cpmac_open+0x3a0/0x3f8
Status: 10008402    KERNEL EXL 
Cause : 30800034
PrId  : 00018448 (MIPS 4KEc)
Modules linked in:
Process ifconfig (pid: 350, threadinfo=94d00000, task=94f9d5d0, tls=00000000)
Stack : 00000040 948312c0 94831200 94831000 ffffffea 00000900 00000041 948312c0
        94831200 94831000 ffffffea 9428865c 00000001 94831000 00000000 00000080
        94831000 94831000 94831000 94890604 94831030 943d0000 943c37c0 00000000
        00000000 94d01e20 94831000 942a45ec 94391e50 94831000 00000141 9429f764
        94831000 00000141 00001102 00001043 94d01e10 942a3858 00000000 94d01e10
        ...
Call Trace:
[<9418e31c>] kfree+0xac/0x1c8
[<9428865c>] cpmac_open+0x3a0/0x3f8
[<942a45ec>] dev_open+0x164/0x264
[<942a3858>] dev_change_flags+0xd0/0x1bc
[<942fea68>] devinet_ioctl+0x2e8/0x964
[<9428d1a8>] sock_ioctl+0x29c/0x2fc
[<941a2378>] vfs_ioctl+0x2c/0x7c
[<941a2ab8>] do_vfs_ioctl+0x5e4/0x638
[<941a2b5c>] sys_ioctl+0x50/0x88
[<94101e10>] stack_done+0x20/0x3c


Code: 000211c2  38420001  30420001 <00028036> 8c860018  8cd10000  8e230000  8e220004  0062102b 
Disabling lock debugging due to kernel taint

---
Reading symbols from /media/OE/OpenWrt/trunk-dg834gv2/build_dir/linux-ar7/linux-2.6.32.24/vmlinux...done.
(gdb) list *cpmac_open+0x3a0/0x3f8
0x942882bc is in cpmac_open (drivers/net/cpmac.c:960).
955
956             spin_unlock(&priv->lock);
957     }
958
959     static int cpmac_open(struct net_device *dev)
960     {
961             int i, size, res;
962             struct cpmac_priv *priv = netdev_priv(dev);
963             struct resource *mem;
964             struct cpmac_desc *desc;
(gdb) 
---

* OK: OpenWRT, svn://svn.openwrt.org/openwrt/trunk, Revision: 23595

- target/linux/ar7/patches-2.6.32: Revision: 21691

---
ADAM2 Revision 0.18.01
(C) Copyright 1996-2003 Texas Instruments Inc. All Rights Reserved.
(C) Copyright 2003 Telogy Networks, Inc.
Usage: setmfreq [-d] [-s sys_freq, in MHz] [cpu_freq, in MHz]
Memory optimization Complete!

DGB34 > 
Press any key to abort OS load, or wait 3 seconds for OS to boot...
checksum error
Linux version 2.6.32.24 (oliver@gamix) (gcc version 4.3.3 (GCC) ) #1 Tue Oct 26 19:00:41 CEST 2010
bootconsole [early0] enabled
CPU revision is: 00018448 (MIPS 4KEc)
TI AR7 (TNETD7300), ID: 0x0005, Revision: 0x02
Determined physical RAM map:
 memory: 01000000 @ 14000000 (usable)
Initrd not found or empty - disabling initrd
Zone PFN ranges:
  Normal   0x00014000 -> 0x00015000
Movable zone start PFN for each node
early_node_map[1] active PFN ranges
    0: 0x00014000 -> 0x00015000
Built 1 zonelists in Zone order, mobility grouping off.  Total pages: 4064
Kernel command line: rootfstype=squashfs,jffs2 console=ttyS0,115200n8
PID hash table entries: 64 (order: -4, 256 bytes)
Dentry cache hash table entries: 2048 (order: 1, 8192 bytes)
Inode-cache hash table entries: 1024 (order: 0, 4096 bytes)
Primary instruction cache 16kB, VIPT, 4-way, linesize 16 bytes.
Primary data cache 16kB, 4-way, VIPT, no aliases, linesize 16 bytes
Memory: 12280k/16384k available (2213k kernel code, 4104k reserved, 473k data, 136k init, 0k highmem)
Hierarchical RCU implementation.
NR_IRQS:256
Calibrating delay loop... 149.50 BogoMIPS (lpj=747520)
Mount-cache hash table entries: 512
NET: Registered protocol family 16
bio: create slab <bio-0> at 0
Switching to clocksource MIPS
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 512 (order: 0, 4096 bytes)
TCP bind hash table entries: 512 (order: -1, 2048 bytes)
TCP: Hash tables configured (established 512 bind 512)
TCP reno registered
NET: Registered protocol family 1
squashfs: version 4.0 (2009/01/31) Phillip Lougher
Registering mini_fo version $Id$
JFFS2 version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
msgmni has been set to 23
io scheduler noop registered
io scheduler deadline registered (default)
Serial: 8250/16550 driver, 2 ports, IRQ sharing disabled
serial8250: ttyS0 at MMIO 0x8610e00 (irq = 15) is a TI-AR7
console [ttyS0] enabled, bootconsole disabled
console [ttyS0] enabled, bootconsole disabled
serial8250: ttyS1 at MMIO 0x8610f00 (irq = 16) is a TI-AR7
physmap platform flash device: 00800000 at 10000000
physmap-flash.0: Found 1 x16 devices at 0x0 in 16-bit bank
 CFI mfr 0x00000004
 CFI id  0x0000227e
 Amd/Fujitsu Extended Query Table at 0x0040
  Amd/Fujitsu Extended Query version 1.3.
number of CFI chips: 1
cfi_cmdset_0002: Disabling erase-suspend-program due to code brokenness.
cmdlinepart partition parsing not available
RedBoot partition parsing not available
4 ar7part partitions found on MTD device physmap-flash.0
Creating 4 MTD partitions on "physmap-flash.0":
0x000000000000-0x000000010000 : "loader"
0x0000003f0000-0x000000400000 : "config"
0x000000020000-0x0000003f0000 : "linux"
0x000000110000-0x0000003f0000 : "rootfs"
mtd: partition "rootfs" set to be root filesystem
mtd: partition "rootfs_data" created automatically, ofs=2D0000, len=120000 
0x0000002d0000-0x0000003f0000 : "rootfs_data"
Fixed MDIO Bus: probed
cpmac-mii: probed
cpmac: device eth0 (regs: 08612800, irq: 41, phy: 0:01, mac: 00:0f:b5:50:00:00)
cpmac: device eth1 (regs: 08610000, irq: 27, phy: 0:00, mac: 00:0f:b5:50:00:00)
Registered led device: ppp
Registered led device: status
Registered led device: adsl
Registered led device: wifi
Registered led device: power
vlynq0: regs 0x08611800, irq 29, mem 0x04000000
Found a VLYNQ device: 00000009
vlynq1: regs 0x08611c00, irq 33, mem 0x0c000000
TCP westwood registered
NET: Registered protocol family 17
802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>
All bugs added by David S. Miller <davem@redhat.com>
VFS: Mounted root (squashfs filesystem) readonly on device 31:3.
Freeing unused kernel memory: 136k freed
Please be patient, while OpenWrt loads ...
---

Attachments (1)

puttycom1.jpg (39.1 KB) - added by anonymous 6 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 7 years ago by jow

  • Owner changed from developers to florian
  • Status changed from new to assigned

comment:2 Changed 7 years ago by florian

I cannot reproduce this issue with a device having an ip175c switch. Have you made any local modifications to get -1 as an irq for eth0?

comment:3 Changed 7 years ago by florian

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with r23862, thanks to Wipster for also help finding the bug.

Changed 6 years ago by anonymous

comment:4 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.