Modify

Opened 7 years ago

Closed 6 years ago

#8129 closed defect (worksforme)

ar71xx - xfrm_ipcomp.ko: No such file or directory

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Backfire 10.03.1
Component: kernel Version: Trunk
Keywords: ipcomp Cc:

Description

When trying to build for ar71xx (RB 433), I get:
cp: cannot stat `build_dir/linux-ar71xx/linux-2.6.32.16/net/xfrm/xfrm_ipcomp.ko': No such file or directory

Attachments (0)

Change History (4)

comment:1 Changed 7 years ago by Kvetch@…

Do you have kmod-ipsec4 enabled? It build ipcomp
Kernel-Modules -> Network Support -> kmod-ipsec4

comment:2 Changed 7 years ago by anonymous

I'm not the one who filed this bug originally, but can verify that kmod-ipsec4 is enabled (in the "M" sense, that is.)

Pretty much trying to compile any ipsec package e.g. strongswan will activate kmod-ipsec4 automatically, and this build error is the result.

comment:3 Changed 7 years ago by anonymous

It would appear something has set INET_IPCOMP=y in the build-dir kernel .config. This in turn makes XFRM_INET=y rather than =m. The package expects a .ko, and there is just the .o there.

As an aside: As great as KConfig is, uCLinux/OpenWRT really need to clean up the defualt_config inheritance mechnanisms to make them more understandable/debuggable. Trying to figure out where this setting is inherited from is making me dizzy given the pulling in and then overriding configs from architecture directories and such. Having done some hacking on uCLinux myself I know it also throws up a lot of obstacles to adding support for new systems that do not fit the mold that others of the same arch have laid down.

Also as an aside: It wouldn't hurt to clear up the obvious confusion caused by "y" in the kmod package meaning "build as m in the kernel, but put it in the flash image" and have the kmod packages properly deal with stuff being actually built monolithically into the kernel.

comment:4 Changed 6 years ago by nico

  • Resolution set to worksforme
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.