Modify

Opened 7 years ago

Closed 7 years ago

#8099 closed defect (worksforme)

tc operations on eth0 dumps kernel because eps is 0

Reported by: tkmbe Owned by: developers
Priority: high Milestone: Backfire 10.03.1
Component: packages Version: Backfire 10.03.1 RC3
Keywords: tc dump kernel Cc:

Description

Hw: Nanostation2

If you use anything from tc on eth0 like

tc qdisc show dev eth0

or

tc -s class show dev eth0

kernel will dump. Tried orig 10.03.1 RC3 and own compilation.
Same issue!
Similar problem was reported for kamikaze (and solved there as stated).
Let me know if you need more infos.

Output:

CPU 0 Unable to handle kernel paging request at virtual address 00000000, epc == 00000000, ra == 801ead84
Oops#1:
Cpu 0
$ 0 : 00000000 10009c00 802764d0 00000000
$ 4 : 80f79580 806ffaf8 00000000 00000000
$ 8 : 802c5614 800450d0 00000000 00000000
$12 : 00000000 00000000 00000014 00424380
$16 : 806ffb68 8064d480 8064d480 80dd9810
$20 : 80db29a0 806ffb68 801eae80 80dd9800
$24 : 00000000 80dd9824
$28 : 806fe000 806ffae8 80f2c400 801ead84
Hi : 00000265
Lo : 00026cee
epc : 00000000 (null)

Tainted: P

ra : 801ead84 0x801ead84
Status: 10009c03 KERNEL EXL IE
Cause : 10800008
BadVA : 00000000
PrId : 00019064 (MIPS 4KEc)
Modules linked in: ath_ahb ath_hal(P) nf_nat_tftp nf_conntrack_tftp nf_nat_irc nf_conntrack_irc nf_nat_ftp nf_conntrack_ftp ipt_MASQUERADE iptable_nat nf_nat xt_NOTRACK iptable_raw xt_state nf_conntrack_ipv4 nf_defrag_ipv4 nf_conntrack pppoe pppox ipt_REJECT xt_TCPMSS ipt_LOG xt_comment xt_multiport xt_mac xt_limit iptable_mangle iptable_filter ip_tables xt_tcpudp x_tables ppp_async ppp_generic slhc crc_ccitt
Process tc (pid: 766, threadinfo=806fe000, task=80f39528, tls=00000000)
Stack : 00000000 804c0160 00000006 80db25e0 00000000 00000000 00000000 801eb2b4

80db29a0 8064d480 80000000 80387c00 80f79580 801eae08 00000001 80b75b80
804c0000 80db29a0 806ffb68 00000000 80387c00 80dd9810 8064d480 80db29a0
00000000 801eaf00 00000000 b0000000 80de1600 80de1600 806ffb68 00000000
00000000 801c67d8 804c0000 80db29a0 8064d480 80de1600 0000001a 801f3f78
...

Call Trace:[<801eb2b4>] 0x801eb2b4
[<801eae08>] 0x801eae08
[<801eaf00>] 0x801eaf00
[<801c67d8>] 0x801c67d8
[<801f3f78>] 0x801f3f78
[<801f2fdc>] 0x801f2fdc
[<801f3f78>] 0x801f3f78
[<801f4200>] 0x801f4200
[<801f3f78>] 0x801f3f78
[<801f302c>] 0x801f302c
[<80087eac>] 0x80087eac
[<801eae80>] 0x801eae80
[<801e2bcc>] 0x801e2bcc
[<801e2ac8>] 0x801e2ac8
[<801f626c>] 0x801f626c
[<801e2ab8>] 0x801e2ab8
[<801f5a1c>] 0x801f5a1c
[<801cbd00>] 0x801cbd00
[<801f5e48>] 0x801f5e48
[<801f349c>] 0x801f349c
[<801cbd00>] 0x801cbd00
[<801c3d50>] 0x801c3d50
[<801c3944>] 0x801c3944
[<800aa1bc>] 0x800aa1bc
[<8007a148>] 0x8007a148
[<800aa638>] 0x800aa638
[<8007a148>] 0x8007a148
[<801cedd0>] 0x801cedd0
[<801c3f28>] 0x801c3f28
[<80055f70>] 0x80055f70
[<801c32a4>] 0x801c32a4
[<801c3474>] 0x801c3474
[<8005b780>] 0x8005b780
[<8005b898>] 0x8005b898
[<80049de8>] 0x80049de8
[<800431d0>] 0x800431d0

Code: (Bad address in epc)

Attachments (0)

Change History (2)

comment:1 Changed 7 years ago by markus_kubler@…

Using WR1043ND (ar71xx) with Backfire 10.03.1 RC3 I cannot reproduce this. Is this Nanostation2-only problem?

comment:2 Changed 7 years ago by jow

  • Resolution set to worksforme
  • Status changed from new to closed

This is probably yet another ABI mismatch, custom kernel plus repo kmods.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.