Modify

Opened 7 years ago

Closed 6 years ago

#8064 closed defect (fixed)

Kernel panic - not syncing: Attempted to kill init on DWL-2100AP rev. 4

Reported by: e.kubrakov@… Owned by: acoul
Priority: response-needed Milestone: Backfire 10.03.1
Component: kernel Version: Trunk
Keywords: Cc:

Description

Kernel crash log:

RedBoot> reset
.RedBoot> fis load -l vmlinux.bin.l7
lzma_init: initialize the decoder
lzma_inflate: decompress stream
lzma_inflate; copy decodification code to RAM
Image loaded from 0x80041000-0x802c2200
RedBoot> exec
Now booting linux kernel:
 Base address 0x80080000 Entry 0x80041000
 Cmdline : 
Linux version 2.6.30.10 (therin@Z10N.site) (gcc version 4.3.3 (GCC) ) #1 Sat Oct 9 19:48:09 OMSST 2010
console [early0] enabled
CPU revision is: 0001800a (MIPS 4Kc)
Determined physical RAM map:
 memory: 01000000 @ 00000000 (usable)
Initrd not found or empty - disabling initrd
Zone PFN ranges:
  Normal   0x00000000 -> 0x00001000
Movable zone start PFN for each node
early_node_map[1] active PFN ranges
    0: 0x00000000 -> 0x00001000
Built 1 zonelists in Zone order, mobility grouping off.  Total pages: 4064
Kernel command line: console=ttyS0,9600 rootfstype=squashfs,jffs2
Primary instruction cache 16kB, VIPT, 4-way, linesize 16 bytes.
Primary data cache 16kB, 4-way, VIPT, no aliases, linesize 16 bytes
NR_IRQS:128
PID hash table entries: 64 (order: 6, 256 bytes)
console handover: boot [early0] -> real [ttyS0]
Dentry cache hash table entries: 2048 (order: 1, 8192 bytes)
Inode-cache hash table entries: 1024 (order: 0, 4096 bytes)
Memory: 13308k/16384k available (1983k kernel code, 3076k reserved, 453k data, 128k init, 0k highmem)
Calibrating delay loop... 179.40 BogoMIPS (lpj=897024)
Mount-cache hash table entries: 512
CPU 0 Unable to handle kernel paging request at virtual address 00000028, epc == 80080000, ra == 8007ff58
Oops[#1]:
Cpu 0
$ 0   : 00000000 1000c000 00000008 80295ae8
$ 4   : 1000c001 80296128 00000000 000000d0
$ 8   : 00000000 80f1a4d8 80295ae8 80295b24
$12   : ffffffff 802ff488 ffffffff ffffffff
$16   : 80f1a480 80f2c000 80f19ee0 8029af10
$20   : 00000000 80272ea8 802fe380 00000000
$24   : 00000000 00000000                  
$28   : 80f18000 80f19e88 80f2c000 8007ff58
Hi    : 00000000
Lo    : 00000000
epc   : 80080000 prepare_usermodehelper_creds+0xe0/0x114
    Not tainted
ra    : 8007ff58 prepare_usermodehelper_creds+0x38/0x114
Status: 1000c003    KERNEL EXL IE 
Cause : 00800008
BadVA : 00000028
PrId  : 0001800a (MIPS 4Kc)
Modules linked in:
Process swapper (pid: 1, threadinfo=80f18000, task=80f17928, tls=00000000)
Stack : 00000000 80f09480 80f2c000 80f19ee0 80f09300 800741cc 80f2c0c3 000007c1
        00000001 00000001 80f19ed0 80f09480 00000000 8029bd80 802d0000 8014b938
        80f04b88 8029bf00 00000006 80f19ed0 80f09488 8014aaa8 8029af10 802fe380
        00000000 00000000 80f2bd00 8014ac00 00000000 80f04b88 80f04b88 8029bf00
        00000000 00000000 00000000 00000000 00000000 8014ad64 8029be60 80181b1c
        ...
Call Trace:
[<80080000>] prepare_usermodehelper_creds+0xe0/0x114
[<800741cc>] call_usermodehelper_setup+0x68/0x9c
[<8014b938>] kobject_uevent_env+0x384/0x404
[<8014ad64>] kset_register+0x40/0x58
[<801839a0>] bus_register+0xb8/0x274
[<802b1c0c>] platform_bus_init+0x34/0x5c
[<802b1d14>] driver_init+0x30/0x44
[<802a32e4>] kernel_init+0x80/0x10c
[<8004eda8>] kernel_thread_helper+0x10/0x18


Code: 3821001f  00812025  40846000 <80080028> 80080030  8008003b  80080044  8008004f  80080057 
Disabling lock debugging due to kernel taint
Kernel panic - not syncing: Attempted to kill init!

Attachments (0)

Change History (14)

comment:1 follow-up: Changed 7 years ago by acoul

  • Owner changed from developers to acoul
  • Status changed from new to assigned

not enough data to compute

have you tried an image from here?

comment:2 in reply to: ↑ 1 Changed 7 years ago by anonymous

Replying to acoul:

not enough data to compute

have you tried an image from here?

Kernel crash log:

 reset
�+. Resetting.
RedBoot startup
Ethernet eth0: MAC address 00:17:9a:76:87:e5
IP: 192.168.0.50/255.255.255.0, Gateway: 192.168.0.1
Default server: 0.0.0.0, DNS server IP: 0.0.0.0

RedBoot(tm) bootstrap and debug environment [ROM]
Non-certified release, version v2_0 - built 16:27:48, Jul  1 2007
With changes made by Waldeck Schutzer <waldeck@dm.ufscar.br>


Copyright (C) 2000, 2001, 2002, Red Hat, Inc.

RAM: 0x80000400-0x81000000, 0x80000400-0x807d1ce0 available
FLASH: 0xbfc00000 - 0xbffe0000, 62 blocks of 0x00010000 bytes each.
== Executing boot script in 1.000 seconds - enter ^C to abort
RedBoot> fis load -l vmlinux.bin.l7
lzma_init: initialize the decoder
lzma_inflate: decompress stream
lzma_inflate; copy decodification code to RAM
Image loaded from 0x80041000-0x802cb844
RedBoot> exec
Now booting linux kernel:
 Base address 0x80080000 Entry 0x80041000
 Cmdline : 
Linux version 2.6.32.24 (buildslave@dd.das-iro.de) (gcc version 4.3.3 (GCC) ) #1 Thu Oct 7 13:47:31 CEST 2010
bootconsole [early0] enabled
CPU revision is: 0001800a (MIPS 4Kc)
Determined physical RAM map:
 memory: 01000000 @ 00000000 (usable)
Initrd not found or empty - disabling initrd
Zone PFN ranges:
  Normal   0x00000000 -> 0x00001000
Movable zone start PFN for each node
early_node_map[1] active PFN ranges
    0: 0x00000000 -> 0x00001000
Built 1 zonelists in Zone order, mobility grouping off.  Total pages: 4064
Kernel command line: console=ttyS0,9600 rootfstype=squashfs,jffs2
PID hash table entries: 64 (order: -4, 256 bytes)
Dentry cache hash table entries: 2048 (order: 1, 8192 bytes)
Inode-cache hash table entries: 1024 (order: 0, 4096 bytes)
Primary instruction cache 16kB, VIPT, 4-way, linesize 16 bytes.
Primary data cache 16kB, 4-way, VIPT, no aliases, linesize 16 bytes
Memory: 13264k/16384k available (2118k kernel code, 3120k reserved, 348k data, 136k init, 0k highmem)
Hierarchical RCU implementation.
NR_IRQS:128
console [ttyS0] enabled, bootconsole disabled
console [ttyS0] enabled, bootconsole disabled
Calibrating delay loop... 179.40 BogoMIPS (lpj=897024)
Mount-cache hash table entries: 512
CPU 0 Unable to handle kernel paging request at virtual address 00000057, epc == 80080014, ra == 800802b4
Oops[#1]:
Cpu 0
$ 0   : 00000000 1000c000 00000000 0000016d
$ 4   : 8029d370 00000000 80260000 000003a0
$ 8   : 00000000 800454f0 80819e08 80819eb0
$12   : 00000015 80803190 ffffffff 00000001
$16   : 8029bd50 00000000 8029d370 8029bd50
$20   : 80068b54 80068b04 800683fc 80067d98
$24   : 00000008 00000000                  
$28   : 80818000 80819e40 80260000 800802b4
Hi    : 00000000
Lo    : 000027b0
epc   : 80080014 0x80080014
    Not tainted
ra    : 800802b4 0x800802b4
Status: 1000c003    KERNEL EXL IE 
Cause : 10800008
BadVA : 00000057
PrId  : 0001800a (MIPS 4Kc)
Modules linked in:
Process swapper (pid: 1, threadinfo=80818000, task=80817938, tls=00000000)
Stack : 00000000 00000000 00000000 80104a98 00008124 8029bd50 802ca9b8 00000000
        8029d370 800802b4 80819e68 80819e68 80819e68 8029e664 00000000 8029be2c
        802a0000 802ca9b8 802afcb8 00000000 00000000 00000000 00000000 00000000
        00000000 802afce4 80837180 000003a0 802ca71c 802ca9b8 802ca720 8004b330
        802a3900 00000080 802a0000 00000000 00000000 80091714 802ca714 802b8ec8
        ...
Call Trace:[<80104a98>] 0x80104a98
[<800802b4>] 0x800802b4
[<802afcb8>] 0x802afcb8
[<802afce4>] 0x802afce4
[<8004b330>] 0x8004b330
[<80091714>] 0x80091714
[<802b8ec8>] 0x802b8ec8
[<802aa33c>] 0x802aa33c
[<8004da3c>] 0x8004da3c
[<802aa26c>] 0x802aa26c
[<8004da2c>] 0x8004da2c


Code: 8008003b  80080044  8008004f <80080057> 00000000  00000000  80080068  80080069  6d656d73 
Disabling lock debugging due to kernel taint
Kernel panic - not syncing: Attempted to kill init!

comment:3 follow-up: Changed 7 years ago by florian

The kernel seems to be configured for 16MB of RAM, while IIRC DWL-2100AP only has 8MB of physical RAM available. Make sure that ar2315_prom_init detects it properly.

comment:4 in reply to: ↑ 3 Changed 7 years ago by vpritiskovic@…

Replying to florian:

The kernel seems to be configured for 16MB of RAM, while IIRC DWL-2100AP only has 8MB of physical RAM available. Make sure that ar2315_prom_init detects it properly.

NOT TRUE!!!!

I have downloaded svn repo an only thing I have changed one line in

spesa@adminator:~/openwrt/dwl$ cat ./target/linux/atheros/Makefile

LINUX_VERSION:=2.6.32.25 >>> LINUX_VERSION:=2.6.30.10

compiled, reflashed and it works flawless

Linux version 2.6.30.10 (spesa@adminator) (gcc version 4.3.3 (GCC) ) #1 Sun Nov 21 16:22:24 CET 2010
console [early0] enabled
CPU revision is: 0001800a (MIPS 4Kc)
Determined physical RAM map:
 memory: 01000000 @ 00000000 (usable)
Initrd not found or empty - disabling initrd
Zone PFN ranges:
  Normal   0x00000000 -> 0x00001000
Movable zone start PFN for each node
early_node_map[1] active PFN ranges
    0: 0x00000000 -> 0x00001000
On node 0 totalpages: 4096
free_area_init_node: node 0, pgdat 8027ef10, node_mem_map 802b7000
  Normal zone: 32 pages used for memmap
  Normal zone: 0 pages reserved
  Normal zone: 4064 pages, LIFO batch:0
Built 1 zonelists in Zone order, mobility grouping off.  Total pages: 4064
Kernel command line: console=ttyS0,9600 rootfstype=squashfs,jffs2
Primary instruction cache 16kB, VIPT, 4-way, linesize 16 bytes.
Primary data cache 16kB, 4-way, VIPT, no aliases, linesize 16 bytes
NR_IRQS:128
PID hash table entries: 64 (order: 6, 256 bytes)
console handover: boot [early0] -> real [ttyS0]
Dentry cache hash table entries: 2048 (order: 1, 8192 bytes)
Inode-cache hash table entries: 1024 (order: 0, 4096 bytes)
Memory: 13460k/16384k available (1972k kernel code, 2924k reserved, 329k data, 128k init, 0k highmem)
Calibrating delay loop... 179.81 BogoMIPS (lpj=899072)
Mount-cache hash table entries: 512
net_namespace: 528 bytes
NET: Registered protocol family 16
bio: create slab <bio-0> at 0
Switched to high resolution mode on CPU 0
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 512 (order: 0, 4096 bytes)
TCP bind hash table entries: 512 (order: -1, 2048 bytes)
TCP: Hash tables configured (established 512 bind 512)
TCP reno registered
NET: Registered protocol family 1
Radio config found at offset 0x10000(0x100)
squashfs: version 4.0 (2009/01/31) Phillip Lougher
Registering mini_fo version $Id$
JFFS2 version 2.2. (NAND) (SUMMARY)  © 2001-2006 Red Hat, Inc.
msgmni has been set to 26
io scheduler noop registered
io scheduler deadline registered (default)
gpiodev: gpio device registered with major 254
Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled
serial8250: ttyS0 at MMIO 0xbc000003 (irq = 37) is a 16550A
eth0: Atheros AR231x: 00:0f:3d:af:eb:05, irq 4
ar231x_eth_mii: probed
eth0: attached PHY driver [Generic PHY] (mii_bus:phy_addr=0:01)
physmap platform flash device: 00800000 at 1e000000
physmap-flash.0: Found 1 x16 devices at 0x0 in 8-bit bank
physmap-flash.0: Found an alias at 0x400000 for the chip at 0x0
 Amd/Fujitsu Extended Query Table at 0x0041
number of CFI chips: 1
cfi_cmdset_0002: Disabling erase-suspend-program due to code brokenness.
cmdlinepart partition parsing not available
Searching for RedBoot partition table in physmap-flash.0 at offset 0x3d0000
6 RedBoot partitions found on MTD device physmap-flash.0
Creating 6 MTD partitions on "physmap-flash.0":
0x000000000000-0x000000030000 : "RedBoot"
0x000000030000-0x000000100000 : "linux"
0x000000100000-0x0000003c0000 : "rootfs"
mtd: partition "rootfs" set to be root filesystem
mtd: partition "rootfs_data" created automatically, ofs=240000, len=180000 
0x000000240000-0x0000003c0000 : "rootfs_data"
0x0000003c0000-0x0000003c1000 : "RedBoot config"
0x0000003d0000-0x0000003e0000 : "FIS directory"
0x0000003e0000-0x000000400000 : "boardconfig"
eth0: Configuring MAC for full duplex
TCP westwood registered
NET: Registered protocol family 17
802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>
All bugs added by David S. Miller <davem@redhat.com>
VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
Freeing unused kernel memory: 128k freed
Please be patient, while OpenWrt loads ...
mini_fo: using base directory: /
mini_fo: using storage directory: /overlay
device eth0 entered promiscuous mode
br-lan: port 1(eth0) entering forwarding state
PPP generic driver version 2.4.2
ip_tables: (C) 2000-2006 Netfilter Core Team
NET: Registered protocol family 24
nf_conntrack version 0.5.0 (256 buckets, 1024 max)
ath_hal: module license 'Proprietary' taints kernel.
Disabling lock debugging due to kernel taint
ath_hal: 2009-05-08 (AR5212, AR5312, RF5111, RF5112, RF2316, RF2317, REGOPS_FUNC, TX_DESC_SWAP, XR)
ath_ahb: trunk
wlan: trunk
wlan: mac acl policy registered
ath_rate_minstrel: Minstrel automatic rate control algorithm 1.2 (trunk)
ath_rate_minstrel: look around rate set to 10%
ath_rate_minstrel: EWMA rolloff level set to 75%
ath_rate_minstrel: max segment size in the mrr set to 6000 us
Atheros HAL provided by OpenWrt, DD-WRT and MakSat Technologies
wifi0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
wifi0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi0: turboG rates: 6Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi0: H/W encryption support: WEP AES AES_CCM TKIP
ath_ahb: wifi0: Atheros 2313 WiSoC: mem=0xb8500000, irq=5
IRQ 5/wifi0: IRQF_DISABLED is not guaranteed on shared IRQs
device ath0 entered promiscuous mode
br-lan: port 2(ath0) entering forwarding state
br-lan: port 2(ath0) entering disabled state
br-lan: port 2(ath0) entering forwarding state


comment:5 Changed 7 years ago by Silvio Peša <vpritiskovic@…>

comment:6 Changed 7 years ago by Dmitry Skryabin <gig-tmb@…>

I all! I guess with topic starter, i have the same problem but on differ hardware.
I have Trendnet TEW-510APB

2x IC42S16400-7T = 32Mb SDRAM
Micronix MX29LV320CBTC-90G = 4Mb FLASH

I'll use kamikaze 8.09 with 2.6.26.5 - all work fine

I'll try compile & upgrade my system to backfire from branch last night
I'll try compile & upgrade from trunk (r25032)
& in both cases with diffreret kernels on startup i'll dont have kernel panic, but have the same error on mount rootfs

VFS: Cannot open root device "<NULL>" or unknown-block(31,2)
Please append a correct "root=" boot option; here are the available partitions:
1f00             192 mtdblock0 (driver?)
1f01            1648 mtdblock1 (driver?)
1f02            3648 mtdblock2 (driver?)
1f03             640 mtdblock3 (driver?)
1f04              64 mtdblock4 (driver?)
1f05               4 mtdblock5 (driver?)
1f06               4 mtdblock6 (driver?)
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(31,2)

but if I change in ./target/linux/atheros/Makefile
from LINUX_VERSIONS to LINUX_VERSION:=2.6.30.10
in both cases all startup fine

VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
eth0: Configuring MAC for full duplex
Freeing unused kernel memory: 124k freed
Please be patient, while OpenWrt loads ...
mini_fo: using base directory: /
mini_fo: using storage directory: /overlay
ip_tables: (C) 2000-2006 Netfilter Core Team

in redboot entry point ram on my board 0x80041000 like topic starter.
may be it's matter? )

comment:7 follow-up: Changed 7 years ago by jow

  • Priority changed from normal to response-needed

Is this still the case with RC5 ?

comment:8 Changed 7 years ago by nbd

  • Resolution set to no_response
  • Status changed from assigned to closed

comment:9 in reply to: ↑ 7 Changed 6 years ago by anonymous

  • Resolution no_response deleted
  • Status changed from closed to reopened

Replying to jow:

Is this still the case with RC5 ?

I can confirm RC5 works out of the box, sorry for late test and response I can post boot log if needed.

comment:10 follow-ups: Changed 6 years ago by jow

So it is fixed?

comment:11 in reply to: ↑ 10 Changed 6 years ago by anonymous

Replying to jow:

So it is fixed?

Yes, with backfire (2.6.30.10 kernel is ok) it is working out of the box since RC1, but trunk is different, please check
https://dev.openwrt.org/ticket/8299#comment:5

have not tested kernel 3.0 yet can do it tommorow...

comment:12 Changed 6 years ago by anonymous

Today I found out that trunk works out of the box wit DWL-2100AP - we just need to set boot script with command go; (before was exec and that was the problem all the time):

>> fis load -l linux
>> go

http://wiki.openwrt.org/toh/d-link/dwl-2100ap#install.openwrt

comment:13 in reply to: ↑ 10 Changed 6 years ago by anonymous

Replying to jow:

So it is fixed?

You can close this ticket, I don't know why exactly but changing the exec command in redboot script to go every build boots fine. Now, we can say this target is ported...

comment:14 Changed 6 years ago by jow

  • Resolution set to fixed
  • Status changed from reopened to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.