Modify

Opened 11 years ago

Closed 11 years ago

Last modified 4 years ago

#800 closed enhancement (fixed)

patches for WL-HDD support

Reported by: FlorianEchtler <floe@…> Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: kernel Version:
Keywords: wl-hdd 2.6 patches Cc:

Description

I've succeeded to get kamikaze running on the Asus WL-HDD (and compatibles).
It took two patches to get it up and running, the first one was suggested by mculibrk:

diff -Naur linux-2.6.17-old/arch/mips/bcm947xx/pci.c linux-2.6.17/arch/mips/bcm947xx/pci.c
--- linux-2.6.17-old/arch/mips/bcm947xx/pci.c   2006-09-28 18:46:18.000000000 +0200
+++ linux-2.6.17/arch/mips/bcm947xx/pci.c       2006-09-26 19:56:26.000000000 +0200
@@ -83,7 +83,7 @@
 static struct resource ext_pci_io_resource = {
        .name   = "Ext PCI I/O resources",
        .start  = 0x100,
-       .end    = 0x1FF,
+       .end    = 0x7FF,
        .flags  = IORESOURCE_IO,
 };

This fixes some errors during bootup where most PCI devices can't be initialized.

diff -Naur linux-2.6.17-old/drivers/mtd/maps/bcm47xx-flash.c linux-2.6.17/drivers/mtd/maps/bcm47xx-flash.c
--- linux-2.6.17-old/drivers/mtd/maps/bcm47xx-flash.c   2006-09-28 22:18:50.000000000 +0200
+++ linux-2.6.17/drivers/mtd/maps/bcm47xx-flash.c       2006-09-28 22:20:00.000000000 +0200
@@ -56,8 +56,8 @@

 #define ROUNDUP(x, y) ((((x)+((y)-1))/(y))*(y))
 #define NVRAM_SPACE 0x8000
-#define WINDOW_ADDR 0x1c000000
-#define WINDOW_SIZE 0x800000
+#define WINDOW_ADDR 0x1fc00000
+#define WINDOW_SIZE 0x400000
 #define BUSWIDTH 2

 static struct mtd_info *bcm947xx_mtd;

This fixes the much more serious problem of eternal reboots, caused by the MTD driver trying to access the flash chip at the wrong location. The offsets were taken from the 2.4 branch which works. However, this could propably lead to problems on other routers, maybe a kernel config flag for the WL-HDD would be in order. Can somebody from the kernel gurus shed some light on why these offsets were changed?

Attachments (2)

bcm47xx-flash.diff (565 bytes) - added by FlorianEchtler <floe@…> 11 years ago.
patch for bcm47xx-flash.c
pci.diff (444 bytes) - added by FlorianEchtler <floe@…> 11 years ago.
patch for pci.c

Download all attachments as: .zip

Change History (4)

Changed 11 years ago by FlorianEchtler <floe@…>

patch for bcm47xx-flash.c

Changed 11 years ago by FlorianEchtler <floe@…>

patch for pci.c

comment:1 Changed 11 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

fixed in [5134]

comment:2 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.