Modify

Opened 7 years ago

Closed 5 years ago

Last modified 4 years ago

#7971 closed defect (wontfix)

Backfire - WRT54G v1.1 - Can't boot

Reported by: Gilles Filippini <gilles.filippini@…> Owned by: developers
Priority: response-needed Milestone: Chaos Calmer 15.05
Component: base system Version: Trunk
Keywords: Cc:

Description

Hi,

Backfire 10.03 and 10.03.1-rc3 don't boot correctly on a WRT54G v1.1.

When the device reboots just after flashing, the DMZ led stays on and the Power led keeps flashing. The same occurs on further reboots.

Flashing back with Kamikaze restores a usable device.

See this forum thread for details:
<https://forum.openwrt.org/viewtopic.php?id=24216>

Attachments (1)

out.TXT (8.5 KB) - added by anonymous 7 years ago.
serial output of "broken" wrt54

Download all attachments as: .zip

Change History (9)

Changed 7 years ago by anonymous

serial output of "broken" wrt54

comment:1 Changed 7 years ago by anonymous

ive had a similar problem (see here). seems that the current 2.6 driver is not usable yet.

comment:2 Changed 7 years ago by jow

1) The device will eventually finish booting, just wait
2) Do you have "wlan0" in your network config? If yes remove it and utilize "option network" in the wireless config instead

comment:3 follow-up: Changed 7 years ago by Gilles Filippini <gilles.filippini@…>

I forgot to mention that this bug refers to the brcm-2.4 image.

BTW, waiting for the boot to finish won't help: I've already waited for 24 hours without success...

comment:4 in reply to: ↑ 3 Changed 7 years ago by nico

  • Priority changed from high to response-needed

Replying to Gilles Filippini <gilles.filippini@…>:

I forgot to mention that this bug refers to the brcm-2.4 image.

Well, the serial output you attached is from a 2.6 image. Can you elaborate on what you tested exactly ?

comment:5 Changed 7 years ago by Gilles Filippini <gilles.filippini@…>

My bug report refers to brcm-2.4 only. While I forgot to mention it in the report, the linked forum thread states that clearly.

I need the brcm-2.4 image because of its WDS "one to many" capability.

I'm not the one who attached the serial output.

I've tried every backfire prebuild brcm-2.4 images from 10.03-beta to 10.03.1-rc3. The problem appears with 10.03-rc2 and remain unfixed in subsequent releases.

I've also tried building from svn between 10.03-rc1 and 10.03 and had a different result: the problem appears around commit svn20728 then.

Thanks.

comment:6 Changed 7 years ago by kjell.krohn@…

Tried today with svn25469, but the bug is still there.

What happens is this:

  1. Put in the power-plug.
  2. Bootloader answers to ping, then stops.
  3. Power-light starts blinking, DMZ light comes on. -and then nothing more happens. Doesn't answer to ping.

Can however enter failsafe mode just fine, by pressing the reset-button on the back.
Ran firstboot and rebooted, but it doesn't help.

Kind regards,
Kjell

comment:7 Changed 5 years ago by florian

  • Resolution set to wontfix
  • Status changed from new to closed

brcm-2.4 is no longer supported.

comment:8 Changed 4 years ago by jow

  • Milestone changed from Backfire 10.03.2 to Chaos Calmer (trunk)

Milestone Backfire 10.03.2 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.