Modify

Opened 7 years ago

Closed 6 years ago

Last modified 5 years ago

#7940 closed defect (invalid)

produce libpcap and tcpdump packages for backfire

Reported by: Brian J. Murrell <brian@…> Owned by: developers
Priority: high Milestone: Backfire 10.03.1
Component: packages Version: Backfire 10.03 RC3
Keywords: Cc:

Description

Currently, there doesn't appear to be libpcap and tcpdump packages for backfire. I wonder why these were not produced.

Could we please have them available? They are indispensable for debugging network problems.

Thanx.

Attachments (0)

Change History (8)

comment:1 Changed 7 years ago by markus_kubler@…

There is the package "tcpdump - 4.0.0-3". I installed it using:
opkg install tcpdump months ago; it works as expected.

There package "libpcap - 1.0.0-2" is also existent.
opkg list | grep libpcap

Or is this ticket spam? => close

comment:2 Changed 7 years ago by jow

  • Resolution set to worksforme
  • Status changed from new to closed

As pointed out, the packages exist for all arches.

comment:3 Changed 7 years ago by Joachim Lindenberg <joachim.lindenberg@…>

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Hello,
I am not the original ticket author, but I also would like to use tcpdump and it looks like it is not included in my copy of OpenWRT. I am using a Netgear WNDR3700 with Backfire 10.03, r20728, openwrt-ar71xx-wndr3700-jffs2-factory.img.
when I do "opkg list | grep libpcap" there is no output, and "opkg install libpcap" returns "* opkg_install_cmd: Cannot install package libpcap.".
Please advise.
Thanks & Best regards, Joachim

comment:4 Changed 7 years ago by jow

  • Resolution set to invalid
  • Status changed from reopened to closed

Run opkg update. This is no support channel!

comment:5 Changed 6 years ago by pontiferous

  • Resolution invalid deleted
  • Status changed from closed to reopened

Confirmed;

0) Fresh install of OpenWRT Backfire 10.03.1-rc5,
1) Clicking 'update package lists' in user interface, then:
2) You cannot find 'tcpdump' in the package list in LuCi using the filter box.
3) You cannot install 'tcpdump' with 'opkg install tcpdump'.

Then:

4) Run 'opkg update'
5) Run 'opkg install tcpdump'

Now both tcpdump and libpcap installs correctly.

comment:6 Changed 6 years ago by Paul "TBBle" Hampson <Paul.Hampson@…>

Same issue with rc6 (x86 generic combined image)

After running opkg update manually, tcpdump and tcpdump-mini are visible in LuCi software available list.

comment:7 Changed 6 years ago by jow

  • Resolution set to invalid
  • Status changed from reopened to closed

Not sure why this ticket got reopened, apparently there is no issue at all.

comment:8 Changed 5 years ago by anonymous

Had the same issue.

  • Installed 10.03.1
  • opkg update
  • opkg install ... (several packages)

Powering down. waited some days. powering on

  • opkg install tcpdump --> failed
  • opkg update
  • opkg install tcpdump --> installs correctly

I think, the package-list is not saves in flash.

Sorry for reopening. but this might be the best way I found to share my experiences (yes, I tried the search funktion)

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.