Modify

Opened 7 years ago

Closed 7 years ago

#7890 closed defect (invalid)

ser2net no longer works with 10.03.1-rc3, works ok with 10.03

Reported by: ari@… Owned by: developers
Priority: normal Milestone: Backfire 10.03.1
Component: kernel Version: Backfire 10.03.1 RC2
Keywords: ser2net Cc:

Description

I have been using ser2net on OpenWrt backfire to access my weather station. I have D-link DIR-825 (ar71xx).

With openwrt 10.03 release it works without problems (ie. kmod-usb-serial-ftdi + ser2net).

With 10.03.1-rc3 it no longer works. kmod-usb-serial-ftdi still works, I have been able to verify that with "microcom" program. Also, ser2net version is same (2.7-2).

In rc3, the ser2net still starts and I'm able to connect to it via network, but no data is passed between serial port and network.

Attachments (0)

Change History (3)

comment:1 Changed 7 years ago by ari@…

In 2.6.32.16 kernel there is a change:

"Daniel Mack (1): USB: ftdi_sio: fix DTR/RTS line modes"

Maybe the problem is related to this, since the change affects ftdi module I'm using.

comment:2 Changed 7 years ago by ari@…

Explanation here:
http://www.listware.net/201008/linux-usb/23081-ftdisio-serial-adapter-data-toggle-problem.html

The fix in ftdi driver required ser2net to be configured differently, ie. I was wrong when I had -RTSCTS in ser2net configuration file. Changed that and everything works.

Please close this ticket.

comment:3 Changed 7 years ago by acoul

  • Resolution set to invalid
  • Status changed from new to closed

thanks for the feedback

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.