Modify

Opened 7 years ago

Closed 7 years ago

#7880 closed defect (duplicate)

Selected TP-LINK TL-WR941ND as target, but got images for TL-WR941ND ...

Reported by: robertchanlist@… Owned by: developers
Priority: normal Milestone: Backfire 10.03.1
Component: kernel Version: Backfire 10.03
Keywords: Cc:

Description

First, I tried to build backfire for my TP-Link TL-WR741ND, it failed with the following error:

....................
arch/mips/ar71xx/built-in.o: In function `ap91_eth_init':
(.init.text+0x13b8): undefined reference to `ar71xx_add_device_dsa'
arch/mips/ar71xx/built-in.o: In function `ap91_eth_init':
(.init.text+0x13b8): relocation truncated to fit: R_MIPS_26 against `ar71xx_add_device_dsa'
make[5]: * [vmlinux] Error 1
......................

Then I tried to build it again for my TL-WR941ND (by changing the target to TL-WR941ND and nothing else), the build was successful.

However, very surprisingly, when I look into the bin folder, I found that I actually got the images for TP-Link TL-WR741ND:

md5sums
openwrt-ar71xx-rootfs.tar.gz
openwrt-ar71xx-root.jffs2-128k
openwrt-ar71xx-root.jffs2-64k
openwrt-ar71xx-root.squashfs
openwrt-ar71xx-root.squashfs-4k
openwrt-ar71xx-tl-wr741nd-v1-squashfs-factory.bin
openwrt-ar71xx-tl-wr741nd-v1-squashfs-sysupgrade.bin
openwrt-ar71xx-uImage-gzip.bin
openwrt-ar71xx-uImage-lzma.bin
openwrt-ar71xx-vmlinux.bin
openwrt-ar71xx-vmlinux.elf
openwrt-ar71xx-vmlinux.gz
openwrt-ar71xx-vmlinux.lzma
packages

In order to confirm this, I removed the entire bin folder, and build again (double-checked that I have selected TL-WR941ND as my target platform, I still got the same thing (i.e. images for TL-WR741ND).

But when I select TL-WR741ND as my target, it failed to build!

Is this a bug? Should I now use the image obtained (i.e. openwrt-ar71xx-tl-wr741nd-v1-squashfs-factory.bin) in my TL-WR741ND or my TL-WR941ND? The last thing I want to see is to load an incorrect image into the router and brick it.

Please help.

Regards,

Robert.

Attachments (0)

Change History (2)

comment:1 Changed 7 years ago by anonymous

Sorry the title should really be:

"Selected TP-LINK TL-WR941ND as target, but got images for TL-WR741ND ..."

comment:2 Changed 7 years ago by swalker

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #7881.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.