Modify

Opened 7 years ago

Closed 7 years ago

#7860 closed defect (duplicate)

package/ncurses does not build

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Backfire 10.03.1
Component: packages Version: Trunk
Keywords: Cc:

Description

using git://nbd.name/openwrt.git on a 64bit opensuse 11.3 I just build
openwrt for kirkwood (dockstar).

ncurses was the only package which did not build. applying all patches failed, because the source files in the dl/ncurses-5.7.tar.gz are read-only, so patch complained about (not) overwriting read-only files and stopped.

this is the patch version in opensuse 11.3:

rpm -q patch
patch-2.6.1.81-1.6.x86_64

and below is my hack for the ncurses Makefile to get it compiled...
what's the right place and way to handle such problems ?

diff --git a/package/ncurses/Makefile b/package/ncurses/Makefile
index cbbb098..3327fa1 100644
--- a/package/ncurses/Makefile
+++ b/package/ncurses/Makefile
@@ -67,6 +67,14 @@ MAKE_FLAGS += \
        HOSTCCFLAGS="" \
        libs
 
+define Build/Prepare
+       rm -rf $(PKG_BUILD_DIR)
+       mkdir -p $(PKG_BUILD_DIR)
+       tar xzvf $(DL_DIR)/$(PKG_SOURCE) -C $(PKG_BUILD_DIR)/..
+       chmod -R +w $(PKG_BUILD_DIR)/
+       $(Build/Patch)
+endef
+
 define Build/Install/Default
        $(MAKE_VARS) \
        $(MAKE) -C $(PKG_BUILD_DIR)/$(MAKE_PATH) \

Attachments (0)

Change History (3)

comment:1 Changed 7 years ago by koenig@…

forgot to set/add my email address...

comment:2 Changed 7 years ago by ledwards@…

This is a duplicate of ticket 7745:
/ticket/7745.html

comment:3 Changed 7 years ago by nbd

  • Resolution set to duplicate
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.