Modify

Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#7840 closed defect (duplicate)

(RDC) WARNING: at arch/x86/mm/ioremap.c:148

Reported by: Bifferos Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: kernel Version: Trunk
Keywords: ioremap.c warning kernel Cc:

Description

I get this warning during boot, tested Kamikaze r22844 on RDC321x, Bifferboard profile.

relevant part of Bootlog is as follows:

platform rtc_cmos: registered platform RTC device (no PNP device found)
------------[ cut here ]------------
WARNING: at arch/x86/mm/ioremap.c:148 __ioremap_caller+0xc7/0x26f()
Modules linked in:
Pid: 1, comm: swapper Not tainted 2.6.32.20 #1
Call Trace:
 [<c010988f>] ? __ioremap_caller+0xc7/0x26f
 [<c0110747>] ? warn_slowpath_common+0x43/0x56
 [<c0110764>] ? warn_slowpath_null+0xa/0xc
 [<c010988f>] ? __ioremap_caller+0xc7/0x26f
 [<c02b93a0>] ? crashlog_init_fs+0x0/0x79
 [<c0109af8>] ? ioremap_nocache+0xd/0xf
 [<c02b93b9>] ? crashlog_init_fs+0x19/0x79
 [<c02b93b9>] ? crashlog_init_fs+0x19/0x79
 [<c0101043>] ? do_one_initcall+0x43/0x11f
 [<c02b23e3>] ? kernel_init+0x79/0xc7
 [<c02b236a>] ? kernel_init+0x0/0xc7
 [<c0102d57>] ? kernel_thread_helper+0x7/0x10
---[ end trace a7919e7f17c0a725 ]---

Attachments (2)

bootlog.txt (8.0 KB) - added by bifferos 7 years ago.
Bootlog
rdc-crashlog.patch (335 bytes) - added by bifferos 7 years ago.
Disable crashlog for RDC

Download all attachments as: .zip

Change History (9)

Changed 7 years ago by bifferos

Bootlog

comment:1 Changed 7 years ago by bifferos

I've tried some different versions:

r22299 is good.
r22688 has the bug

comment:2 Changed 7 years ago by bifferos

r22412 seems broken as well.

comment:3 Changed 7 years ago by bifferos

I *think* this happened at rev 22305, but it's getting late, and I wasn't doing rebuilds every time.

comment:4 Changed 7 years ago by anonymous

Same problem on a backfire@22752 on soekris 4501

Changed 7 years ago by bifferos

Disable crashlog for RDC

comment:5 Changed 7 years ago by bifferos

Simply disabling the crashlog removed the warning. I've attached a patch to do this for RDC, but quite possibly it should be applied to the generic 2.6.32 config instead. I had a brief look but the crashlog code is a closed book to me, and I've no idea why it triggers the warning.

comment:6 Changed 7 years ago by nbd

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #7732

comment:7 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.