Modify

Opened 7 years ago

Closed 6 years ago

#7836 closed defect (fixed)

DG834Gv2 switch broken in 10.03.1-rc3

Reported by: KillaB Owned by: florian
Priority: normal Milestone: Backfire 10.03.1
Component: base system Version:
Keywords: Cc:

Description

I'm able to obtain a DHCP lease on RC2, but my client sees no traffic from the switch on RC3.

Also, I'm puzzled by the closing of ticket #99 since I still only see eth0 and eth1, not eth0.0 and eth0.1 as one might expect with switch driver support....or am I misunderstanding the concept?

Attachments (0)

Change History (13)

comment:1 Changed 7 years ago by florian

  • Owner changed from developers to florian
  • Status changed from new to accepted

switch drivers are swconfig enabled switch drivers, so they will not create vlans automatically like this unless you create them. This has nothing to do like the usual brcm47xx/brcm-2.4 switch configurations. I will need a bootlog of your device to diagnose the problem. Thanks!

comment:2 Changed 7 years ago by KillaB

Thanks for the driver clarification.

Here's a bootlog:
http://openwrt.pastebin.com/EjpzfhkX

And another after running firstboot:
http://openwrt.pastebin.com/DzUanYXV

comment:3 Changed 7 years ago by KillaB

Are [22849] and [22850] meant to fix this problem, and if so, will they be rolled into an rc4 release of 10.03.1 for testing?

comment:4 Changed 7 years ago by florian

They will be rolled in rc4 and the final release, though the patch trying to address all the issues is still work in progress.

comment:5 Changed 7 years ago by anonymous

Original problem still exists in 10.03.1-rc4.
Plenty of Rx bytes on eth0 (from my PC trying to obtain an IP), but nothing on br-lan.
Disabled the firewall, still nothing. Noticed /lib/network/switch.sh was not executable. Not sure if that's by design or not? Changed permissions to 755 and rebooted; still nothing.

Let me know if there's anything else you'd like me to try.

Is the default /etc/config/network file no longer valid due to the following change?

"Backfire 10.03.1-rc3
Changes since Backfire 10.03.1 RC2:

  • Switch drivers enabled on ar7"

comment:6 Changed 7 years ago by KillaB

Any chance [24139] thru [24142] might fix this issue?

comment:7 Changed 7 years ago by florian

Will backport them

comment:8 Changed 7 years ago by KillaB

Sorry to be impatient, but I'm just curious if there are any updates on this.
I haven't seen anything more than a kernel version bump in the past seven weeks.

comment:9 Changed 7 years ago by Simon Iremonger <wiltslug@…>

KillaB --

If this is the same problem I am finding -- Do you by any chance find that the ethernet port externally labelled #4, works correctly, just the other 3 no longer usable?

Thanks,
--Simon

comment:10 Changed 7 years ago by KillaB

It's a fair guess, but I didn't actually test each port.
I've since reloaded 8.09.2

comment:11 Changed 7 years ago by Simon Iremonger <wiltslug@…>

As per another thread, testing 'r25675' as florian requested.

I compiled for ar7 and kept binaries here for anybody else who wants that particular release (you might be better with current trunk however:-
http://hermes.enyc.org.uk/openwrt-2011-02-23-r25675/

It now *works* with all 4 ethernet switch ports (on DG834Gv3, same switch as DG834Gv2).
I have my native-ipv6 on DSL working and all 4 ethernet ports working.

The serial console works *better* -- it no longer garbles, get linux kernel messages and "press any key to use this console" message are ok, but pressing anything appears to return a space-character and not work. (The pspboot bootloader is fine, I know my ttl serial interface is ok).

comment:12 Changed 7 years ago by SimonIremonger

Briefly,
I provide a recent backfire build which excludes the problematic 970-972 kernel patches that cause the issue, and does not include 'swconfig' out of the box either.
http://openwrt.enyc.org.uk/openwrt/backfire-2011-07-30-r27838/
(make sure you read "Simon-Notes.txt").
This build does work on ADSL+Ethernet on a DG834Gv3 (same switch same problem), but I have not yet tested wireless functionality.
p.s. Serial Console (I seem to have had issues with previously) works fine on cold-boots, now.

comment:13 Changed 6 years ago by florian

  • Resolution set to fixed
  • Status changed from accepted to closed

Fixed with r29241.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.