Modify

Opened 7 years ago

Closed 7 years ago

#7796 closed defect (fixed)

FFmpeg return no such file or directory converting a file

Reported by: ramponis <ramponis@…> Owned by: developers
Priority: normal Milestone: Backfire 10.03.1
Component: packages Version: Trunk
Keywords: Cc:

Description

ffmpeg -y -i /mnt/sdb/share/In/test.dvr-ms -vcodec copy -acodec copy -f dvd /mnt/sdb/share/Out/test.mpg
FFmpeg version 0.5.2, Copyright (c) 2000-2009 Fabrice Bellard, et al.

configuration: --enable-cross-compile --cross-prefix=i486-openwrt-linux-uclibc- --arch=i386 --prefix=/usr --enable-shared --enable-static --disable-debug --enable-gpl --disable-libfaad --disable-mmx --disable-mmx2 --enable-pthreads --disable-optimizations --enable-small --disable-stripping --disable-vhook --enable-zlib --enable-postproc --disable-bsfs --disable-devices --disable-encoders --disable-decoders --enable-decoder=ac3 --enable-decoder=atrac3 --enable-decoder=h264 --enable-decoder=jpegls --enable-decoder=mp3 --enable-decoder=mpeg1video --enable-decoder=mpeg2video --enable-decoder=mpeg4 --enable-decoder=mpeg4aac --enable-decoder=mpegvideo --enable-decoder=png --enable-decoder=wmav1 --enable-decoder=wmav2 --enable-decoder=zlib --disable-muxers --enable-muxer=ffm --disable-demuxers --enable-demuxer=ac3 --enable-demuxer=ffm --enable-demuxer=h264 --enable-demuxer=mp3 --enable-demuxer=mpegts --enable-demuxer=mpegvideo --enable-demuxer=rm --enable-demuxer=rtsp --enable-demuxer=sdp --disable-parsers --enable-parser=ac3 --disable-protocols --enable-protocol=rtp --enable-protocol=udp
libavutil 49.15. 0 / 49.15. 0
libavcodec 52.20. 1 / 52.20. 1
libavformat 52.31. 0 / 52.31. 0
libavdevice 52. 1. 0 / 52. 1. 0
libpostproc 51. 2. 0 / 51. 2. 0
built on Jul 13 2010 08:53:28, gcc: 4.1.2

/mnt/sdb/share/In/test.dvr-ms: no such file or directory

Attachments (0)

Change History (4)

comment:1 Changed 7 years ago by gsedej@…

Same here. No matter what you set as "-i", nothing works

comment:2 Changed 7 years ago by anonymous

Same problem here. I'm trying to use ffmpeg with pytivo to push files from a hard drive connected to my Buffalo WZR-HP-G300NH. I got everything up and running, but encountered an error when trying to actually do the push and tracked it back to a non-functional ffmpeg. I don't need transcoding, it just needs to use ffmpeg to get information about the video file (I believe it is failing when it tries to figure out the length of the file). I realize there must be another way to get the file information that it needs since all I need to do is push the file untouched, but I'm not the author and don't want to try to re-invent the wheel.

When trying to mess with ffmpeg directly, I get the same "no such file or directory" error reported above no matter what input is given.

I'd really appreciate a functional build or a pointer on how to cross-compile a basic build myself from OS X.

comment:3 Changed 7 years ago by anonymous

You're missing "--enable-protocol=file".
You can use the patch from: /ticket/8831.html

comment:4 Changed 7 years ago by jow

  • Resolution set to fixed
  • Status changed from new to closed

ffmpeg has the file protocol enabled, therfore I assume it is fixed with RC5.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.