Modify

Opened 7 years ago

Closed 7 years ago

#7774 closed defect (fixed)

wpa_supplicant.sh - compares PEAP with peap... creates invalid conf file

Reported by: Nachum Kanovsky <nachumk@…> Owned by: jow
Priority: high Milestone: Backfire 10.03.1
Component: packages Version: Trunk
Keywords: Cc:

Description

I'm using the current trunk version on the WRT54GL. I configured my wireless using LUCI and set it to Client, WPA2-EAP, PEAP, and MSCHAPV2.

I noticed that the /var/run/wpa0...conf file is created from /lib/wifi/wpa_supplicant.sh. The problem is that /etc/config/wireless has eap set to PEAP and the compare in wpa_supplicant.sh is 'case eap' in 'peap|ttls' which doesn't match due to the config being capitalized and the compare being lowercase. When I change peap to PEAP in wpa_supplicant.sh it does much better.

I still have issues connecting, but this is seems to be a bug somewhere. Either in LUCI or wpa_supplicant.sh.

Thanx

Attachments (0)

Change History (2)

comment:1 Changed 7 years ago by jow

  • Owner changed from developers to jow
  • Status changed from new to accepted

comment:2 Changed 7 years ago by jow

  • Resolution set to fixed
  • Status changed from accepted to closed

This is fixed in RC5.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.