Modify

Opened 8 years ago

Closed 6 years ago

Last modified 4 years ago

#7698 closed defect (fixed)

hotplug.d/button stops working after turning on wifi.

Reported by: alex.barakin@… Owned by: juhosg
Priority: normal Milestone: Chaos Calmer 15.05
Component: other Version: Trunk
Keywords: hotplug buttons wifi wl500gpv2 Cc:

Description

device: asus wl500gpv2

target system: bcm947xx/953xx (2.6)

config: all defaults

after enabling wifi hotplug2 generates some misterious events (catched with script in /etc/hotplug.d/button):

Thu Jan  1 00:06:48 UTC 1970 button=reset action=pressed
Thu Jan  1 00:06:48 UTC 1970 button=ses action=pressed
Thu Jan  1 00:06:54 UTC 1970 button=ses action=released
Thu Jan  1 00:06:54 UTC 1970 button=reset action=released
Thu Jan  1 00:06:54 UTC 1970 button=reset action=pressed
Thu Jan  1 00:06:54 UTC 1970 button=ses action=pressed

after that the real buttons cease to generate events.

note that there no "released" events.

interesting fact. after:

# echo -n $(cat /proc/diag/gpiomask) > /proc/diag/gpiomask

these "deffered" events are triggered:

Thu Jan  1 00:07:43 UTC 1970 button=ses action=released
Thu Jan  1 00:07:44 UTC 1970 button=reset action=released

and real buttons are also beginning to work.

bug discovered after an attempt to make it work package utilities/restorefactory.

Attachments (2)

mac80211.sh.patch (547 bytes) - added by alex.barakin@… 7 years ago.
restorefactory.patch (1.1 KB) - added by alex.barakin@… 7 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 7 years ago by alex.barakin@…

after some tests i saw that events triggered while hostapd called.
workaround attached.

also attached patch for utils/restorefactory (increase interval to 10sec).

Changed 7 years ago by alex.barakin@…

Changed 7 years ago by alex.barakin@…

comment:2 Changed 7 years ago by nunojpg

  • Owner changed from developers to juhosg
  • Status changed from new to assigned

comment:3 Changed 6 years ago by daniel@…

I can confirm, that this bug is still present!
I used trunk from 2012-02-03 (Linux 3.0.17 #6 Fri Feb 3 15:24:20 CET 2012 mips GNU/Linux).

When I do
echo -n $(cat /proc/diag/gpiomask) > /proc/diag/gpiomask
it magically works again.

comment:4 Changed 6 years ago by radek.nemec

Seems to be fixed in trunk (31853).

comment:5 Changed 6 years ago by jow

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:6 Changed 4 years ago by jow

  • Milestone changed from Backfire 10.03.2 to Chaos Calmer (trunk)

Milestone Backfire 10.03.2 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.