Modify

Opened 8 years ago

Closed 7 years ago

Last modified 3 years ago

#7689 closed defect (fixed)

not load transmission torrents with files >2Gb on x86 router

Reported by: Andrey Popov <admin@…> Owned by: developers
Priority: normal Milestone: Backfire 10.03.1
Component: packages Version: Trunk
Keywords: Cc:

Description

OpenWRT backfire
x86 router
ext3 file system
Transmission torrent client

cannot load torrent with files over 2Gb - invalid argument error in Transmission Web GUI display

if try Verify Local Data than verifying only 2Gb and invalid argument error in Web GUI display

transmission-remote -n succefully create torrent with files over 2Gb but .... Verify Local Data than verifying only 2Gb and invalid argument error in Web GUI display

Samba copy normaly large file, inside router also copy large file.

Transmission version from 1.91 to 2.03 - same error.

where find problem?

Attachments (1)

transmisson_error.png (464.2 KB) - added by anonymous 7 years ago.

Download all attachments as: .zip

Change History (29)

comment:1 Changed 8 years ago by cezary@…

Did you try recompile transmission with --enable-largefile option?

comment:2 Changed 8 years ago by Andrey Popov <admin@…>

I use compiled image and packages from repository

comment:3 Changed 8 years ago by Andrey Popov <admin@…>

and transmission-remote -n succefully create torrent with files over 2Gb but
if transmission-remote -a with this created torrent than error

comment:4 Changed 7 years ago by obsy <cezary@…>

I cannot confirm this. backfire 10.03.1-rc1/ar71xx, transmission 2.04, disk with ext2 filesystem - debian dvd iso1 - 4.36GB - downloaded without problem.
Verification also works.

comment:5 follow-up: Changed 7 years ago by nico

Can anyone give it a try with 10.03.1-rc1 on x86 ?

comment:6 in reply to: ↑ 5 Changed 7 years ago by anonymous

Replying to nico:

Can anyone give it a try with 10.03.1-rc1 on x86 ?

I can confirm that for trunk svn 22705 the problem exists for the x86 build, ar71xx works fine, I tested with a 6GB mkv torrent.

Transmission web interface reports

Error: Value too large for defined data type (/mnt/sda1/transmission/done/...

and the download stops.

I tried the x86 kernel default configuration and my custom pentium 4 /no math emulation/ smp config on a pentium 4 dual core box.

The ar7xx box is a tplink 1043-nd.

comment:7 Changed 7 years ago by Andrey Popov <admin@…>

problem exist on my x86 router during all BackFire build begining 10.03-beta, 10.03-rc1, 10.03-rc2, 10.03-rc3 and 10.03 final and remain on 10.03.1-rc1.

  • Samba copy large file by net
  • mc copy large file inside router

one problem also - wget - when it get large file then it show progress 100% at 2Gb point, but contiunue get until whole file copied.

comment:8 Changed 7 years ago by admin@…

root@cs-internet-app:/mnt# wget ftp://195.24.153.102/torrents/xpmce_july_2010/xp
_sp3_mce_july2010.iso
Connecting to 195.24.153.102 (195.24.153.102:21)
xp_sp3_mce_july2010. 100% |*| 3874M --:--:-- ETA

but wget show 100% at 1902M but continue copy until whole 3874M copied.

comment:9 Changed 7 years ago by admin@…

transmission developer says:
https://trac.transmissionbt.com/ticket/3536

My guess is that your copy of Transmission was built without largefile support. If so, that's a packaging issue that needs to be addressed by the people who packaged your copy of Transmission.

comment:10 Changed 7 years ago by obsy <cezary@…>

comment:11 Changed 7 years ago by anonymous

NOT SOLVE problem!!!!
same error

comment:12 Changed 7 years ago by obsy <cezary@…>

So, search problem somewhere in x86 target.

Changed 7 years ago by anonymous

comment:13 Changed 7 years ago by AndreyPopov

but where search problem?????

samba3 work with large files
ctorrent work with same torrent and same file location

comment:14 Changed 7 years ago by ramponis <ramponis@…>

The problem is not fixed in the last snapshot

http://downloads.openwrt.org/snapshots/ … -2_x86.ipk
http://downloads.openwrt.org/snapshots/ … -2_x86.ipk

it works on other platform (tested on bcrm63xx)

comment:15 Changed 7 years ago by anonymous

already three users that acknowlegment problem

but where problem?

comment:16 Changed 7 years ago by admin@…

http://trac.transmissionbt.com/ticket/3536#comment:12

where I can find sizeof(off_t) ??????

comment:17 Changed 7 years ago by jow

It is 8 on OpenWrt. We use large file support which means off_t is uint64_t which equals to eight bytes.

comment:18 Changed 7 years ago by admin@…

like this:
/ticket/8166.html

may be problem of transmission with large file in uClibc library?

comment:19 Changed 7 years ago by admin@…

probaly problem gone with trunk 24843

now testing more and more.......

comment:20 Changed 7 years ago by mandgeo@…

Same problem here. I'm using backfire 10.03.1-rc4 X86.

"Invalid argument (inout.c:159)" is what i get when i run the daemon in the foreground and "Value too large for defined data type" in transmission web interface.

I hope that i will automatically get the next messages on this ticket. Maybe a solution will appear.

comment:21 Changed 7 years ago by admin@…

since trunk build 24843 my problem gone!

backfire 10.03.1-rc4 is build 24045.

comment:22 Changed 7 years ago by anonymous

I don't understand what you are trying to say. The latest Openwrt available is backfire 10.03.1-rc4. That's what it says on the first page of openwrt.org, that's what i see in the download folder of backfire.

From where could i get build 24843 for X86? http://downloads.openwrt.org/snapshots/trunk/x86/openwrt-x86-generic-combined-ext4.img.gz ...This is the file?

comment:23 Changed 7 years ago by anonymous

Just recompile current version of Backfire. -rc4 is 24045 build, old.

comment:24 Changed 7 years ago by admin@…

you're right. snapshots folder. now it contain build 25080

comment:25 Changed 7 years ago by mandgeo

Thanks!

comment:26 Changed 7 years ago by jow

  • Resolution set to fixed
  • Status changed from new to closed

I assume this is fixed in RC5.

comment:27 Changed 3 years ago by anonymous

i have the same problem and i don't understand what are you talking about,.. ok i quit

comment:28 Changed 3 years ago by anonymous

i have the same problem and i don't understand what are you talking about,.. ok i quit

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.