Modify

Opened 8 years ago

Closed 7 years ago

#7687 closed defect (fixed)

ppp0 interface does not automatically goes UP on device's boot

Reported by: User294 Owned by: developers
Priority: response-needed Milestone: Backfire 10.03.1
Component: base system Version: Backfire 10.03
Keywords: Cc: t3st3r@…

Description

To reproduce:
1) Install OpenWRT Backfire to some supported device. I'm tried at least 2 supported targets: Atheros AR71xx aka Ubiquiti RouterStation and brcm47xx aka Asus WL500GP router.
2) Configure some PPP-based interface. Tested with at least PPtP and PPPoE.
3) Set up connections via web face as usually. Activate PPP link, etc. Make sure that your setup could work and PPP link works.
4) Reboot device. Ensure that only physical interfaces are brought UP. PPP interface is not activated. There is no settings in web face as well.

Result:

PPP link not re-established upon reboot and there is no settings in web face to do it. Some ISPs are using PPP-based links for customers so such behavior makes OpenWRT quite user-unfriendly in some setups.

Workaround:

User can issue ifup command manually for appropriate interfaces group. It's also possible to add ifup to startup scripts.

Expected:

Ideally, there should be option to connect PPP-based connections automatically (or manually otherwise). If automatic connect enabled, PPP link should be brought UP upon device boot.

Attachments (0)

Change History (4)

comment:1 Changed 8 years ago by jow

Please try current trunk or recent backfire branch, I believe this is fixed already.

comment:2 Changed 7 years ago by nico

  • Priority changed from normal to response-needed

Can you confirm this issue is still present in 10.03.1-rc1 ?

comment:3 Changed 7 years ago by User294

Currently I have some much worse troubles with 10.03.1-rc3 on my hardware which deals with PPPoE link right now (Ubiquiti RouterStation), so I guess I have to deal with these issues first to get 10.03.1-* anyhow usable and stable :(. Looks like I have to figure out settings that will work for me and file a bug(s). Right now RS locks up soon after uploading firmware image and then I have no further option than to reflash device again, as even reboot does not helps too much (device co9mpletely stops responding via network, so I have to resort to boot loader recovery). Looks like some of my settings are causing troubled, I have to investigate this first to get device into usable alive state, I guess.

comment:4 Changed 7 years ago by jow

  • Resolution set to fixed
  • Status changed from new to closed

I believe this is fixed now, if not please reopen.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.