Modify

Opened 8 years ago

Last modified 7 years ago

#7664 new defect

dir-300 revB1 doesn't respond

Reported by: remur@… Owned by: developers
Priority: normal Milestone:
Component: base system Version: Trunk
Keywords: network rt305x Cc:

Description

Good day, I am building the default image for the dlink dir 300 rev b1 router, this is
Target: Ralink RT288x/RT305x
Subtarget: RT305x based boards
Profile: Default Profile

image: squashfs image

The rest is left untouched.

Image builds fine, then I create the .img
(dd if=vmlinux-dir-300-b1.uImage bs=1024k conv=sync; dd if=root.squashfs bs=65536 conv=sync;) > openwrt-dir300b1-squashfs.img

sign it
v2image -v -i openwrt-dir300b1-squashfs.img -o openwrt-dir300b1-squashfs-webflash.bin -d /dev/mtdblock/2 -s wrgn23_dlwbr_dir300b

and flash it with the recovery interface
(I found this on the web)

The flash process etc works and the router boots and the power led is on without blinking, attaching a lan cable makes the port led light up, when there is traffic on the cable it starts blinking.

So I assume the system is running

But the system doesn't respond to pings to 192.168.1.1 and ssh, nmap also fails to detect any life =(
dhcp requests fall also on deaf ears

/etc/config/network is
# Copyright (C) 2006 OpenWrt.org

config interface loopback

option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0

config interface lan

option ifname eth0
option type bridge
option proto static
option ipaddr 192.168.1.1
option netmask 255.255.255.0

and there is also a uci-default/network to set the proper interfaces
https://dev.openwrt.org/browser/trunk/target/linux/ramips/base-files/etc/uci-defaults/network

I tried playing around with the config/network settings, like setting the ifname to eth0.1 right away, still it didn't work.

Attachments (0)

Change History (1)

comment:1 Changed 7 years ago by laigor <laigor@…>

Router start responding after modifying /etc/config/network in base-diles to:

config interface lan

option ifname eth0.1
option type bridge
option proto static
option ipaddr 192.168.1.1
option netmask 255.255.255.0

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.