Modify

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7641 closed defect (fixed)

tinyproxy: not able to use syslog and create pidfile

Reported by: roecker@… Owned by: developers
Priority: low Milestone: Backfire 10.03.1
Component: packages Version: Backfire 10.03
Keywords: tinyproxy Cc:

Description

I created an openwrt 10.03 image containing the tinyproxy which had 2 small Problems:

1.) I wasn't able to configure tinyproxy to use Syslog. Two changes has to be made to get this working:

  • change the line "option Syslog On" to "option Syslog on" in tinyproxy.conf
  • change the "SysLog" (in the "SysLog >> $CFGFILE"-Line) in the initscript of tinyproxy to "Syslog".

Without these changes it keeps always "Syslog Off" in the /tmp/etc/tinyproxy.conf and tinyproxy then want's to log to the file /var/log/tinyproxy/tinyproxy.log which cannot be created due to lack of permissions (the subdirectory is not available).

2.) Similarly to the logfile problem, the PID-file could not be created in /var/run/tinyproxy/tinyproxy.pid. The subdirectory tinyproxy does not exist. Maybe it just can't be created because tinyproxy is running as "nobody:nogroup".
I added a small patch (which works for me) and put it into the feeds/packages/net/tinyproxy/patches directory. I just changed the default log- and pid-file path to a directory which is writeable...

Attachments (1)

020-config_and_pid-path.patch (640 bytes) - added by roecker@… 8 years ago.
workaround-patch for log and pidfile creation

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by roecker@…

workaround-patch for log and pidfile creation

comment:1 Changed 8 years ago by comitizer@…

I can confirm this issue. I just created /var/log/tinyproxy and /var/run/tinyproxy and then chown to nobody:nogroup

comment:2 Changed 8 years ago by florian

  • Resolution set to fixed
  • Status changed from new to closed

Applied in r22431, thanks!

comment:3 Changed 8 years ago by nico

  • Milestone set to Backfire 10.03.1

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.