Modify

Opened 8 years ago

Closed 6 years ago

Last modified 4 years ago

#7606 closed defect (worksforme)

rooter hangs if init.d scripts are modified and extroot is used

Reported by: umiki at med.unideb.hu Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Rooter does not boot, if init.d scripts are edited and extroot is used. The same scripts are OK if overlay is mounted on the jffs2 partition (default setup, extroot not used).

Router / build: wl-500gpV1 r22134 + eglibc 2.12; 100Mb ext4 partition for extroot

(I did not check if the problem also occurs with uclibc. I saw the error with several startup scripts -- for instance applying r22147 [fstab], but also tried telnet etc.)

((Also probably a separate issue, but editing files hangs mcedit [of Midnight Commander] when saving files using the same setup, vi works fine.))

Attachments (0)

Change History (5)

comment:1 Changed 8 years ago by umiki at med.unideb.hu

Opkg also hangs when installing packages. It might be caused by the recent upgrade to 2.6.34, since there were no problems before that (2.6.32).

comment:2 Changed 8 years ago by umiki at med.unideb.hu

I have checked with r22734 and the problem still persists. I know I hadn't described the problem clearly (and wrote rooter instead of router), but I think this is a serious defect rendering the system unusable. I can not pinpoint where the problem is, but it seems that overlaying works ok, if the jffs2 partition is used for overlaying, but it malfunctions when a partition on external device (extroot) is used (for instance it hangs during startup if initscrips are modified, opkg hangs while installing packages, there are problems when accessing modified files, etc.)

comment:3 Changed 8 years ago by umiki at med.unideb.hu

I have also checked the same setup (same .config) but with 2.6.32.14 kernel. Everything works fine, so the problem is probably located somewhere in the kernel, or in the kernel patches.

comment:4 Changed 6 years ago by nbd

  • Resolution set to worksforme
  • Status changed from new to closed

comment:5 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.