Modify

Opened 8 years ago

Closed 4 years ago

#7604 closed defect (not_a_bug)

b44 problems in trunk

Reported by: realopty <realopty@…> Owned by: hauke
Priority: highest Milestone:
Component: kernel Version: Trunk
Keywords: b44 Cc:

Description

when issusing the command

ethtool -s eth0 port mii

the changes dont stick. but my real issue is the fact that the speed and duplex keep flip-flopping. I think the issues are all related.

My device is the SimpleTech SimpleShare NAS. ive included cpuinfo and some other info.

Im using the latest svn of 'trunk'

Attachments (3)

ethtool output (7.5 KB) - added by realopty 8 years ago.
showing how ethtool reports the flopping
openwrt-cpuinfo (363 bytes) - added by realopty 8 years ago.
cpu info
openwrt-dmsg (10.0 KB) - added by realopty 8 years ago.
dmsg

Download all attachments as: .zip

Change History (10)

Changed 8 years ago by realopty

showing how ethtool reports the flopping

Changed 8 years ago by realopty

cpu info

Changed 8 years ago by realopty

dmsg

comment:1 Changed 8 years ago by realopty

note: ive checked the cable. ive also changed routers. same issue.

comment:2 Changed 8 years ago by realopty <realopty@…>

root@OpenWrt:/# mii-tool -v eth0
eth0: negotiated 100baseTx-FD flow-control, link ok

product info: Altimata AC101LF rev 1
basic mode: autonegotiation enabled
basic status: autonegotiation complete, link ok

i believe ive found the problem. my phy chip is a AC101LKQT not the one stated above.

comment:3 Changed 7 years ago by jow

  • Owner changed from developers to hauke
  • Status changed from new to assigned

comment:4 Changed 5 years ago by florian

It this still an issue with current trunk?

comment:5 Changed 5 years ago by hauke

  • Resolution set to no_response
  • Status changed from assigned to closed

If someone still has this issue in trunk or Attitude Adjustment please reopen this ticket.

comment:6 Changed 5 years ago by Will Holmes <realopty@…>

  • Resolution no_response deleted
  • Status changed from closed to reopened

Unfortunately im still seeing this issue with the device.

Thanks,
RealOpty

comment:7 Changed 4 years ago by hauke

  • Resolution set to not_a_bug
  • Status changed from reopened to closed

You can not change the port type in b44 and when the wrong port type would be used it will result in Ethernet not working at all. When the Ethernet speed of one link changes often this is probably a hardware problem.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.