Modify

Opened 8 years ago

Closed 6 years ago

Last modified 3 years ago

#7593 closed defect (fixed)

mmc_over_gpio ar71xx - kmod-spi-bitbang

Reported by: lexxai <lexxai@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: mmc gpio ar71xx Cc:

Description

I have ar71xx board with Dlink-615 c2

Linux version 2.6.32.14 (buildbot@…) (gcc version 4.3.3 (GCC) ) #1 Fri Jul 9 08:31:33 CDT 2010
CPU revision is: 00019374 (MIPS 24Kc)
Atheros AR9130 rev 2, CPU:400.000 MHz, AHB:100.000 MHz, DDR:400.000 MHz

opkg install luci-app-mmc-over-gpio
Installing luci-app-mmc-over-gpio (0.9+svn6215-1) to root...
Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/luci-app-mmc-over-gpio_0.9+svn6215-1_ar71xx.ipk.
Collected errors:

* satisfy_dependencies_for: Cannot satisfy the following dependencies for luci-app-mmc-over-gpio:

  • kmod-spi-bitbang *
  • opkg_install_cmd: Cannot install package luci-app-mmc-over-gpio.


if I doing opkg install luci-app-mmc-over-gpio --force-depends
then installed packages
..
Configuring kmod-crc-itu-t.
Configuring kmod-mmc.
Configuring kmod-crc7.
Configuring kmod-mmc-spi.
Configuring kmod-spi-gpio-old.
Configuring kmod-mmc-over-gpio.
Configuring luci-app-mmc-over-gpio.
cfg20c30b
Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for luci-app-mmc-over-gpio:
  • kmod-spi-bitbang *
  • pkg_run_script: postinst script returned status 1.
  • opkg_configure: luci-app-mmc-over-gpio.postinst returned 1.

Attachments (0)

Change History (6)

comment:1 Changed 8 years ago by lexxai <lexxai@…>

the same and with

OpenWrt Backfire 10.03

comment:2 Changed 8 years ago by florian

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #7594

comment:3 Changed 6 years ago by anonymous

  • Resolution duplicate deleted
  • Status changed from closed to reopened

there is no package: kmod-spi-bitbang @ http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/

even when openwrt is compiled from source, in make menuconfig is set the:
<M> kmod-spi-bitbang.......... Serial Peripheral Interface bitbanging library

the package is not made.

comment:4 Changed 6 years ago by nbd

  • Resolution set to fixed
  • Status changed from reopened to closed

It's built into the kernel, and a dummy package for it should be built after r28649

comment:5 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:6 Changed 3 years ago by valentt

This issue is resolved and can be closed.

On OpenWrt 14.07:

opkg install luci-app-mmc-over-gpio
Installing luci-app-mmc-over-gpio (0.12+svn-r10530-1) to root...
Downloading http://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/generic/packages/luci/luci-app-mmc-over-gpio_0.12+svn-r10530-1_ar71xx.ipk.
Configuring luci-app-mmc-over-gpio.

Package installed and works in Luci as expected.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.