Modify

Opened 8 years ago

Last modified 4 years ago

#7576 reopened defect

Tp-link TL-WR741ND uses wrong antenna

Reported by: nx5 Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: kernel Version: Backfire 10.03
Keywords: Cc:

Description

I just got a tl-wr741nd and flashed backfire 10.03. Everything works fine but the external antenna is not being used. I'm using mac80211/ath9k

This router has only one external antenna but internally it has two, one of them as a PCB trace antenna. I have tried putting a reflector on the external antenna, using a 14db panel antenna and I see no change in reception (always the same amount of aps when scanning, same power, etc). I also expected it to be much better with the stock antenna.

So, I've come to the conclusion it's NOT using the external antenna but the internal pcb one. Maybe diversity is disabled but the antenna is not set correctly or something. txantenna, rxantenna and diversity seem to be all ignored in /etc/config/wireless.

You can see the antenna connections on this pic from the wiki:
http://wiki.openwrt.org/_media/toh/tp-link/wr741nd-09-serial-pins.jpg

Attachments (0)

Change History (12)

comment:1 Changed 8 years ago by nx5

update: as a station i still have the problem but i think as AP maybe it's working ok. I made some tests and it looks like turning the directional antenna does change the power received in other stations. It remains to be seen if this is just the tx antenna being properly selected... maybe the rxantenna is still not working properly.

i found some info from atheros on the ar9285 too:

802.11n does allow for 1 stream devices with a 1x1 TX/RX chain setup
but the hardware *can* have two antennas like your typical legacy
device with diversity enabled. This is the case for AR9285, for
example.

comment:2 Changed 8 years ago by nx5

I made another test today by checking the power of an associated sta as seen by the router in ap mode, it seems it's not a matter of ap or sta, it's a matter of reception or transmission: When receiving, i get the same power no matter what i do with the ap, thus it looks like it's transmitting on the external antenna but receiving on the tiny internal one only. When transmitting (router as sta), i can see power vary by moving the directional antenna, wrpping the stock antenna in tinfoil etc., but when i scan as sta i get very few aps presumably due to the wrong antenna being chosen to receive.

So, transmission seems to choose the right antenna, reception does not.

comment:3 Changed 7 years ago by jow

Is this issue still present in rc3 or trunk?

comment:4 Changed 7 years ago by anonymous

Hi

I have TL-WR741ND, it looks like the issue is still present in rc3.

I get the same "Link Quality" of 50/70 or -60 dBm with the external antenna removed or attached.

From /etc/openwrt_release:

DISTRIB_REVISION="r22796"
DISTRIB_DESCRIPTION="OpenWrt Backfire 10.03.1-rc3"

Regards,
Nik.

comment:5 Changed 6 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

as of trunk r28107 you can now set the rx antenna properly. to use only the external antenna on tl-wr741nd, put 'option txantenna 1' and 'option rxantenna 1' in the wifi-device section in /etc/config/wireless

comment:6 Changed 6 years ago by Nilfred <nilfred@…>

Backported to backfire in r28138 but not fixed by default.
Changes in /etc/config/wireless should go in defconfig or uci-defaults?

comment:7 Changed 6 years ago by nbd

I intentionally did not change the default config, because by default with the standard antenna, using diversity is the right setting. If you replace it with an external antenna, you need to change the config accordingly.

comment:8 Changed 5 years ago by epek

  • Resolution fixed deleted
  • Status changed from closed to reopened

Testing on a rev 4.20 with r32911, the problem probably still exists:

  • I cannot choose just the internal antenna. There is only chainmask 0x00000001 available.
  • Using a directional antenna (14dbi panel) on the external connector, I still see only near-field-APs around. (within 200meters range at most).
  • setting diversity on or off makes a great differnce in wheter no station or only a few ones can be seen.

I doubt, that the problem is really fixed.

comment:9 follow-up: Changed 5 years ago by nbd

a chainmask of 1 is correct, this is a single-stream device after all. did you check the available antennas bitmask using iw?

comment:10 in reply to: ↑ 9 Changed 5 years ago by Epek <epek@…>

Replying to nbd:

a chainmask of 1 is correct, this is a single-stream device after all. did you check the available antennas bitmask using iw?

Available Antennas: TX 0x1 RX 0x1
Configured Antennas: TX 0x1 RX 0x1

Nevertheless the device has two antennas (PCB and external). Diversity chip?

comment:11 Changed 4 years ago by anonymous

Any efforts so far? Can we talk to the diversity chip or is it "dumb"?

comment:12 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as reopened .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.