Modify

Opened 8 years ago

Closed 7 years ago

Last modified 4 years ago

#7518 closed defect (fixed)

network freezes after wifi off on DIR-825

Reported by: anonymous Owned by: developers
Priority: response-needed Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: ar71xx, dir-825, mac80211, ath9k Cc:

Description

Noticed strange local network freezing, which happens sometimes (not every time) after switching off wifi with the next commands:
uci set wireless.radio1.disabled=1;
wifi down radio1

Router stops responding for about 30 seconds, then it returns to normal state and shows 0.00/0.00/0.00 load levels etc. I tried to start pinging outside IP from one ssh connection to router, while from another ssh connection perform above commands: in this case router stopped displaying outgoing pings, but when freeze was over it showed at one time all sent and received packets with no packet loss. So it seems that only local interface stops responding, while on the wan side (and other parts of the router?) everything is fine.
Problem exists on all openwrt versions from backfire release 10.03 to the current trunk snapshot r21897.

Attachments (0)

Change History (8)

comment:1 Changed 7 years ago by rand256

The problem still exists at trunk revision r23842.

To reproduce this:

  1. Turn on radio0 or radio1 wifi device in access point mode using console commands:
    # uci set wireless.radio0.disabled=0
    # wifi
    
  2. Wait for about 5-10 minutes or more. It doesn't matter whether some devices will associate with this access point or not.
  3. Turn off this wifi device using console commands:
    # uci set wireless.radio0.disabled=1
    # wifi
    

After that all devices connected to the router by wire at the LAN side will expect network freeze for about 10-20 seconds. This means no pings or any other connections nor to the router nor anywhere else could be possible from them. Looks like just a huge lag. At the same time router can be accessed from the WAN side with no delays.

Moreover, if one will try to turn wifi on, and then immidiately off, then freeze will not happen.

comment:2 Changed 7 years ago by nbd

  • Priority changed from normal to response-needed

Please try the latest version

comment:3 Changed 7 years ago by rand256

Tested again and the issue is still present at r26150. But now the lag wired clients experiencing is a bit smaller, about 5-10 seconds.
This is how it looks like:

Reply from 172.16.10.10: bytes=32 time<1ms TTL=64
Reply from 172.16.10.10: bytes=32 time<1ms TTL=64
Reply from 172.16.10.10: bytes=32 time<1ms TTL=64
Request timed out. <-- at this point wifi was switched off
Request timed out.
Request timed out.
Reply from 172.16.10.10: bytes=32 time<1ms TTL=64
Reply from 172.16.10.10: bytes=32 time<1ms TTL=64
Reply from 172.16.10.10: bytes=32 time<1ms TTL=64
Reply from 172.16.10.10: bytes=32 time<1ms TTL=64

IP 172.16.10.10 is the address of OpenWrt box. Every connection on the LAN side temporarily hangs, and then continue to work like before.

comment:4 Changed 7 years ago by nbd

It may not be a freeze, maybe it's an ARP issue.

comment:5 Changed 7 years ago by anonymous

So is there anything to be done with this problem? I can try to provide additional information, but I don't know what to look at.

comment:6 Changed 7 years ago by nbd

Please try the latest version, it should be fixed now with r26990

comment:7 Changed 7 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

comment:8 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.