Modify

Opened 8 years ago

Closed 7 years ago

Last modified 5 years ago

#7511 closed defect (invalid)

OpenVPN crashes when first pakets arrive

Reported by: dh5ym Owned by: developers
Priority: normal Milestone: Backfire 10.03.1
Component: packages Version: Trunk
Keywords: openvpn Cc:

Description

OpenVPN 2.1.1 (in client mode)
OpenWRT 10.03

OpenVPN able to start and initiates the connection correctly.
The configuration was tested with PC system before.
OpenVPN crashes reproducible when the first paket (e.g. ping)
arrives at the client.

Log:

Wed Jun 23 19:06:25 2010 SENT CONTROL [server]: 'PUSH_REQUEST' (status=1)
Wed Jun 23 19:06:25 2010 PUSH: Received control message: 'PUSH_REPLY,route 10.8.
0.0 255.255.255.0,topology net30,ping 10,ping-restart 120,ifconfig 10.8.0.6 10.8
.0.5'
Wed Jun 23 19:06:25 2010 OPTIONS IMPORT: timers and/or timeouts modified
Wed Jun 23 19:06:25 2010 OPTIONS IMPORT: --ifconfig/up options modified
Wed Jun 23 19:06:25 2010 OPTIONS IMPORT: route options modified
Wed Jun 23 19:06:25 2010 TUN/TAP device tun0 opened
Wed Jun 23 19:06:25 2010 TUN/TAP TX queue length set to 100
Wed Jun 23 19:06:25 2010 /sbin/ifconfig tun0 10.8.0.6 pointopoint 10.8.0.5 mtu 1
500
Wed Jun 23 19:06:25 2010 /sbin/route add -net 10.8.0.0 netmask 255.255.255.0 gw
10.8.0.5
Wed Jun 23 19:06:25 2010 Initialization Sequence Completed
CPU 0 Unable to handle kernel paging request at virtual address 00726964, epc ==

81f124e8, ra == 81f1243c

Oops#2:
Cpu 0
$ 0 : 00000000 00482749 00726964 000000c1
$ 4 : 00000001 00000000 00000000 00000000
$ 8 : 37000000 81de5455 00000018 3231302f
$12 : 16151413 00000055 8141de58 1a191817
$16 : 00000055 81df6560 00000000 00000055
$20 : 81de4ac0 00000000 8141de50 00000055
$24 : 00000008 81de5455
$28 : 8141c000 8141dde0 00000000 81f1243c
Hi : 000000aa
Lo : 00001f6d
epc : 81f124e8 0x81f124e8

Tainted: P D

ra : 81f1243c 0x81f1243c
Status: 1000f803 KERNEL EXL IE
Cause : 00800008
BadVA : 00726964
PrId : 00029007 (Broadcom BCM3302)
Modules linked in: ohci_hcd ath_pci ath_hal(P) nf_nat_tftp nf_conntrack_tftp nf_
nat_irc nf_conntrack_irc nf_nat_ftp nf_conntrack_ftp ipt_MASQUERADE iptable_nat
nf_nat xt_NOTRACK iptable_raw xt_state nf_conntrack_ipv4 nf_defrag_ipv4 nf_connt
rack ehci_hcd pppoe pppox ipt_REJECT xt_TCPMSS ipt_LOG xt_comment xt_multiport x
t_mac xt_limit iptable_mangle iptable_filter ip_tables xt_tcpudp x_tables tun pp
p_async ppp_generic slhc usbcore nls_base crc_ccitt switch_robo switch_core diag
Process openvpn (pid: 988, threadinfo=8141c000, task=81ddf9f8, tls=00000000)
Stack : 8141de08 00000055 00000000 00000034 00000055 81013000 00080000 80000000

00000000 00000000 81c60000 81ec35c0 8141de58 fffffdee 8141de50 81c30420
8141df18 00000008 0000027c 0000027e 00000020 8009d250 00000000 00000007
00000001 00000002 00000000 00000000 004826f4 00000055 81dbdc94 00000000
00000000 00000001 ffffffff 81c30420 00000000 00000000 00000000 00000000
...

Call Trace:[<8009d250>] 0x8009d250
[<800483d8>] 0x800483d8
[<800ae314>] 0x800ae314
[<8009ddf4>] 0x8009ddf4
[<8009df6c>] 0x8009df6c
[<80003230>] 0x80003230
[<80035188>] 0x80035188

Code: 10400018 00000000 8e2200b0 <90430000> 24020040 306300f0 10620005 2402
0060 14620008
Segmentation fault
root@OpenWrt:/etc/openvpn#

Attachments (0)

Change History (3)

comment:1 Changed 8 years ago by dh5ym

re-checked with build from openwrt download page.
works. So it seems there is something wrong with my configuration.
kmod-tun was self compiled together with openwrt image but openvpn
package was loaded from default server.
Maybe somebody has some clarification ?

comment:2 Changed 8 years ago by anonymous

Shibby's releases suffer from the same problem.

It is because the tun module is not build with the same config as the kernel.

It would be best if the kmod-tun build script checked this in some way.

comment:3 Changed 7 years ago by jow

  • Resolution set to invalid
  • Status changed from new to closed

miscompilation / abi mismatch

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.