Modify

Opened 8 years ago

Closed 7 years ago

#7508 closed defect (no_response)

uhttpd crashes when serving a zip file to iPhone

Reported by: Daniel A. Nagy <nagydani@…> Owned by: jow
Priority: normal Milestone:
Component: packages Version: Backfire 10.03
Keywords: Cc:

Description

When attempting to download a statically stored zip file from an iPhone (desktop Safari browsers are not affected), uhttpd crashes.

This does not depend on the size of the zip file. 100% reproducible with even short zip files. Was not able to reproduce with other http clients.

In its crashed state, uhttpd still binds to the port (no immediate rejects), but does not answer to TCP connections.

Attachments (0)

Change History (4)

comment:1 Changed 8 years ago by Daniel A. Nagy <nagydani@…>

Only version 9 of uhttpd crashes. Version 7 simply refuses to serve the zip file to the iPhone, but does not crash.

comment:2 Changed 8 years ago by jow

  • Owner changed from developers to jow
  • Status changed from new to accepted

comment:3 Changed 8 years ago by jow

I cannot verify this. I tried with the iPhone similator from the developer SDK and I just get a message "Safar cannot download this file".

comment:4 Changed 7 years ago by jow

  • Resolution set to no_response
  • Status changed from accepted to closed

timeout

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.