Modify

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7481 closed defect (obsolete)

Fix for minor but fatal mistake in wireless config detection

Reported by: John Morris <jmorris@…> Owned by: developers
Priority: highest Milestone: Backfire 10.03.1
Component: base system Version: Backfire 10.03
Keywords: Cc:

Description

A wrt54gl won't have WiFi without this minor patch. I duplicated this problem on two units, blowing away any existing config on each. After much gnashing of teeth I found a minor but fatal bug.

Patch /lib/wifi/mac80211.sh thusly:

--- mac80211.sh.orig 2010-06-16 19:20:15.165222860 -0500
+++ mac80211.sh 2010-06-16 19:24:48.802777380 -0500
@@ -428,6 +428,7 @@

option macaddr $(cat /sys/class/ieee80211/${dev}/macaddress)
option hwmode 11${mode_11n}${mode_band}

$ht_capab

+ option phy $dev

# REMOVE THIS LINE TO ENABLE WIFI:
option disabled 1


Attachments (0)

Change History (2)

comment:1 Changed 8 years ago by jow

  • Resolution set to obsolete
  • Status changed from new to closed

This fix does not solve the issue cleanly. Phy numbers are not guaranteed to correspond to physical devices, they may be incremented with each module reload.

Your detection problem is most likely caused by incorrect wifi mac settings in nvram, see
/changeset/20775.html - that will fixup the mac and wireless config.

comment:2 Changed 8 years ago by John Morris <jmorris@…>

Yes, dropping that in and adding a link in rc.d fixes it and gives a MAC address more similar to the wired ports.

Since the WRT54GL is pretty popular, perhaps a FAQ or an updated download image might be in order?

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.