Modify

Opened 8 years ago

Closed 7 years ago

#7469 closed defect (wontfix)

Strange AP - STA behaviour

Reported by: anonymous Owned by: nbd
Priority: response-needed Milestone: Backfire 10.03.1
Component: packages Version: Backfire 10.03
Keywords: Cc:

Description

SW: Backfire 10.03 (r21701)
HW: ADI Pronghorn Metro

We are experiencing a strange issue with AP - STA setup. Here is the test case: at first AP and station are associated, ping is working in both ways(in particular, on the AP, from Busybox's arp output, we can see the 0x2 flag for the station's ip address).
Then we power off STA for a while (until we see the flag 0x0 on the AP). We notice that when we power on the STA again, even if it associate correctly with the AP, we are not able to ping from AP to STA (that is because, on the AP, the flag on the arp table for the STA's ip address remains at 0x0). The output of the ping says "Destination Unreachable", we think that the STA in not replying to AP's arp request (this is confirmed by taking a look at packets capture). As soon as we start a ping from STA to AP, everything starts work again as expected (please see the attached pcap capture for details, 10.0.0.1 is AP, 10.0.0.2 is STA).

The same issue does NOT occour when we swap AP and STA (i.e. we power off AP for a while). Can anyone try to reproduce this problem? Please let me know if you need more details

Attachments (1)

capture.pcap (902 bytes) - added by anonymous 8 years ago.

Download all attachments as: .zip

Change History (9)

Changed 8 years ago by anonymous

comment:1 Changed 8 years ago by nbd

Any details on what kind of wifi cards and driver you're using?

comment:2 Changed 8 years ago by thepeople

  • Owner changed from developers to nbd
  • Status changed from new to assigned

comment:3 Changed 7 years ago by nico

  • Priority changed from normal to response-needed

comment:4 Changed 7 years ago by nbd

  • Resolution set to worksforme
  • Status changed from assigned to closed

-ETIMEDOUT

comment:5 Changed 7 years ago by anonymous

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I have the same problem and it described here https://forum.openwrt.org/viewtopic.php?id=28551

I have atheros's and madwifi on both ap and sta router. I need another wireless client to find out if the problem is on the ap or on the sta router side

comment:6 Changed 7 years ago by flux

made additional tests. Communication between 2 win wlan clients are fine. A linux client (wpa_supplicant 0.6.9) and a win client also works. So I assume that problem with the current hostapd. I have this problem on the brcm47xx and an atheros wireless.

comment:7 Changed 7 years ago by flux <petergof@…>

and yes I'm using current backfire branch.

comment:8 Changed 7 years ago by nbd

  • Resolution set to wontfix
  • Status changed from reopened to closed

madwifi development has stopped, consider switching to ath5k

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.