Opened 8 years ago

Closed 7 years ago

Last modified 4 years ago

#7464 closed enhancement (fixed)

ath9k bad performance with spatial stream (RX-STBC1)

Reported by: anonymous Owned by: nbd
Priority: high Milestone: Backfire 10.03.1
Component: base system Version: Backfire 10.03
Keywords: ath9k spatial stream Cc:


Used Backfire branch Rev 21782

I use an Atheros AR9280 Dual band mini-pci in a RSPro.
The detected capabilities gives uneven and bad performance in NA 40mhz(only tried this mode). The performance is only bad one way.
(transfering files from the router)

phy0: Atheros AR9280 Rev:2 mem=0xb0000000, irq=48

Capabilities: 0x11ce

SM Power Save disabled
RX STBC 1-stream
Max AMSDU length: 7935 bytes
Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
Minimum RX AMPDU time spacing: 8 usec (0x06)
HT TX/RX MCS rate indexes supported: 0-15

Which gives this spatial streams in config/wireless:
list ht_capab TX-STBC
list ht_capab RX-STBC1

If I remove list ht_capab RX-STBC1, or change it to RX-STBC the performance is much better.

Attachments (0)

Change History (11)

comment:1 Changed 8 years ago by jow

  • Owner changed from developers to nbd
  • Status changed from new to assigned

comment:2 Changed 8 years ago by anonymous

What kind of client are you using?

comment:3 Changed 8 years ago by anonymous

The client I used was Atheros AR5418(AR5008) on windows 7.

comment:4 Changed 8 years ago by anonymous

odd. this config option is not supposed to make a difference, since AR5008 does not support STBC at all.

comment:5 Changed 8 years ago by anonymous

Just tried with a Intel Wireless WiFi Link 5300AGN with both win7 and Linux and cannot see the reported issue with this card. It's very fast, win7 reports transfer speeds up to 15-16 MB pr sec, and thats through one floor.
I will try the ar5008 card again and report back.

my hostapd-phy0.conf:
(I dont know why the values is doubled)

comment:6 Changed 8 years ago by anonymous

This ticket can be closed, the ticket description is inaccurate. It seems it has nothing to do with the RX-STBC1.
However I do experience quite erratic wireless thoughput when transfering files from the router to a client, the other way is much faster. This is specially noticeable with an AR5008 as client.

comment:7 Changed 8 years ago by jow

  • Resolution set to invalid
  • Status changed from assigned to closed

Closed by user request

comment:8 Changed 7 years ago by anonymous

  • Resolution invalid deleted
  • Status changed from closed to reopened

I am still having bad performance one way if option RX-STBC1 is set on my AR9280 AP with ar5416/18 as client.
But it seems that it is indeed a issue with hostapd, this seems like a fix?;a=commitdiff;h=36af1c7d31bdc5ba4dacacbf32d3c7585665ae2b

comment:9 Changed 7 years ago by nbd

  • Resolution set to fixed
  • Status changed from reopened to closed

fixed in r22854, r22855

comment:10 follow-up: Changed 7 years ago by anonymous

Yes. That fixed it :)

comment:11 in reply to: ↑ 10 Changed 7 years ago by Alex

Fixed a lot - so thank you very much for the patch you've found!

Replying to anonymous:

Yes. That fixed it :)

Add Comment

Modify Ticket

as closed .
The resolution will be deleted. Next status will be 'reopened'.

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.