Opened 11 years ago

Closed 11 years ago

#743 closed defect (duplicate)

bug with reboot command

Reported by: hsw5020@… Owned by: developers
Priority: normal Milestone: 0.9/rc6
Component: other Version:
Keywords: Cc:



installed RC5 on a WRTSL54GS with default configuration (ie bridged lan and wifi). pppoe is configured and working. i have 2 computers. one is directly connected to the router via ethernet, and the other is on a wireless connection.

after i run reboot from the CLI, i can't get on the internet or ping my router. i run arp from windows, and it shows the mac address of the router as XX:...:33:AC. this is the wrong mac address! an ifconfig from the CLI shows the mac address as being XX:..:00:DB (this is for the br0 interface). i also notice the mac addres of eth0 (the wired LAN) is XX:...:33:AC. coincidence?

now when i clear the arp cache in windows and ping the router, i can get online. now if i look at window's arp table it shows the mac address of the router as XX:..:00:DB. however, i don't face the above problem if i simply unplug/plug the power chord.

i should point out i am able easily to replicate this problem. also, one other person on forum reports the exact same problem.

thanks in advance.

Attachments (0)

Change History (5)

comment:1 Changed 11 years ago by kaloz

  • Milestone set to 0.9/rc6

comment:2 Changed 11 years ago by florian

Can you have a try at latest whiterussian revision ? [5169] introduced a change that could prevent your router from going failsafe as you describe your problem

comment:3 Changed 11 years ago by hsw5020

hi florian.

made the changes exactly as per the revision. unfortunately this does not prevent the router from behaving as in my post. anything else i can try?

btw, was just wondering. when executing reboot command, what lines of code or what script is run?

comment:4 Changed 11 years ago by datenritter

could this have anything to do with the internal switch? on older WRTs it is configured via GPIO on boot, and i have a similar problem with routers i soldered extensions onto using the GPIO lines as data lines. the switch's vlan-tagging function is not configured anymore on reboot, so it losses LAN connectivity.

comment:5 Changed 11 years ago by nbd

  • Resolution set to duplicate
  • Status changed from new to closed

related to #947

Add Comment

Modify Ticket

as closed .
The resolution will be deleted. Next status will be 'reopened'.

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.