Modify

Opened 8 years ago

Closed 7 years ago

Last modified 6 years ago

#7427 closed defect (fixed)

default route in ipv6 route is not added to the Fonero 2100 (Backfire 10.03.x r21662)

Reported by: anonymous Owned by: developers
Priority: response-needed Milestone: Backfire 10.03.1
Component: packages Version: Backfire 10.03
Keywords: Cc:

Description

I have a very similar problem with the default route for ipv6
I have a Fonero 2100 Backfire 10.03.x. Fonero works as a client on the network. Radvd running on the router WR1043ND backfire 10.03.x. Fonero gets properly address ipv6 but it does not add default route.

root@OpenWrt:~# ping6 -c 3 www.sixxs.net
PING www.sixxs.net (2001:1af8:1:f006::6): 56 data bytes
ping6: sendto: Network is unreachable
ath0      Link encap:Ethernet  HWaddr 00:18:84:1B:08:4D
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:9 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:1394 (1.3 KiB)

br-lan    Link encap:Ethernet  HWaddr 00:18:84:1B:08:4C
          inet addr:192.168.1.20  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::e467:ceff:fe0e:92e4/64 Scope:Link
          inet6 addr: 2001:5b0:16b:1310:218:84ff:fe1b:84c/64 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:325 errors:0 dropped:0 overruns:0 frame:0
          TX packets:220 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:22677 (22.1 KiB)  TX bytes:39705 (38.7 KiB)

eth0      Link encap:Ethernet  HWaddr 00:18:84:1B:08:4C
          inet6 addr: 2001:5b0:16b:1310:218:84ff:fe1b:84c/64 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:326 errors:0 dropped:0 overruns:0 frame:0
          TX packets:227 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:27345 (26.7 KiB)  TX bytes:41284 (40.3 KiB)
          Interrupt:4 Base address:0x1000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:14 errors:0 dropped:0 overruns:0 frame:0
          TX packets:14 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:2112 (2.0 KiB)  TX bytes:2112 (2.0 KiB)

wifi0     Link encap:UNSPEC  HWaddr 00-18-84-1B-08-4D-00-00-00-00-00-00-00-00-00-00
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:17 errors:0 dropped:0 overruns:0 frame:11
          TX packets:26 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:195
          RX bytes:782 (782.0 B)  TX bytes:3908 (3.8 KiB)
          Interrupt:3 Memory:b0000000-b000ffff
config 'interface' 'loopback'
        option 'ifname' 'lo'
        option 'proto' 'static'
        option 'ipaddr' '127.0.0.1'
        option 'netmask' '255.0.0.0'

config 'interface' 'lan'
        option 'ifname' 'eth0'
        option 'type' 'bridge'
        option 'proto' 'static'
        option 'netmask' '255.255.255.0'
        option 'ipaddr' '192.168.1.20'
        option 'gateway' '192.168.1.1'
        option 'dns' '192.168.1.1'
root@OpenWrt:~# brctl show
bridge name     bridge id               STP enabled     interfaces
br-lan          8000.0018841b084c       no              eth0
                                                        ath0}}}
{{{
root@OpenWrt:~# ip -6 route
2001:5b0:16b:1310::/64 dev eth0  proto kernel  metric 256  expires 85927sec mtu 1280 advmss 1220 hoplimit 0
2001:5b0:16b:1310::/64 dev br-lan  proto kernel  metric 256  expires 85931sec mtu 1280 advmss 1220 hoplimit 0
fe80::/64 dev br-lan  proto kernel  metric 256  mtu 1280 advmss 1220 hoplimit 0

}}}




When you manually add ^ ip -6 route add default via 2001:5b0:16b:1310::1 dev br-lan ^
everything is working properly.


{{{
root@OpenWrt:~# ip -6 route
2001:5b0:16b:1310::/64 dev eth0  proto kernel  metric 256  expires 85927sec mtu 1280 advmss 1220 hoplimit 0
2001:5b0:16b:1310::/64 dev br-lan  proto kernel  metric 256  expires 85931sec mtu 1280 advmss 1220 hoplimit 0
fe80::/64 dev br-lan  proto kernel  metric 256  mtu 1280 advmss 1220 hoplimit 0
default via 2001:5b0:16b:1310::1 dev br-lan  metric 1024  mtu 1280 advmss 1220 hoplimit 0
}}}

{{{
root@OpenWrt:~# ping6 -c 3 www.sixxs.net
PING www.sixxs.net (2001:838:2:1::30:67): 56 data bytes
64 bytes from 2001:838:2:1::30:67: seq=0 ttl=53 time=102.104 ms
64 bytes from 2001:838:2:1::30:67: seq=1 ttl=53 time=90.726 ms
64 bytes from 2001:838:2:1::30:67: seq=2 ttl=53 time=93.393 ms

--- www.sixxs.net ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max = 90.726/95.407/102.104 ms
}}}

On other computers, this problem does not occur. Everything is done automatically.

Attachments (0)

Change History (8)

comment:1 Changed 8 years ago by anonymous

ne more strange thing
manually set the gateway address and

config 'interface' 'loopback'
        option 'ifname' 'lo'
        option 'proto' 'static'
        option 'ipaddr' '127.0.0.1'
        option 'netmask' '255.0.0.0'

config 'interface' 'lan'
        option 'ifname' 'eth0'
        option 'type' 'bridge'
        option 'proto' 'static'
        option 'netmask' '255.255.255.0'
        option 'ipaddr' '192.168.1.20'
        option 'gateway' '192.168.1.1'
        option 'dns' '192.168.1.1'
        option 'ip6addr' '2001:5b0:16b:1310:218:84ff:fe1b:84c'
        option 'ip6gw' '2001:5b0:16b:1310::1'

root@OpenWrt:~# ip -6 route
2001:5b0:16b:1310::/64 dev eth0  proto kernel  metric 256  expires 85894sec mtu 1280 advmss 1220 hoplimit 0
2001:5b0:16b:1310::/64 dev br-lan  proto kernel  metric 256  expires 85898sec mtu 1280 advmss 1220 hoplimit 0
fe80::/64 dev br-lan  proto kernel  metric 256  mtu 1280 advmss 1220 hoplimit 0
default via 2001:5b0:16b:1310::1 dev br-lan  metric 1  mtu 1280 advmss 1220 hoplimit 0
default dev br-lan  proto kernel  metric 256  mtu 1280 advmss 1220 hoplimit 0

Why are two gates? After all, how is it created a bridge. Time should be only one IP address is ipv6 bridge. And here we have two of the same IPv6 addresses for the eth0 bridge and forming a part of the bridge.
And there we have two default routes.
It should be only one address of the bridge, and a default route.

comment:2 Changed 8 years ago by anonymous

Please see below. the log shows that all the information needed to reach Fonero 2100. I do not know why do not you create a default route.

log from the fonero radvdump 2100

#
# radvd configuration generated by radvdump 1.6
# based on Router Advertisement from fe80::c039:e9ff:fe27:320c
# received by interface br-lan
#

interface br-lan
{
        AdvSendAdvert on;
        # Note: {Min,Max}RtrAdvInterval cannot be obtained with radvdump
        AdvManagedFlag off;
        AdvOtherConfigFlag off;
        AdvReachableTime 0;
        AdvRetransTimer 0;
        AdvCurHopLimit 64;
        AdvDefaultLifetime 1800;
        AdvHomeAgentFlag off;
        AdvDefaultPreference medium;
        AdvLinkMTU 1280;
        AdvSourceLLAddress on;

        prefix 2001:5b0:16b:1310::/64
        {
                AdvValidLifetime 86400;
                AdvPreferredLifetime 14400;
                AdvOnLink on;
                AdvAutonomous on;
                AdvRouterAddr on;
        }; # End of prefix definition

}; # End of interface definition

comment:3 Changed 8 years ago by jow

What provides your IPv6 upstream connection? Aiccu? 6scripts?

comment:4 Changed 8 years ago by anonymous

log from rdisc6

root@OpenWrt:~# rdisc6 br-lan
Soliciting ff02::2 (ff02::2) on br-lan...

Hop limit                 :           64 (      0x40)
Stateful address conf.    :           No
Stateful other conf.      :           No
Router preference         :       medium
Router lifetime           :         1800 (0x00000708) seconds
Reachable time            :  unspecified (0x00000000)
Retransmit time           :  unspecified (0x00000000)
 Prefix                   : 2001:5b0:16b:1310::/64
  Valid time              :        86400 (0x00015180) seconds
  Pref. time              :        14400 (0x00003840) seconds
 MTU                      :         1280 bytes (valid)
 Source link-layer address: 00:23:CD:16:B4:BA
 from fe80::c039:e9ff:fe27:320c

comment:5 Changed 8 years ago by anonymous

Ok. I have a solution. Works

There is a problem with loading the ipv6 module.

I have the following modules in the system
ls /etc/modules.d/

root@OpenWrt:/etc/modules.d# ls
01-crypto-core          40-fs-nfsd              48-ipv6
09-crypto-aes           40-ipt-core             49-ebtables
09-crypto-arc4          41-ipt-conntrack        49-ebtables-ipv4
20-cfg80211             42-ipt-conntrack-extra  49-ebtables-ipv6
20-crc-ccitt            42-ipt-nat              49-ip6tables
20-fs-exportfs          43-ipt-nat-extra        50-ledtrig-morse
20-textsearch           45-ipt-ipopt            50-madwifi
21-mac80211             45-ipt-iprange          60-leds-gpio
30-fs-nfs-common        45-ipt-nathelper
40-fs-nfs               45-ipt-nathelper-extra

if I change the order of the
mv /etc/modules.d/20-ipv6 /etc/modules.d/48-ipv6

This is all about And the result is
(((
root@OpenWrt:/etc/modules.d# ip -6 route
2001:5b0:16b:1310::/64 dev br-lan proto kernel metric 256 expires 86392sec mtu 1280 advmss 1220 hoplimit 0
fe80::/64 dev br-lan proto kernel metric 256 mtu 1280 advmss 1220 hoplimit 0
default via fe80::c039:e9ff:fe27:320c dev br-lan proto kernel metric 1024 expires 1792sec mtu 1280 advmss 1220 hoplimit 64

root@OpenWrt:/etc/modules.d# ifconfig
ath0 Link encap:Ethernet HWaddr 00:18:84:1B:08:4D

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:2634 errors:0 dropped:2 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:216904 (211.8 KiB)

br-lan Link encap:Ethernet HWaddr 00:18:84:1B:08:4C

inet addr:192.168.1.20 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::c0ee:aaff:fe0e:6b72/64 Scope:Link
inet6 addr: 2001:5b0:16b:1310:218:84ff:fe1b:84c/64 Scope:Global
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:3176 errors:0 dropped:0 overruns:0 frame:0
TX packets:373 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:224700 (219.4 KiB) TX bytes:53569 (52.3 KiB)

eth0 Link encap:Ethernet HWaddr 00:18:84:1B:08:4C

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:3206 errors:0 dropped:0 overruns:0 frame:0
TX packets:376 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:271426 (265.0 KiB) TX bytes:54732 (53.4 KiB)
Interrupt:4 Base address:0x1000

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:4 errors:0 dropped:0 overruns:0 frame:0
TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:676 (676.0 B) TX bytes:676 (676.0 B)

wifi0 Link encap:UNSPEC HWaddr 00-18-84-1B-08-4D-00-00-00-00-00-00-00-00-00-00

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1295 errors:0 dropped:0 overruns:0 frame:86
TX packets:3102 errors:5 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:195
RX bytes:64747 (63.2 KiB) TX bytes:386988 (377.9 KiB)
Interrupt:3 Memory:b0000000-b000ffff

}}}

I checked. If I select a smaller number of take-off is wrong.

comment:6 Changed 8 years ago by jow

  • Priority changed from high to response-needed

comment:7 Changed 7 years ago by jow

  • Resolution set to fixed
  • Status changed from new to closed

This should be solved in RC5.

comment:8 Changed 6 years ago by anonymous

To be complete and just in case someone ends here like me:

if you have this problem:

default dev br-lan  proto kernel  metric 256  mtu 1280 advmss 1220 hoplimit 0

the problem is

        option 'ip6addr' '2001:5b0:16b:1310:218:84ff:fe1b:84c'

Its missing the /64

        option 'ip6addr' '2001:5b0:16b:1310:218:84ff:fe1b:84c/64'

without it, the openwrt cant setup a valid route and assume a weird default route

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.