Opened 8 years ago

Closed 5 years ago

#7426 closed defect (invalid)

Impossibile compile ext2 image for x86 platform

Reported by: ramponis <ramponis@…> Owned by: developers
Priority: normal Milestone: Backfire 10.03.1
Component: kernel Version: Trunk
Keywords: Cc:


I have tried to compile ext2 image for x86 platform r
I use always the same config.
At the end of compilation i receive this error.

[code]/home/ramponis/tags/backfire_10.03/staging_dir/host/bin/genext2fs: couldn't allocate a block (no free space)
make[5]: * [install] Error 1
make[5]: Leaving directory `/home/ramponis/tags/backfire_10.03/target/linux/x86/image'
* [install] Error 2
make[4]: Leaving directory `/home/ramponis/tags/backfire_10.03/target/linux/x86'
make[3]: * [install] Error 2
make[3]: Leaving directory `/home/ramponis/tags/backfire_10.03/target/linux'
* [target/linux/install] Error 2
make[2]: Leaving directory `/home/ramponis/tags/backfire_10.03'
make[1]: * /home/ramponis/tags/backfire_10.03/staging_dir/target-i386_uClibc- Error 2
make[1]: Leaving directory `/home/ramponis/tags/backfire_10.03'
* [world] Error 2[/code]

It show me that there is no free space, but this is not true.
There are 30gb free space on the disk.

It works in r21342

Attachments (0)

Change History (8)

comment:1 follow-up: Changed 8 years ago by anonymous

perhaps the inode table is full ?
tune2fs -l

comment:2 in reply to: ↑ 1 Changed 8 years ago by ramponis <ramponis@…>

Replying to anonymous:

perhaps the inode table is full ?
tune2fs -l

sudo tune2fs -l /dev/sda1

tune2fs 1.41.11 (14-Mar-2010)
Filesystem volume name: <none>
Last mounted on: <not available>
Filesystem UUID: 4616273c-8d5d-4112-b6f3-5e8929995eaa
Filesystem magic number: 0xEF53
Filesystem revision #: 1 (dynamic)
Filesystem features: has_journal ext_attr resize_inode dir_index filetype needs_recovery sparse_super large_file
Filesystem flags: signed_directory_hash
Default mount options: (none)
Filesystem state: clean
Errors behavior: Continue
Filesystem OS type: Linux
Inode count: 17940480
Block count: 71746282
Reserved block count: 3587314
Free blocks: 13579882
Free inodes: 8401481
First block: 0
Block size: 4096
Fragment size: 4096
Reserved GDT blocks: 1006
Blocks per group: 32768
Fragments per group: 32768
Inodes per group: 8192
Inode blocks per group: 512
Filesystem created: Fri Feb 27 11:03:58 2009
Last mount time: Thu Jun 3 16:33:43 2010
Last write time: Mon May 24 09:35:11 2010
Mount count: 8
Maximum mount count: 22
Last checked: Mon May 24 09:35:11 2010
Check interval: 15552000 (6 months)
Next check after: Sat Nov 20 08:35:11 2010
Reserved blocks uid: 0 (user root)
Reserved blocks gid: 0 (group root)
First inode: 11
Inode size: 256
Required extra isize: 28
Desired extra isize: 28
Journal inode: 8
First orphan inode: 8770660
Default directory hash: half_md4
Directory Hash Seed: 0efa1808-cc05-447c-bde8-623a47d2b087
Journal backup: inode blocks

comment:3 Changed 8 years ago by ramponis <ramponis@…>

Compiled 21701 and it works
Close this ticket

Thank you

comment:4 Changed 8 years ago by florian

  • Resolution set to fixed
  • Status changed from new to closed

comment:5 Changed 5 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:6 Changed 5 years ago by anonymous

compiled 21701????
what does it means....can you please tell more clearly?

comment:7 Changed 5 years ago by ramponis

It means trunk release 21701, but now is very old.
The compilation works now on backfire 10.03.1, attitude_adjustment 12.09 and trunk.
So leave this ticket closed

comment:8 Changed 5 years ago by jow

  • Resolution set to invalid
  • Status changed from reopened to closed

Add Comment

Modify Ticket

as closed .
The resolution will be deleted. Next status will be 'reopened'.

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.