Modify

Opened 11 years ago

Closed 10 years ago

Last modified 10 years ago

#742 closed defect (fixed)

installing rc5 bin/openwrt-wr850g-squashfs.bin via org. fw web interface went wrong

Reported by: newsgr Owned by: developers
Priority: normal Milestone: 0.9/rc6
Component: packages Version:
Keywords: Cc:

Description

Hi,
there just wanted to drop a line and report:

I have a wr850gV2 (this is what is says on the white sticker, didn't unscrew it yet).
Grabbed the bin/openwrt-wr850g-squashfs.bin via openwrt.org->downloads->bin.

checked md5sum: OK.

following the readme there (00-readme):
"openwrt-wr850g-<type>.bin

This is also a trx file, but with a Motorola header
added to the start of the file, making it a valid
firmware file for a Motorola device."

(so, .bin!=.trx ?? yes,_no_,maybe, fw uloader does care? huh confused )

renamed this to .trx as the org.FW webinterface only takes .trx file (and the note states they are the same or a least the bootloader doesn't care) pressed the upload button. It did it, said "upload successful (yeahh, it would have complained about a wrong fw binary file - wouldn't it? No it wouldn't!), new fw installed" reboot - that was it: bricked.

Renaming was probably the cause for the failure, but on another place (http://wiki.openwrt.org/OpenWrtDocs/Hardware/Motorola/WR850G) it says:
"Note: At least some bootloader version does not work with such a stripped file but will instead take the unstripped .trx-file. If flashing does not work in the later steps, try again without this step."
So should I have taken removed the header or not? I wasn't using thebootloader code at all when using the orgFW webinterface?
Docu (on the wr850g page coulde be a bit more elaborate, a section: "first conversion" maybe..)

Or settings? So pressed reset or 10-15 sec. to get it onto the
right IP, shutdown the PC. tried to connect via telnet, ping it.
No luck.

So now:
When power on modem led is off, wireless is blinking as are the LAN1-4 port leds.

Will go and try to find out how to recover.

Greetz,

Georg

Attachments (0)

Change History (5)

comment:1 Changed 11 years ago by anonymous

Ok, my humble appologies for the above message.
I managed to telnet to the box. But only after I found this in somewhere of the documentation: "Using OpenWrt the first time"

When coming to openwrt.org the first time it really is hard to find the right information to get you started. There is the wiki, forum and lot of other stuff which probably could(should?) be better organised.

Many info is only contained in the forum like here http://forum.openwrt.org/viewtopic.php?id=3474.
Well it might be that people do the stupid things (like I did) because they couldn't find their way through the docs.

They also contain some unclear/contradictory info where you hopelessly are lost being new e.g. does it load the .bin oder .trx. Afer some reading: they are not the same, but does the fw-installer (might it be the built in in protected flash, or an openwrt loader care?), is the header 32B or 8B etc.

I guess you already know this but I thought I share my experience, perhaps it's helpful. By no means I meant to complain, just give measures to improve things.

Thx for Openwrt,

Georg

comment:2 Changed 11 years ago by kaloz

  • Milestone set to 0.9/rc6
  • Resolution set to invalid
  • Status changed from new to closed

comment:3 Changed 11 years ago by dondruce@…

  • Resolution invalid deleted
  • Status changed from closed to reopened

I recently obtained a Motorola WR850G v2 router and decided to Flash it. When trying to use the openwrt-wr850g-squashfs.bin file, I get an error message stating "Incorrect file type - the file type should be ".trx"" Some searching brough me to this page. I obviously do not want to brick my Router - learn from others attitude. Has anyone solved this problem? Has anyone successfully managed to flash the Motorola WR850G v2 Router? On hold till I find out more.

comment:4 Changed 10 years ago by florian

  • Resolution set to fixed
  • Status changed from reopened to closed

Should be fixed with [9434]

comment:5 Changed 10 years ago by dondruce@…

It bricked my Motorola last time I tried it. Not sure how to recover.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.