Modify

Opened 8 years ago

Closed 6 years ago

#7382 closed defect (no_response)

I/O error in writting to usb devices SD card and usb stick RouterStatio PRO

Reported by: hruza.tomas@… Owned by: juhosg
Priority: response-needed Milestone: Backfire 10.03.1
Component: base system Version: Backfire 10.03
Keywords: Cc:

Description (last modified by nico)

Hello,

I would like to use the Ubiquity RouterStation PRO as the webserver with 16GB SD card (kingstone class4) as storage. In case of writing to the SD card (eg. create filesystem or copy larger files) I get a message in dmesg writting failed at I/O error. I have tried multiple SD cards and everytime I got the same result. I got the same error even for USB stick. I tried latest stable openwrt backfire 10.03 and snapshot test release. In both cases I got the same error.

Could you please help me.
Thanks a lot.
Best regards Tomas

uname -a
Linux OpenWrt 2.6.32.12 #1 Sat May 15 07:19:21 CDT 2010 mips GNU/Linux

errors from dmesg:

mini_fo: using base directory: /
mini_fo: using storage directory: /overlay
eth0: link down
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
ar71xx-ehci ar71xx-ehci: Atheros AR71xx built-in EHCI controller
ar71xx-ehci ar71xx-ehci: new USB bus registered, assigned bus number 1
ar71xx-ehci ar71xx-ehci: irq 3, io mem 0x1b000000
ar71xx-ehci ar71xx-ehci: USB 2.0 started, EHCI 1.00
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected
SCSI subsystem initialized
Initializing USB Mass Storage driver...
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
usb 1-2: new high speed USB device using ar71xx-ehci and address 2
usb 1-2: configuration #1 chosen from 1 choice
scsi0 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 2
usb-storage: waiting for device to settle before scanning
scsi 0:0:0:0: Direct-Access     Generic  STORAGE DEVICE   9451 PQ: 0 ANSI: 0
sd 0:0:0:0: [sda] 31326208 512-byte logical blocks: (16.0 GB/14.9 GiB)
sd 0:0:0:0: [sda] Write Protect is off
sd 0:0:0:0: [sda] Mode Sense: 03 00 00 00
sd 0:0:0:0: [sda] Assuming drive cache: write through
usb-storage: device scan complete
sd 0:0:0:0: [sda] Assuming drive cache: write through
 sda:
usb 1-2: reset high speed USB device using ar71xx-ehci and address 2
device eth1 entered promiscuous mode
ar71xx: pll_reg 0xb8050010: 0x1099
eth0: link up (100Mbps/Full duplex)
usb 1-2: reset high speed USB device using ar71xx-ehci and address 2
sd 0:0:0:0: [sda] Unhandled sense code
sd 0:0:0:0: [sda] Result: hostbyte=0x00 driverbyte=0x08
sd 0:0:0:0: [sda] Sense Key : 0x3 [current] 
sd 0:0:0:0: [sda] ASC=0x47 ASCQ=0x1
sd 0:0:0:0: [sda] CDB: cdb[0]=0x28: 28 00 00 00 00 00 00 00 08 00
end_request: I/O error, dev sda, sector 0
Buffer I/O error on device sda, logical block 0
ar71xx: pll_reg 0xb8050014: 0x110000
eth1: link up (1000Mbps/Full duplex)
br-lan: port 1(eth1) entering forwarding state
usb 1-2: reset high speed USB device using ar71xx-ehci and address 2
sd 0:0:0:0: [sda] Media Changed
sd 0:0:0:0: [sda] Result: hostbyte=0x00 driverbyte=0x08
sd 0:0:0:0: [sda] Sense Key : 0x6 [current] 
sd 0:0:0:0: [sda] ASC=0x28 ASCQ=0x0
sd 0:0:0:0: [sda] CDB: cdb[0]=0x28: 28 00 00 00 00 00 00 00 08 00
end_request: I/O error, dev sda, sector 0
Buffer I/O error on device sda, logical block 0
 unable to read partition table
sd 0:0:0:0: [sda] Assuming drive cache: write through
sd 0:0:0:0: [sda] Attached SCSI removable disk
Generic kernel compatibility enabled based on linux-next next-20100113cfg80211: Calling CRDA to update world regulatory domain
cfg80211: World regulatory domain updated:
    (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
    (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
PPP generic driver version 2.4.2
ip_tables: (C) 2000-2006 Netfilter Core Team
NET: Registered protocol family 24
nf_conntrack version 0.5.0 (1985 buckets, 7940 max)
CONFIG_NF_CT_ACCT is deprecated and will be removed soon. Please use
nf_conntrack.acct=1 kernel parameter, acct=1 nf_conntrack module option or
sysctl net.netfilter.nf_conntrack_acct=1 to enable it.
ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
ar71xx-ohci ar71xx-ohci: Atheros AR71xx built-in OHCI controller
ar71xx-ohci ar71xx-ohci: new USB bus registered, assigned bus number 2
ar71xx-ohci ar71xx-ohci: irq 14, io mem 0x1c000000
usb usb2: configuration #1 chosen from 1 choice
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 2 ports detected
ar71xx-wdt: enabling watchdog timer
sd 0:0:0:0: [sda] Assuming drive cache: write through
sd 0:0:0:0: [sda] Assuming drive cache: write through
 sda:
usb 1-2: reset high speed USB device using ar71xx-ehci and address 2
usb 1-2: reset high speed USB device using ar71xx-ehci and address 2
sd 0:0:0:0: [sda] Unhandled sense code
sd 0:0:0:0: [sda] Result: hostbyte=0x00 driverbyte=0x08
sd 0:0:0:0: [sda] Sense Key : 0x3 [current] 
sd 0:0:0:0: [sda] ASC=0x47 ASCQ=0x1
sd 0:0:0:0: [sda] CDB: cdb[0]=0x28: 28 00 00 00 00 00 00 00 08 00
end_request: I/O error, dev sda, sector 0
Buffer I/O error on device sda, logical block 0
usb 1-2: reset high speed USB device using ar71xx-ehci and address 2
sd 0:0:0:0: [sda] Unhandled sense code
sd 0:0:0:0: [sda] Result: hostbyte=0x00 driverbyte=0x08
sd 0:0:0:0: [sda] Sense Key : 0x3 [current] 
sd 0:0:0:0: [sda] ASC=0x47 ASCQ=0x1
sd 0:0:0:0: [sda] CDB: cdb[0]=0x28: 28 00 00 00 00 00 00 00 08 00
end_request: I/O error, dev sda, sector 0
Buffer I/O error on device sda, logical block 0
 unable to read partition table
usb 1-2: reset high speed USB device using ar71xx-ehci and address 2
sd 0:0:0:0: [sda] Unhandled sense code
sd 0:0:0:0: [sda] Result: hostbyte=0x00 driverbyte=0x08
sd 0:0:0:0: [sda] Sense Key : 0x3 [current] 
sd 0:0:0:0: [sda] ASC=0x47 ASCQ=0x1
sd 0:0:0:0: [sda] CDB: cdb[0]=0x28: 28 00 00 00 00 00 00 00 08 00
end_request: I/O error, dev sda, sector 0
Buffer I/O error on device sda, logical block 0
usb 1-2: reset high speed USB device using ar71xx-ehci and address 2
sd 0:0:0:0: [sda] Unhandled sense code
sd 0:0:0:0: [sda] Result: hostbyte=0x00 driverbyte=0x08
sd 0:0:0:0: [sda] Sense Key : 0x3 [current] 
sd 0:0:0:0: [sda] ASC=0x47 ASCQ=0x1
sd 0:0:0:0: [sda] CDB: cdb[0]=0x28: 28 00 00 00 00 00 00 00 20 00
end_request: I/O error, dev sda, sector 0
Buffer I/O error on device sda, logical block 0
Buffer I/O error on device sda, logical block 1
Buffer I/O error on device sda, logical block 2
Buffer I/O error on device sda, logical block 3
usb 1-2: reset high speed USB device using ar71xx-ehci and address 2
sd 0:0:0:0: [sda] Unhandled sense code
sd 0:0:0:0: [sda] Result: hostbyte=0x00 driverbyte=0x08
sd 0:0:0:0: [sda] Sense Key : 0x3 [current] 
sd 0:0:0:0: [sda] ASC=0x47 ASCQ=0x1
sd 0:0:0:0: [sda] CDB: cdb[0]=0x28: 28 00 00 00 00 00 00 00 08 00
end_request: I/O error, dev sda, sector 0
Buffer I/O error on device sda, logical block 0
sd 0:0:0:0: [sda] Unhandled sense code
sd 0:0:0:0: [sda] Result: hostbyte=0x00 driverbyte=0x08
sd 0:0:0:0: [sda] Sense Key : 0x3 [current] 
sd 0:0:0:0: [sda] ASC=0x47 ASCQ=0x1
sd 0:0:0:0: [sda] CDB: cdb[0]=0x28: 28 00 01 dd ff f8 00 00 01 00
end_request: I/O error, dev sda, sector 31326200
Buffer I/O error on device sda, logical block 3915775
sd 0:0:0:0: [sda] Unhandled sense code
sd 0:0:0:0: [sda] Result: hostbyte=0x00 driverbyte=0x08
sd 0:0:0:0: [sda] Sense Key : 0x3 [current] 
sd 0:0:0:0: [sda] ASC=0x47 ASCQ=0x1
sd 0:0:0:0: [sda] CDB: cdb[0]=0x28: 28 00 01 dd ff f8 00 00 01 00
end_request: I/O error, dev sda, sector 31326200
Buffer I/O error on device sda, logical block 3915775
usb 1-2: reset high speed USB device using ar71xx-ehci and address 2

this modules are loaded:

ohci_hcd               16896  0 
nf_nat_tftp              432  0 
nf_conntrack_tftp       2400  1 nf_nat_tftp
nf_nat_irc               816  0 
nf_conntrack_irc        2512  1 nf_nat_irc
nf_nat_ftp              1328  0 
nf_conntrack_ftp        4640  1 nf_nat_ftp
ipt_MASQUERADE           992  2 
iptable_nat             2768  1 
nf_nat                 10912  5 nf_nat_tftp,nf_nat_irc,nf_nat_ftp,ipt_MASQUERADE,iptable_nat
xt_NOTRACK               544  0 
iptable_raw              656  1 
xt_state                 768  3 
nf_conntrack_ipv4       7920  6 iptable_nat,nf_nat
nf_defrag_ipv4           656  1 nf_conntrack_ipv4
nf_conntrack           38848 12 nf_nat_tftp,nf_conntrack_tftp,nf_nat_irc,nf_conntrack_irc,nf_nat_ftp,nf_conntrack_ftp,ipt_MASQUERADE,iptable_nat,nf_nat,xt_NOTRACK,xt_state,nf_conntrack_ipv4
pppoe                   8304  0 
pppox                   1216  1 pppoe
ipt_REJECT              1712  2 
xt_TCPMSS               2560  2 
ipt_LOG                 4272  0 
xt_comment               464  0 
xt_multiport            1792  0 
xt_mac                   576  0 
xt_limit                1008  1 
iptable_mangle           992  0 
iptable_filter           768  1 
ip_tables               8544  4 iptable_nat,iptable_raw,iptable_mangle,iptable_filter
xt_tcpudp               1760  5 
x_tables                9296 13 ipt_MASQUERADE,iptable_nat,xt_NOTRACK,xt_state,ipt_REJECT,xt_TCPMSS,ipt_LOG,xt_comment,xt_multiport,xt_mac,xt_limit,ip_tables,xt_tcpudp
ext2                   42224  0 
ppp_async               6400  0 
ppp_generic            18848  3 pppoe,pppox,ppp_async
slhc                    4160  1 ppp_generic
vfat                    7712  0 
fat                    42256  1 vfat
ath9k                  80816  0 
ath9k_common            4816  1 ath9k
ath9k_hw              255264  2 ath9k,ath9k_common
ath                     7008  2 ath9k,ath9k_hw
mac80211              194832  2 ath9k,ath9k_common
cfg80211              117360  4 ath9k,ath9k_common,ath,mac80211
compat_firmware_class     4816  0 
compat                   432  0 
arc4                     816  0 
aes_generic            30256  0 
deflate                 1360  0 
ecb                     1328  0 
cbc                     2016  0 
ext3                   91248  0 
jbd                    31376  1 ext3
mmc_block               6288  0 
mmc_core               37392  1 mmc_block
usb_storage            32624  0 
sd_mod                 21600  0 
scsi_mod               68176  2 usb_storage,sd_mod
ehci_hcd               31216  0 
usbcore                97600  4 ohci_hcd,usb_storage,ehci_hcd
nls_base                4800  3 vfat,fat,usbcore
mbcache                 3920  0 
crc_ccitt                976  1 ppp_async
leds_gpio               1456  0 
button_hotplug          2752  0 
gpio_buttons            1968  0 
input_polldev           1360  1 gpio_buttons
input_core             16896  4 button_hotplug,gpio_buttons,input_polldev

installed packages:

base-files - 43-r21442
block-extroot - 0.0.1-2
block-mount - 0.1.0-2
busybox - 1.16.1-5
crda - 1.1.0-2
dnsmasq - 2.52-4
dropbear - 0.52-4
e2fsprogs - 1.41.11-1
fdisk - 2.13.0.1-4
firewall - 2-1
hotplug2 - 1.0-beta-2
iptables - 1.4.7-1
iptables-mod-conntrack - 1.4.7-1
iptables-mod-nat - 1.4.7-1
iw - 0.9.19-1
kernel - 2.6.32.12-1
kmod-ath - 2.6.32.12+2010-04-28-1
kmod-ath9k - 2.6.32.12+2010-04-28-1
kmod-button-hotplug - 2.6.32.12-1
kmod-cfg80211 - 2.6.32.12+2010-04-28-1
kmod-crc-ccitt - 2.6.32.12-1
kmod-crypto-aes - 2.6.32.12-1
kmod-crypto-arc4 - 2.6.32.12-1
kmod-crypto-core - 2.6.32.12-1
kmod-fs-ext2 - 2.6.32.12-1
kmod-fs-ext3 - 2.6.32.12-1
kmod-fs-mbcache - 2.6.32.12-1
kmod-fs-vfat - 2.6.32.12-1
kmod-input-core - 2.6.32.12-1
kmod-input-gpio-buttons - 2.6.32.12-1
kmod-input-polldev - 2.6.32.12-1
kmod-ipt-conntrack - 2.6.32.12-1
kmod-ipt-core - 2.6.32.12-1
kmod-ipt-nat - 2.6.32.12-1
kmod-ipt-nathelper - 2.6.32.12-1
kmod-leds-gpio - 2.6.32.12-1
kmod-mac80211 - 2.6.32.12+2010-04-28-1
kmod-mmc - 2.6.32.12-1
kmod-nls-base - 2.6.32.12-1
kmod-ppp - 2.6.32.12-1
kmod-pppoe - 2.6.32.12-1
kmod-scsi-core - 2.6.32.12-1
kmod-usb-core - 2.6.32.12-1
kmod-usb-ohci - 2.6.32.12-1
kmod-usb-storage - 2.6.32.12-1
kmod-usb2 - 2.6.32.12-1
libblkid - 1.41.11-1
libc - 0.9.30.1-43
libext2fs - 1.41.11-1
libgcc - 4.3.3+cs-43
libiptc - 1.4.7-1
libncurses - 5.7-2
libnl-tiny - 0.1-1
libpthread - 0.9.30.1-44
librt - 0.9.30.1-44
libuci - 12012009.5-1
libusb - 0.1.12-2
libuuid - 1.41.11-1
libxtables - 1.4.7-1
mtd - 12
opkg - 528-1
pciutils - 3.1.7-2
ppp - 2.4.4-6
ppp-mod-pppoe - 2.4.4-6
swconfig - 5
uci - 12012009.5-1
udevtrigger - 106-1
usbutils - 0.86-2
vim-full - 7.1-3
vsc7385-ucode-ap83 - 1
vsc7385-ucode-pb44 - 1
vsc7395-ucode-ap83 - 1
vsc7395-ucode-pb44 - 1
wireless-tools - 29-4
wpad-mini - 20100418-1
zlib - 1.2.3-5

Attachments (0)

Change History (5)

comment:1 Changed 8 years ago by nico

  • Description modified (diff)

comment:2 Changed 8 years ago by amain@…

I can confirm a similar observation with SDIO cards used in the Router Station Pro for some time now. Cold starting the RS PRO and then immediately using the SDIO card gives several I/O/FileSystem errors. Rebooting, warm start, and then there is no problem at all. So it seems the SDIO cards need some time to 'warm up' before it can be used? Let me know if more information is needed. The problem is easily reproduced.

comment:3 Changed 8 years ago by ebelloti@…

I can confirm this exact same behavior using a 4GB SD Card. There are dmesg entries stating I/O Error when trying to access the device. Sometimes it can't even read the device partition table, other times it reads the part table but fails upon accessing the partition. Tested across different sd cards known to be working fine over other systems. Also notice the messages indicating "high-speed USB device resseting" right before the device access fails.

It seems the device is not ready at the time the hotplug2 system (I believe) kicks in to access the device.

comment:4 Changed 7 years ago by jow

  • Owner changed from developers to juhosg
  • Priority changed from normal to response-needed
  • Status changed from new to assigned

Is this still the case in recent versions?

comment:5 Changed 6 years ago by nbd

  • Resolution set to no_response
  • Status changed from assigned to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.