Modify

Opened 8 years ago

Closed 8 years ago

Last modified 4 years ago

#7360 closed defect (duplicate)

Ubiquiti RSPro rootfs mount issue

Reported by: vipul.sawant@… Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: kernel Version: Trunk
Keywords: ubiqiti rootfs Cc:

Description

The ubiquiti RSPro boot fails on rootfs mount (kernel panic). The image is compiled from trunk revision 21500

The RSpro boot log:
+

AR8316 PHY found on MAC0

AR8316 PHY found on MAC1

Ethernet eth0: MAC address 00:15:6d:c1:c6:65

IP: 192.168.1.20/255.255.255.0, Gateway: 0.0.0.0

Default server: 0.0.0.0

RedBoot(tm) bootstrap and debug environment [ROMRAM]

Ubiquiti Networks certified release, version 0.9.00318M.0905121200 - built 12:01:38, May 12 2009

Copyright (C) 2000, 2001, 2002, 2003, 2004 Red Hat, Inc.

Board: Ubiquiti RouterStation PRO

Arch: ar7100pro

RAM: 0x80000000-0x88000000, [0x8003bf00-0x87fe1000] available

Flash: 0xbf000000-0xc0000000, in 256 blocks of 0x00010000 bytes each

Executing boot script in 1.000 seconds - enter C to abort

RedBoot> fis load -d -e kernel

Trying LZMA decompression...

Image loaded from 0x80060000-0x802c5978

Image is not ELF, skipping ELF parsing...

RedBoot> exec

Now booting linux kernel:

Base address 0x80050000 Entry 0x80060000

memsize=0x08000000

modetty0=0,n,8,1,hw

board=RouterStation PRO

ethaddr=00.15.6d.c1.c6.65

Linux version 2.6.32.12 (vsawant@tb2) (gcc version 4.3.3 (GCC) ) #4 Tue May 18 18:44:29 IST 2010

bootconsole [early0] enabled

CPU revision is: 00019374 (MIPS 24Kc)

Atheros AR7161 rev 2, CPU:720.000 MHz, AHB:180.000 MHz, DDR:360.000 MHz

Determined physical RAM map:

memory: 08000000 @ 00000000 (usable)

Initrd not found or empty - disabling initrd

Zone PFN ranges:

Normal 0x00000000 -> 0x00008000

Movable zone start PFN for each node

early_node_map[1] active PFN ranges

0: 0x00000000 -> 0x00008000

Built 1 zonelists in Zone order, mobility grouping on. Total pages: 32512

Kernel command line: rootfstype=squashfs,yaffs,jffs2 noinitrd console=ttyS0,115200 board=UBNT-RSPRO board=RouterStation PRO ethaddr=00.15.6d.c1.c6.65

PID hash table entries: 512 (order: -1, 2048 bytes)

Dentry cache hash table entries: 16384 (order: 4, 65536 bytes)

Inode-cache hash table entries: 8192 (order: 3, 32768 bytes)

Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.

Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes

Writing ErrCtl register=00000f02

Readback ErrCtl register=00000f02

Memory: 126832k/131072k available (1931k kernel code, 4076k reserved, 369k data, 152k init, 0k highmem)

SLUB: Genslabs=7, HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1

Hierarchical RCU implementation.

NR_IRQS:56

Calibrating delay loop... 478.41 BogoMIPS (lpj=2392064)

Mount-cache hash table entries: 512

NET: Registered protocol family 16

MIPS: machine is Ubiquiti RouterStation Pro

registering PCI controller with io_map_base unset

bio: create slab <bio-0> at 0

pci 0000:00:00.0: PME# supported from D0 D1 D2 D3hot

pci 0000:00:00.0: PME# disabled

PCI: mapping irq 48 to pin1@0000:00:11.0

Switching to clocksource MIPS

NET: Registered protocol family 2

IP route cache hash table entries: 1024 (order: 0, 4096 bytes)

TCP established hash table entries: 4096 (order: 3, 32768 bytes)

TCP bind hash table entries: 4096 (order: 2, 16384 bytes)

TCP: Hash tables configured (established 4096 bind 4096)

TCP reno registered

NET: Registered protocol family 1

squashfs: version 4.0 (2009/01/31) Phillip Lougher

Registering mini_fo version $Id$

JFFS2 version 2.2. (NAND) (SUMMARY) © 2001-2006 Red Hat, Inc.

msgmni has been set to 248

io scheduler noop registered

io scheduler deadline registered (default)

Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled

serial8250.0: ttyS0 at MMIO 0x18020000 (irq = 11) is a 16550A

console [ttyS0] enabled, bootconsole disabled

console [ttyS0] enabled, bootconsole disabled

Atheros AR71xx SPI Controller driver version 0.2.4

m25p80 spi0.0: mx25l12805d (16384 Kbytes)

Searching for RedBoot partition table in spi0.0 at offset 0xfe0000

Searching for RedBoot partition table in spi0.0 at offset 0xff0000

5 RedBoot partitions found on MTD device spi0.0

Creating 5 MTD partitions on "spi0.0":

0x000000000000-0x000000030000 : "RedBoot"

0x000000030000-0x000000100000 : "kernel"

0x000000100000-0x000000ff0000 : "rootfs"

mtd: partition "rootfs" set to be root filesystem

split_squashfs: no squashfs found in "spi0.0"

0x000000ff0000-0x000000fff000 : "FIS directory"

0x000000fff000-0x000001000000 : "RedBoot config"

ag71xx_mdio: probed

eth0: Atheros AG71xx at 0xb9000000, irq 4

eth1: Atheros AG71xx at 0xba000000, irq 5

eth1: AR8316 switch driver attached.

Atheros AR71xx hardware watchdog driver version 0.1.0

TCP westwood registered

NET: Registered protocol family 17

802.1Q VLAN Support v1.8 Ben Greear <greearb@…>

All bugs added by David S. Miller <davem@…>

VFS: Cannot open root device "<NULL>" or unknown-block(31,2)

Please append a correct "root=" boot option; here are the available partitions:

1f00 192 mtdblock0 (driver?)

1f01 832 mtdblock1 (driver?)

1f02 15296 mtdblock2 (driver?)

1f03 60 mtdblock3 (driver?)

1f04 4 mtdblock4 (driver?)

Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(31,2)

Attachments (0)

Change History (4)

comment:1 Changed 8 years ago by yjdofc@…

If you use squash format firmware, there is no this problem.

comment:2 Changed 8 years ago by anonymous

with jffs2 format firmware, I have the same problem/ticket/7322.html, and I tried squash format firmware, no problem.

comment:3 Changed 8 years ago by acoul

  • Resolution set to duplicate
  • Status changed from new to closed

this is a duplicate of #7319

comment:4 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.