Modify

Opened 8 years ago

Closed 7 years ago

#7338 closed defect (fixed)

LuCI QoS page does not disable interface when the enable box is not checked

Reported by: ledwards@… Owned by: jow
Priority: normal Milestone: Backfire 10.03.1
Component: luci Version: Backfire 10.03
Keywords: QoS Enabled Cc:

Description

On the LuCI Administration -> Network -> QoS page, unchecking the Interfaces "enable" box has no effect on QoS (it does not disable the interface). Checking the box adds the 'enabled' option to the QoS config (/etc/config/qos) as follows:

config 'interface' 'wan'
        option 'classgroup' 'Default'
        option 'overhead' '1'
        option 'upload' '128'
        option 'download' '1024'
        option 'enabled' '1'

Unchecking the box removes the 'enabled' option as follows:

config 'interface' 'wan'
        option 'classgroup' 'Default'
        option 'overhead' '1'
        option 'upload' '128'
        option 'download' '1024'

Apparently QoS defaults to "enabled" when the 'enabled' option is not set. Setting the 'enabled' option to '0' does disable the interface as desired:

config 'interface' 'wan'
        option 'classgroup' 'Default'
        option 'overhead' '1'
        option 'upload' '128'
        option 'download' '1024'
        option 'enabled' '0'

Either the enabled option should be set to 0 when the box is unchecked, or QoS should be updated to not enable the interface unless enabled is set to 1.

Attachments (0)

Change History (3)

comment:1 Changed 8 years ago by jow

  • Owner changed from developers to jow
  • Status changed from new to accepted

comment:2 Changed 7 years ago by anonymous

Is this going to be fixed for 10.03.01? It looks like there is a duplicate of this ticket on the LuCI trac:
http://luci.subsignal.org/trac/ticket/139

Maybe it was already fixed by:
http://luci.subsignal.org/trac/changeset/6165

Can this be moved to trunk and latest Backfire? Thanks.

comment:3 Changed 7 years ago by nico

  • Component changed from packages to luci
  • Resolution set to fixed
  • Status changed from accepted to closed

Fixed upstream

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.