Modify

Opened 8 years ago

Closed 7 years ago

Last modified 2 years ago

#7337 closed defect (invalid)

ath_pci reports bus read error on ar7161/Ubiquiti RouterStation Pro

Reported by: luca.pietroni@… Owned by: nbd
Priority: high Milestone: Backfire 10.03.1
Component: other Version: Backfire 10.03
Keywords: ath_info atheros madwifi Cc:

Description

UBNT RsPro + WLM54AG-6BP23 (madwifi) + r18121

I've tested this board with stable backfire, r20653 compiled with
ImageBuilder, r18961 from trunk, r21380 and r21440, same issue.

ath_info output:

root@smesh10:~# ath_info 10000000
-==Device Information==-
MAC Revision: 5210  (0x00)
Bus error

Proc info:

root@smesh10:~# cat /proc/cpuinfo
system type             : Atheros AR7161 rev 2
machine                 : Ubiquiti RouterStation Pro
processor               : 0
cpu model               : MIPS 24Kc V7.4
BogoMIPS                : 478.41
wait instruction        : yes
microsecond timers      : yes
tlb_entries             : 16
extra interrupt vector  : yes
hardware watchpoint     : yes, count: 4, address/irw mask: [0x0ffc,
0x0ffc, 0x0ffb, 0x0ffb]
ASEs implemented        : mips16
shadow register sets    : 1
core                    : 0
VCED exceptions         : not available
VCEI exceptions         : not available

lspci:

root@smesh10:~# lspci -vvvs 11.0
00:11.0 Ethernet controller: Atheros Communications Inc. AR5413 802.11abg
NIC (rev 01)
       Subsystem: Atheros Communications Inc. EnGenius EMP-8602 (400mw)
or Compex WLM54AG (SuperAG)
       Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B- DisINTx-
       Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR- INTx-
       Latency: 96 (2500ns min, 7000ns max), Cache Line Size: 32 bytes
       Interrupt: pin A routed to IRQ 48
       Region 0: Memory at 10000000 (32-bit, non-prefetchable) [size=64K]
       Capabilities: [44] Power Management version 2
               Flags: PMEClk- DSI- D1- D2- AuxCurrent=375mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
               Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=2 PME-
       Kernel driver in use: ath_pci

dmesg output:

Linux version 2.6.30.10 (luca@luca-nc10) (gcc version 4.3.3 (GCC) ) #2 Fri
May 7 10:19:28 CEST 2010
prom: fw_arg0=00000002, fw_arg1=80050028, fw_arg2=80050000,
fw_arg3=00000001
MyLoader: sysp=00000000, boardp=00000000, parts=ace50014
console [early0] enabled
CPU revision is: 00019374 (MIPS 24Kc)
Atheros AR7161 rev 2, CPU:720.000 MHz, AHB:180.000 MHz, DDR:360.000 MHz
Determined physical RAM map:
memory: 08000000 @ 00000000 (usable)
Initrd not found or empty - disabling initrd
Zone PFN ranges:
 Normal   0x00000000 -> 0x00008000
Movable zone start PFN for each node
early_node_map[1] active PFN ranges
   0: 0x00000000 -> 0x00008000
On node 0 totalpages: 32768
free_area_init_node: node 0, pgdat 802a6e70, node_mem_map 81000000
 Normal zone: 256 pages used for memmap
 Normal zone: 0 pages reserved
 Normal zone: 32512 pages, LIFO batch:7
Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 32512
Kernel command line: rootfstype=squashfs,yaffs,jffs2 noinitrd
console=ttyS0,115200 board=UBNT-RSPRO board=RouterStation PRO
ethaddr=00.15.6d.c1.3c.1e
Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
Writing ErrCtl register=0007c182
Readback ErrCtl register=0007c182
NR_IRQS:56
PID hash table entries: 512 (order: 9, 2048 bytes)
Dentry cache hash table entries: 16384 (order: 4, 65536 bytes)
Inode-cache hash table entries: 8192 (order: 3, 32768 bytes)
Memory: 126804k/131072k available (1967k kernel code, 4092k reserved, 371k
data, 140k init, 0k highmem)
SLUB: Genslabs=7, HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
Calibrating delay loop... 478.41 BogoMIPS (lpj=2392064)
Mount-cache hash table entries: 512
net_namespace: 528 bytes
NET: Registered protocol family 16
MIPS: machine is Ubiquiti RouterStation Pro
registering PCI controller with io_map_base unset
bio: create slab <bio-0> at 0
pci 0000:00:00.0: reg 10 32bit mmio: [0x000000-0xfffffff]
pci 0000:00:00.0: reg 14 io port: [0x00-0xff]
pci 0000:00:00.0: supports D1 D2
pci 0000:00:00.0: PME# supported from D0 D1 D2 D3hot
pci 0000:00:00.0: PME# disabled
pci 0000:00:11.0: reg 10 32bit mmio: [0x000000-0x00ffff]
PCI: mapping irq 48 to pin1@0000:00:11.0
NET: Registered protocol family 2
Switched to high resolution mode on CPU 0
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 4096 (order: 3, 32768 bytes)
TCP bind hash table entries: 4096 (order: 2, 16384 bytes)
TCP: Hash tables configured (established 4096 bind 4096)
TCP reno registered
NET: Registered protocol family 1
squashfs: version 4.0 (2009/01/31) Phillip Lougher
Registering mini_fo version $Id$
JFFS2 version 2.2. (NAND) (SUMMARY)  © 2001-2006 Red Hat, Inc.
yaffs May  6 2010 16:24:30 Installing.
msgmni has been set to 248
io scheduler noop registered
io scheduler deadline registered (default)
Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled
serial8250.0: ttyS0 at MMIO 0x18020000 (irq = 11) is a 16550A
console handover: boot [early0] -> real [ttyS0]
ag71xx_mdio: probed
eth0: Atheros AG71xx at 0xb9000000, irq 4
eth0: connected to PHY at ag71xx-mdio:04 [uid=004dd041, driver=Generic
PHY]
eth1: Atheros AG71xx at 0xba000000, irq 5
eth1: connected to 4 PHYs
Atheros AR71xx SPI Controller driver version 0.2.4
m25p80 spi0.0: mx25l128 (16384 Kbytes)
spi0.0: searching for MyLoader partition table at offset 0x10000
spi0.0: searching for MyLoader partition table at offset 0x20000
spi0.0: searching for MyLoader partition table at offset 0x30000
spi0.0: searching for MyLoader partition table at offset 0x40000
spi0.0: no MyLoader partition table found
Searching for RedBoot partition table in spi0.0 at offset 0xfe0000
Searching for RedBoot partition table in spi0.0 at offset 0xff0000
5 RedBoot partitions found on MTD device spi0.0
Creating 5 MTD partitions on "spi0.0":
0x000000000000-0x000000030000 : "RedBoot"
0x000000030000-0x000000100000 : "kernel"
0x000000100000-0x000000ff0000 : "rootfs"
mtd: partition "rootfs" set to be root filesystem
mtd: partition "rootfs_data" created automatically, ofs=380000, len=C70000
0x000000380000-0x000000ff0000 : "rootfs_data"
0x000000ff0000-0x000000fff000 : "FIS directory"
0x000000fff000-0x000001000000 : "RedBoot config"
Atheros AR71xx hardware watchdog driver version 0.1.0
ar71xx-wdt: timeout=15 secs (max=23)
ip_tables: (C) 2000-2006 Netfilter Core Team
TCP westwood registered
NET: Registered protocol family 17
802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>
All bugs added by David S. Miller <davem@redhat.com>
VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
Freeing unused kernel memory: 140k freed
Please be patient, while OpenWrt loads ...
Registered led device: ubnt:green:rf
gpio-buttons driver version 0.1.1
input: gpio-buttons as /devices/platform/gpio-buttons/input/input0
Button Hotplug driver version 0.3.1
mini_fo: using base directory: /
mini_fo: using storage directory: /jffs
SCSI subsystem initialized
ar71xx: pll_reg 0xb8050010: 0x1099
eth0: link up (100Mbps/Full duplex)
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
PPP generic driver version 2.4.2
NET: Registered protocol family 24
Driver 'sd' needs updating - please use bus_type methods
ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
ar71xx-ehci ar71xx-ehci: Atheros AR71xx built-in EHCI controller
ar71xx-ehci ar71xx-ehci: new USB bus registered, assigned bus number 1
ar71xx-ehci ar71xx-ehci: irq 3, io mem 0x1b000000
ar71xx-ehci ar71xx-ehci: USB 2.0 started, EHCI 1.00
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected
nf_conntrack version 0.5.0 (2048 buckets, 8192 max)
CONFIG_NF_CT_ACCT is deprecated and will be removed soon. Please use
nf_conntrack.acct=1 kernel paramater, acct=1 nf_conntrack module option or
sysctl net.netfilter.nf_conntrack_acct=1 to enable it.
usb 1-2: new high speed USB device using ar71xx-ehci and address 2
usb 1-2: configuration #1 chosen from 1 choice
xt_time: kernel timezone is -0000
nf_conntrack_rtsp v0.6.21 loading
nf_nat_rtsp v0.6.21 loading
ath_hal: module license 'Proprietary' taints kernel.
Disabling lock debugging due to kernel taint
ath_hal: 2009-05-08 (AR5210, AR5211, AR5212, AR5416, RF5111, RF5112,
RF2413, RF5413, RF2133, RF2425, REGOPS_FUNC, XR)
ath_pci: trunk
wlan: trunk
wlan: mac acl policy registered
ath_rate_minstrel: Minstrel automatic rate control algorithm 1.2 (trunk)
ath_rate_minstrel: look around rate set to 10%
ath_rate_minstrel: EWMA rolloff level set to 75%
ath_rate_minstrel: max segment size in the mrr set to 6000 us
PCI: Enabling device 0000:00:11.0 (0000 -> 0002)
Atheros HAL provided by OpenWrt, DD-WRT and MakSat Technologies
wifi0: 11a rates: 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
wifi0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps
24Mbps 36Mbps 48Mbps 54Mbps
wifi0: turboA rates: 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi0: turboG rates: 6Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi0: H/W encryption support: WEP AES AES_CCM TKIP
ath_pci: wifi0: Atheros 5413: mem=0x10000000, irq=48
ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
ar71xx-ohci ar71xx-ohci: Atheros AR71xx built-in OHCI controller
ar71xx-ohci ar71xx-ohci: new USB bus registered, assigned bus number 2
ar71xx-ohci ar71xx-ohci: irq 14, io mem 0x1c000000
usb usb2: configuration #1 chosen from 1 choice
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 2 ports detected
uhci_hcd: USB Universal Host Controller Interface driver
usbcore: registered new interface driver usbserial
USB Serial support registered for generic
usbcore: registered new interface driver usbserial_generic
usbserial: USB Serial Driver core
Initializing USB Mass Storage driver...
scsi0 : SCSI emulation for USB Mass Storage devices
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
usb-storage: device found at 2
usb-storage: waiting for device to settle before scanning
scsi 0:0:0:0: Direct-Access     Generic  STORAGE DEVICE   9451 PQ: 0 ANSI:
0
usb-storage: device scan complete
sd 0:0:0:0: [sda] Attached SCSI removable disk

Attachments (0)

Change History (10)

comment:1 Changed 7 years ago by dangole

same issue on Senao EAP7660D, might be related to the WiFi module used.

comment:2 Changed 7 years ago by jow

  • Owner changed from developers to nbd
  • Status changed from new to assigned

Its not clear to me when the bus error occurs. During normal wifi usage or only when running ath_info?

comment:3 Changed 7 years ago by dangole

the error occurs when running ath_info while having madwifi kernel module loaded. probably this a feature rather than a bug...
also, it is not clear to me whether running ath_info while having madwifi loaded up already is even intented at all.
however, i can reproduce this behaviour.

comment:4 Changed 7 years ago by nbd

  • Resolution set to invalid
  • Status changed from assigned to closed

10000000 is a physical address, not a virtual one. You need to specify a virtual address such as 0xb0000000

comment:5 Changed 5 years ago by anonymous

nbd, where can virtual address be found?

comment:6 Changed 5 years ago by nbd

use the one i gave you ;)

comment:7 Changed 5 years ago by anonymous

aha.. that would be slot1 ? I thought it was example so didn't try it.. when I get bus error it's hard to get out of that state without reboot.. as rrmod gives kernel panic.

comment:8 Changed 5 years ago by nbd

Add 0xa0000000 to the physical address and you get the virtual uncached one

comment:9 Changed 5 years ago by anonymous

root@nod5:~# ath_info 0xb0000000

-==Device Information==-

MAC Revision: 5210 (0x00)
Bus error
root@nod5:~#
root@nod5:~# ath_info b0010000

-==Device Information==-

MAC Revision: 5210 (0x00)
Bus error

after that device reboots.

comment:10 Changed 2 years ago by anonymous_D

any chance anybody knows true address for ath_info on ar71xx or any mips based embedded device??

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.