Modify

Opened 8 years ago

Closed 7 years ago

#7310 closed defect (fixed)

Usb hid device for APC ups is not detected completely (d-link dir-825)

Reported by: ari@… Owned by: nico
Priority: normal Milestone: Backfire 10.03.1
Component: base system Version: Trunk
Keywords: dir-825 usb hid Cc:

Description

I have APC BackUPS attached to d-link dir-825 usb port. Router runs
backfire 10.03.

Kernel sees the device as:
root@wlan-var825:~# lsusb

Bus 002 Device 002: ID 051d:0002 American Power Conversion Uninterruptible Power Supply

Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

in /proc/bus/usb/devices there is:

T: Bus=02 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 2 Spd=1.5 MxCh= 0

D: Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1

P: Vendor=051d ProdID=0002 Rev= 1.06

S: Manufacturer=APC

S: Product=Back-UPS ES 700 FW:829.D3 .I USB FW:D3

S: SerialNumber=5B0943T75468

C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr= 2mA

I:* If#= 0 Alt= 0 #EPs= 1 Cls=03(HID ) Sub=00 Prot=00 Driver=usbhid

E: Ad=81(I) Atr=03(Int.) MxPS= 6 Ivl=10ms

in dmesg there is:

hub 2-0:1.0: USB hub found

hub 2-0:1.0: 2 ports detected

usbcore: registered new interface driver usbhid

usbhid: v2.6:USB HID core driver

usb 2-1: new low speed USB device using ar71xx-ohci and address 2

usb 2-1: configuration #1 chosen from 1 choice

generic-usb 0003:051D:0002.0001: claimed by neither input, hiddev
nor hidraw

However, apcupsd expects /dev/hiddev* to be present, but
that device is not there. I found some messages about CONFIG_USB_HIDDEV, but couldn't find anything relevant in menuconfig.

I would be really nice to able to monitor ups with this device.

Attachments (0)

Change History (7)

comment:1 Changed 8 years ago by ari@…

Ooops, the component should have been "base system" instead of "packages".

comment:2 Changed 8 years ago by swalker

  • Component changed from packages to base system

Dupe of #5876?

comment:3 Changed 8 years ago by Ari Suutari <ari@…>

I think that this is not kernel bug mentined in #5876. Not being on expert on this, but it looks more like
that kernel should be compiled with CONFIG_USB_HIDDEV=y set.

I'll try to compile kernel with it to see if it fixes the problem.
(menuconfig option for that would be nice, of course)

comment:4 Changed 8 years ago by Ari Suutari <ari@…>

Ups is detected correctly with following patch:

--- package/kernel/modules/usb.mk	2010-05-24 12:33:42.000000000 +0300
+++ package/kernel/modules/usb.mk.new	2010-05-24 12:33:36.000000000 +0300
@@ -815,7 +815,7 @@
 define KernelPackage/usb-hid
 $(call KernelPackage/usb/Depends,@LINUX_2_6 +!TARGET_x86:kmod-input-core +kmod-input-evdev +!TARGET_x86:kmod-hid)
   TITLE:=Support for USB Human Input Devices
-  KCONFIG:=CONFIG_HID_SUPPORT=y CONFIG_USB_HID
+  KCONFIG:=CONFIG_HID_SUPPORT=y CONFIG_USB_HID CONFIG_USB_HIDDEV=y
   FILES:=$(LINUX_DIR)/drivers/$(USBHID_DIR)/usbhid.ko
   AUTOLOAD:=$(call AutoLoad,70,usbhid)
 endef

So the problem is only that hid support compiles module without CONFIG_USB_HIDDEV.
Having this either as menuconfig option or as default would solve this.

comment:5 Changed 8 years ago by nico

  • Owner changed from developers to nico
  • Status changed from new to accepted

comment:6 Changed 7 years ago by frank030366@…

Developers, Nico - what are you think about comment above? Is this the only issue, or may be another pieces of code need to be corrected? I've got the same issue as described on another hardware - ASUS WL-500g premium V1 and I'm need this ticket to be resolved too.

comment:7 Changed 7 years ago by nico

  • Resolution set to fixed
  • Status changed from accepted to closed

Fixed in [22632] (trunk) & [22633] (backfire), thanks !

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.