Modify

Opened 8 years ago

Closed 7 years ago

Last modified 6 years ago

#7294 closed defect (duplicate)

build fails

Reported by: anonymous Owned by: nico
Priority: response-needed Milestone: Backfire 10.03.1
Component: packages Version: Backfire 10.03
Keywords: Cc:

Description

Here part of the output of make V=99: (backfire r21386)

...
rm -rf /home/fernando/backfire/staging_dir/target-armeb_v5te_uClibc-0.9.30.1_eabi/root-ixp4xx/tmp-luasec
touch /home/fernando/backfire/staging_dir/target-armeb_v5te_uClibc-0.9.30.1_eabi/root-ixp4xx/stamp/.luasec_installed
make[3]: Leaving directory `/home/fernando/backfire/feeds/packages/lang/luasec'
make[3]: Entering directory `/home/fernando/backfire/feeds/packages/lang/distribute'
install -d -m0755 /home/fernando/backfire/staging_dir/host
cp -fpR /home/fernando/backfire/build_dir/host/distribute-0.6.10ipkg-install/* /home/fernando/backfire/staging_dir/host
cp: cannot stat `/home/fernando/backfire/build_dir/host/distribute-0.6.10
ipkg-install/*': No such file or directory
make[3]: * /home/fernando/backfire/build_dir/host/distribute-0.6.10/.built Error 1
make[3]: Leaving directory `/home/fernando/backfire/feeds/packages/lang/distribute'
make[2]:
* [package/feeds/packages/distribute/host/compile] Error 2
make[2]: Leaving directory `/home/fernando/backfire'
make[1]: * /home/fernando/backfire/staging_dir/target-armeb_v5te_uClibc-0.9.30.1_eabi/stamp/.package_compile Error 2
make[1]: Leaving directory `/home/fernando/backfire'
make:
* [world] Error 2

At line 6 (cp command) it seems to be a double / in the path but I don't know where it comes from.

Attachments (0)

Change History (7)

comment:1 Changed 8 years ago by florian

  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce this issue on ixp4xx, works fine here.

comment:2 Changed 8 years ago by anonymous

Here part of the output of make V=99: (backfire r22184)

cp -fpR /home/poma/opwrt/backfire/build_dir/target-i386_uClibc-0.9.30.1/libevent-1.4.13-stable/ipkg-install/usr/lib/libevent-1.4.so.* /home/poma/opwrt/backfire/staging_dir/target-i386_uClibc-0.9.30.1/root-x86/tmp-libevent/usr/lib/
cp -fpR /home/poma/opwrt/backfire/staging_dir/target-i386_uClibc-0.9.30.1/root-x86/tmp-libevent/. /home/poma/opwrt/backfire/staging_dir/target-i386_uClibc-0.9.30.1/root-x86/
rm -rf /home/poma/opwrt/backfire/staging_dir/target-i386_uClibc-0.9.30.1/root-x86/tmp-libevent
touch /home/poma/opwrt/backfire/staging_dir/target-i386_uClibc-0.9.30.1/root-x86/stamp/.libevent_installed
make[3]: Leaving directory `/home/poma/opwrt/backfire/feeds/packages/libs/libevent'
make[3]: Entering directory `/home/poma/opwrt/backfire/feeds/packages/lang/distribute'
install -d -m0755 /home/poma/opwrt/backfire/staging_dir/host
cp -fpR /home/poma/opwrt/backfire/build_dir/host/distribute-0.6.10ipkg-install/* /home/poma/opwrt/backfire/staging_dir/host
cp: cannot stat `/home/poma/opwrt/backfire/build_dir/host/distribute-0.6.10
ipkg-install/*': No such file or directory
make[3]: * /home/poma/opwrt/backfire/build_dir/host/distribute-0.6.10/.built Error 1
make[3]: Leaving directory `/home/poma/opwrt/backfire/feeds/packages/lang/distribute'
make[2]:
* [package/feeds/packages/distribute/host/compile] Error 2
make[2]: Leaving directory `/home/poma/opwrt/backfire'
make[1]: * /home/poma/opwrt/backfire/staging_dir/target-i386_uClibc-0.9.30.1/stamp/.package_compile Error 2
make[1]: Leaving directory `/home/poma/opwrt/backfire'
make:
* [world] Ошибка 2

comment:3 Changed 8 years ago by anonymous

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I got the same error as the topicstarter. The log is as following:
make[3]: Entering directory `/home/puff/dir320/feeds/packages/lang/distribute'
gzip -dc /home/puff/dir320/dl/distribute-0.6.10.tar.gz | /bin/tar -C /home/puff/dir320/build_dir/host/distribute-0.6.10/.. -xf -
ls: cannot access ./patches: No such file or directory
touch /home/puff/dir320/build_dir/host/distribute-0.6.10/.preparedd1e50a6b464dc405ee179e8d5d68bfa3
(cd /home/puff/dir320/build_dir/host/distribute-0.6.10/; if [ -x configure ]; then cp -fpR /home/puff/dir320/scripts/config.{guess,sub} /home/puff/dir320/build_dir/host/distribute-0.6.10 && ./configure CFLAGS="-O2 -I/home/puff/dir320/staging_dir/host/include" CPPFLAGS="-O2 -I/home/puff/dir320/staging_dir/host/include" LDFLAGS="-L/home/puff/dir320/staging_dir/host/lib" SHELL="/bin/bash" --target=i486-linux-gnu --host=i486-linux-gnu --build=i486-linux-gnu --program-prefix="" --program-suffix="" --prefix=/home/puff/dir320/staging_dir/host --exec-prefix=/home/puff/dir320/staging_dir/host --sysconfdir=/home/puff/dir320/staging_dir/host/etc --localstatedir=/home/puff/dir320/staging_dir/host/var ; fi )
touch /home/puff/dir320/build_dir/host/distribute-0.6.10/.configured
install -d -m0755 /home/puff/dir320/staging_dir/host
cp -fpR /home/puff/dir320/build_dir/host/distribute-0.6.10
ipkg-install/* /home/puff/dir320/staging_dir/host
cp: cannot stat `/home/puff/dir320/build_dir/host/distribute-0.6.10ipkg-install/*': No such file or directory
make[3]: * /home/puff/dir320/build_dir/host/distribute-0.6.10/.built Error 1
make[3]: Leaving directory `/home/puff/dir320/feeds/packages/lang/distribute'
make[2]:
* [package/feeds/packages/distribute/host/compile] Error 2
make[2]: Leaving directory `/home/puff/dir320'
make[1]: * /home/puff/dir320/staging_dir/target-mipsel_uClibc-0.9.30.1/stamp/.package_compile Error 2
make[1]: Leaving directory `/home/puff/dir320'
make:
* [world] Error 2

comment:4 Changed 7 years ago by nico

  • Component changed from toolchain to packages
  • Owner changed from developers to nico
  • Status changed from reopened to accepted

I can't reproduce your issues, please try:

make package/feeds/packages/distribute/clean
make package/feeds/packages/distribute/compile BUILD_LOG=1 V=99

and attach the following file to this ticket:

logs/package/feeds/packages/distribute/compile.txt

comment:5 Changed 7 years ago by nico

  • Priority changed from normal to response-needed

comment:6 Changed 7 years ago by anonymous

There are same defect #8163.
There are said this appear due to selection of

"Include the web interface" Location

->Network

->BitTorrent

Selects:PACKAGE_MAKO

I confirm that when I unselected this package problem resolved.
So may be there are some missing dependency?

comment:7 Changed 7 years ago by nbd

  • Resolution set to duplicate
  • Status changed from accepted to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.