Modify

Opened 8 years ago

Closed 4 years ago

Last modified 4 years ago

#7275 closed defect (fixed)

Reboot during heavy network load on WRT54G v3

Reported by: ayecee@… Owned by: developers
Priority: response-needed Milestone: Chaos Calmer 15.05
Component: base system Version: Trunk
Keywords: Cc:

Description

Router reboots when downloading a large file via ssh from a computer directly connected to the WAN side, after a roughly one minute interval. This is using Backfire, with 2.6 kernel.

During the download, a connected ssh session stops responding. If the download is halted before the minute has passed, the ssh session starts responding again and the router does not reboot.

There is no impact when downloading from a regular internet connection, which does not reach speeds high enough to trigger this.

I suspect that the reboot is because the watchdog process does not get a chance to run during heavy load in the network stack.

Attachments (1)

wifi_down_bug.txt (1.9 KB) - added by pesos <mormo_dark@…> 8 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 8 years ago by pesos <mormo_dark@…>

hi,

hey i have similar problems with wrt54g3g. When copying large files from any computer lan or wan, wifi stops responding. Helps wifi up. The router will not restart. Kernel 2.6. I tested fw from svn, image builder.

Changed 8 years ago by pesos <mormo_dark@…>

comment:2 Changed 8 years ago by pesos <mormo_dark@…>

maybe problem is device wlan0 left promiscuous mode

logs in attachment

comment:3 Changed 8 years ago by pesos <mormo_dark@…>

hi,

I tested version trunk from http://downloads.openwrt.org/snapshots/trunk/brcm47xx/openwrt-wrt54g3g-squashfs.bin and i have same problem when I copy somethin trough sftp wifi stop after 10-20 seconds. Anyone tellme how to enable debug for wifi or for all system ?? I want help with resolve this bug.

comment:4 Changed 8 years ago by pesos <mormo_dark@…>

hi,

I did other tests and they show that the wifi hangs only when connection is encrypted sftp, scp.
Copying via ftp works fine. I have two wrt54g3g and can do miscellaneous tests if anyone have ideas for ideas on this ticket.

comment:5 follow-up: Changed 7 years ago by jow

  • Priority changed from normal to response-needed

Is this still the case with RC5 ?

comment:6 Changed 7 years ago by nbd

  • Resolution set to no_response
  • Status changed from new to closed

comment:7 in reply to: ↑ 5 Changed 6 years ago by anonymous

  • Resolution no_response deleted
  • Status changed from closed to reopened

Replying to jow:

Is this still the case with RC5 ?

Yes. Problem remains.

comment:8 Changed 5 years ago by anonymous

I'm experiencing similar problems with 10.03.1. Going back to 10.04.1-RC4 fixed the problem.

comment:9 Changed 4 years ago by tripolar

  • Resolution set to fixed
  • Status changed from reopened to closed

problem should be fixed with latest trunk. if not please reopen a new ticket.

comment:10 Changed 4 years ago by jow

  • Milestone changed from Backfire 10.03.2 to Chaos Calmer (trunk)

Milestone Backfire 10.03.2 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.