Opened 8 years ago

Closed 8 years ago

#7258 closed defect (fixed)

swconfig is non-functional (brcm47xx trunk), not hardware-related

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Backfire 10.03.1
Component: base system Version: Trunk
Keywords: Cc:


swconfig seems to be non-functional in trunk (r21249).

Tried on a Linksys WRT54GL v1.1 with 2.6 kernel (i.e. brcm47xx),
but the problem seems to be unrelated to hardware.

{{{# swconfig dev eth0 show
Failed to connect to the switch}}}

So switch (and hence wired interfaces) does not pass any traffic after boot (although I see failsafe UDP packet). robocfg (which use plain ioctl's, not NETLINK) works without errors, and /proc/switch is in place. switch-* modules are loaded.

tried to run strace, got:

bind(3, {sa_family=AF_NETLINK, pid=3136, groups=00000000}, 12) = 0
getsockname(3, {sa_family=AF_NETLINK, pid=3136, groups=00000000}, [12]) = 0
brk(0x418000)                           = 0x418000
sendmsg(3, {msg_name(12)={sa_family=AF_NETLINK, pid=0, groups=00000000}, msg_iov(1)=[{"\24\0\0\0\20\0\5\3\215*\330K@\f\0\0\3\1\0\0", 20}], msg_controllen=0, msg_flags=0}, 0) = 20
recvmsg(3, {msg_name(12)={sa_family=AF_NETLINK, pid=0, groups=00000000}, msg_iov(1)=[{"t\0\0\0\20\0\2\0\215*\330K@\f\0\0\1\2\0\0\v\0\2\0nlctrl\0\0"..., 4096}], msg_controllen=0, msg_flags=0}, 0) = 1288
recvmsg(3, {msg_name(12)={sa_family=AF_NETLINK, pid=0, groups=00000000}, msg_iov(1)=[{"\24\0\0\0\3\0\2\0\215*\330K@\f\0\0\0\0\0\0\v\0\2\0nlctrl\0\0"..., 4096}], msg_controllen=0, msg_flags=0}, 0) = 20
close(3)                                = 0
write(2, "Failed to connect to the switch\n", 32Failed to connect to the switch
) = 32

weird, it really gets chunk of data over NETLINK, but fails to parse it?

Image was produced by a first pass of clean build (with a customized config of course)

Attachments (0)

Change History (3)

comment:1 Changed 8 years ago by KanjiMonster

The Broadcom switch drivers do not provide swconfig support, you have to use robo-cfg or the switch package.

comment:2 Changed 8 years ago by anonymous

So it is a bug in trunk version of /lib/network/ ? (Checked Backfire release, /proc/switch is used in it instead of swconfig)

Original trunk image is currently unbootable on WRT54G (without preconfigured wifi interface or robocfg initscript)

BTW, what configuration medthod is used by luci?

comment:3 Changed 8 years ago by jow

  • Resolution set to fixed
  • Status changed from new to closed

Don't select swconfig on brcm47xx since it overwrites the architecure specific thus rendering the ethernet defunct. I masked swconfig out for brcm47xx since no known board supports it.

Add Comment

Modify Ticket

as closed .
The resolution will be deleted. Next status will be 'reopened'.

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.