Modify

Opened 8 years ago

Closed 8 years ago

#7248 closed defect (fixed)

Grub doesn't install right with latest trunk change.

Reported by: Jon.Scruggs@… Owned by: developers
Priority: normal Milestone: Backfire 10.03.1
Component: packages Version: Trunk
Keywords: Cc: Jon.Scruggs@…

Description

Hi,

I tried to compile an x86 net5501 image with the latest trunk. At the end doing the install phase, it failed because it could not find certain directories of grub. I did a make package/grub/clean and tried again, but it failed again, so I looked at the revision log for grub and I reverted this change:
https://dev.openwrt.org/changeset/21184/trunk/package/grub
When I used the old way, it worked perfectly. No install error at all, so eliminating those three lines causes grub to fail. That did not fix the problem that the comment suggests that it fixes.

I forget the exact error because that is no longer in my console buffer, but it was during the cp copy that it couldn't find the files in a directory to transfer.

I will recompile to get the exact error if you want me to.

Thanks.

Attachments (0)

Change History (4)

comment:1 in reply to: ↑ description Changed 8 years ago by nico

Replying to Jon.Scruggs@…:

...
I will recompile to get the exact error if you want me to.
...

We can't do much w/o it...

comment:2 Changed 8 years ago by Jon.Scruggs@…

It was not good enough to just run make package/grub/clean to get this error, because once it installed, not all of grub was removed. I had to start fresh by removing the build_dir and staging dir.

In this phase, I get the error:

make[2] package/rootfs-prepare
make[3] package/preconfig
make[2] target/install
make[3] -C target/linux install

make -r world: build failed. Please re-run make with V=99 to see what's going on
make: * [world] Error 1

The error is:
touch /home/jon/trunk/build_dir/linux-x86_net5501/linux-2.6.32.12/.image
make -C image compile install TARGET_BUILD=
make[5]: Entering directory `/home/jon/trunk/target/linux/x86/image'
make[5]: `compile' is up to date.
cp -fpR /home/jon/trunk/build_dir/linux-x86_net5501/linux-2.6.32.12/arch/x86/boot/bzImage /home/jon/trunk/build_dir/linux-x86_net5501/bzImage
# for the image builder
cp -fpR /home/jon/trunk/staging_dir/host/usr/lib/grub/i386-*/stage1 /home/jon/trunk/staging_dir/host/usr/lib/grub/i386-*/stage2 /home/jon/trunk/staging_dir/host/usr/lib/grub/i386-*/e2fs_stage1_5 /home/jon/trunk/build_dir/linux-x86_net5501/
cp: cannot stat `/home/jon/trunk/staging_dir/host/usr/lib/grub/i386-*/stage1': No such file or directory
cp: cannot stat `/home/jon/trunk/staging_dir/host/usr/lib/grub/i386-*/stage2': No such file or directory
cp: cannot stat `/home/jon/trunk/staging_dir/host/usr/lib/grub/i386-*/e2fs_stage1_5': No such file or directory
make[5]: * [install] Error 1
make[5]: Leaving directory `/home/jon/trunk/target/linux/x86/image'
make[4]:
* [install] Error 2
make[4]: Leaving directory `/home/jon/trunk/target/linux/x86'
make[3]: * [install] Error 2
make[3]: Leaving directory `/home/jon/trunk/target/linux'
make[2]:
* [target/linux/install] Error 2
make[2]: Leaving directory `/home/jon/trunk'
make[1]: * /home/jon/trunk/staging_dir/target-i386_uClibc-0.9.30.3/stamp/.target_install Error 2
make[1]: Leaving directory `/home/jon/trunk'
make:
* [world] Error 2

Changing to this causes it to be installed right for me:
CONFIGURE_FLAGS:= \

--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \
--build=$(GNU_HOST_NAME)

I don't know why.

Hope this helps.

comment:3 Changed 8 years ago by Jon.Scruggs@…

The formatting was butchered in my last post, but you get the idea. Add newlines where needed to get the right output.

comment:4 Changed 8 years ago by acoul

  • Resolution set to fixed
  • Status changed from new to closed

should be fixed on r21264 (thank you for reporting)

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.