Modify

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7238 closed defect (obsolete)

kernel crash

Reported by: anonymous Owned by: developers
Priority: highest Milestone: Backfire 10.03.1
Component: kernel Version: Trunk
Keywords: Cc: rkraju@…

Description

I am using openwrt linux kernel of the version#13192 for Router station.
Ported my application on this, but I am getting the crashes randomly

Crash1 :

Unhandled kernel unaligned access#1:
Cpu 0
$ 0 : 00000000 00000000 00000000 00000001
$ 4 : 83aaa9e4 00010101 83aaa988 00000013
$ 8 : 83aaa4e8 00000001 802aa000 01312d00
$12 : 00000000 389fd980 8396b420 802ae7e8
$16 : 802f0d30 8027dbb8 802f0d30 00000000
$20 : 0000012f 24f4f539 802f0d30 83aaa800
$24 : 00000000 80078690
$28 : 83aaa000 83aaa4d8 7fd82480 8009c90c
Hi : 00000000
Lo : 3b9aca00

Executing boot script in 3.000 seconds - enter C to abortnted

Aa : 8009c90c tick_sched_timer+0x238/0x2a4
Status: 10005402 KERNEL EXL
Cause : 00800010
BadVA : 00010109
PrId : 00019374 (MIPS 24K)
Modules linked in: ssMacDrv adi9352_3Drv ieee802_16d_mips sharkDrv hal_mips ws_pci_mips lecDrv services logDrv [last unloaded: logDrv]
Process �'�*� (pid: -2144690176, threadinfo=83aaa000, task=83aaa800, tls=802aa000)
Stack : 0000012f 24f4f539 802f0d30 83aaa658 83aaa4e8 83aaa4e8 0000012f 24f4f539

00000000 83aaa800 802f0d30 8027dbb8 802f0d30 00000000 0000012f 24f4f539
802f0d30 83aaa658 7fd82480 8009c90c 802aa000 802aa000 802aa000 802aa000
83aaa580 0000ed36 0000012f 24f4f539 800950b8 802aa000 802f0d30 8027dbb8
802f0d30 8027dbb8 7fffffff ffffffff 0000012f 24f4b8be 80095120 802aa000
...

Call Trace:
[<80093348>] run_posix_cpu_timers+0xec/0x8dc

Code: 00000000 8ee20138 8ee3013c <8ca40008> 00431021 0044102b 10400004 00000000 8ca20008
Kernel panic - not syncing: Fatal exception in interrupt
=================================================================
Crash 2:
root@OpenWrt:/load1/lm_scripts# Unhandled kernel unaligned access#1:
Cpu 0
$ 0 : 00000000 802b0000 0240f809 24a5e2e9
$ 4 : 0240f809 0240f809 c025c490 00000013
$ 8 : 83028590 00000001 afa20010 01312d00
$12 : 00000000 389fd980 83a595b8 802ae7e8
$16 : 802f0d30 8027dbb8 802f0d30 00000000
$20 : 00001193 2e7e2414 802f0d30 c025c308
$24 : 00000000 80078690
$28 : 83028000 83028580 7fd82480 8009c90c
Hi : 00000000
Lo : 3b9aca00
epc : 80093348 run_posix_cpu_timers+0xec/0x8dc Not tainted
ra : 8009c90c tick_sched_timer+0x238/0x2a4
Status: 10005402 KERNEL EXL
Cause : 00800010
BadVA : 0240f811
PrId : 00019374 (MIPS 24K)
Modules linked in: ssMacDrv adi9352_3Drv ieee802_16d_mips sharkDrv hal_mips ws_pci_mips lecDrv services logDrv [last unloaded: logDrv]
Process �� (pid: -1843003388, threadinfo=83028000, task=c025c308, tls=00006c6c)
Stack : 00001193 2e7e2414 802f0d30 83028700 83028590 83028590 00001193 2e7e2414

00000000 c025c308 802f0d30 8027dbb8 802f0d30 00000000 00001193 2e7e2414
802f0d30 83028700 7fd82480 8009c90c c0217900 00000238 74000002 000074d4
83028628 000dbb76 00001193 2e7e2414 800950b8 000001ac 802f0d30 8027dbb8
802f0d30 8027dbb8 7fffffff ffffffff 00001193 2e7e0573 80095120 0000752b
...

Call Trace:
[<80093348>] run_posix_cpu_timers+0xec/0x8dc

Code: 00000000 8ee20138 8ee3013c <8ca40008> 00431021 0044102b 10400004 00000000 8ca20008
Kernel panic - not syncing: Fatal exception in interrupt

Attachments (1)

crash25.txt (1.5 KB) - added by rkraju@… 8 years ago.

Download all attachments as: .zip

Change History (5)

Changed 8 years ago by rkraju@…

comment:1 follow-up: Changed 8 years ago by acoul

this looks like a dupe of #7207

comment:2 in reply to: ↑ 1 Changed 8 years ago by anonymous

Replying to acoul:

this looks like a dupe of #7207

This is similar to #7207, but I am using the trunk.

comment:3 Changed 8 years ago by nbd

  • Resolution set to obsolete
  • Status changed from new to closed

r13192 is very old => marking as obsolete

comment:4 Changed 8 years ago by nico

  • Milestone changed from Kamikaze to Backfire 10.03.1

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.