Modify

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7187 closed defect (fixed)

Backfire 10.03 at the ag241v2 is not working

Reported by: rpc@… Owned by: florian
Priority: highest Milestone: Backfire 10.03.1
Component: kernel Version: Backfire 10.03
Keywords: Cc:

Description

Until now I was using kamikaze 7.09 8.09 9.09.1 8.09.2. There was no problem with flashing openwrt on the router ag241 previous versions.
Despite strenuous attempts, I can not run properly on ag241 Backfire. After uploading your router does not respond to the address 192.168.1.1. DSL syncs correctly but I can not get to the router via telnet or ssh. The ping does not respond well.
The same applies to the trunk version. The effect is similar - not working ethernet. In desperation, I used a version of the step on your part but also does not work. http://downloads.openwrt.org/backfire/10.03/ar7/openwrt-AG241v2-squashfs-code.bin

Attachments (2)

ag241.txt (6.8 KB) - added by rpc@… 8 years ago.
logs
8.09.2.txt (6.3 KB) - added by rpc@… 8 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 8 years ago by florian

  • Owner changed from developers to florian
  • Status changed from new to accepted

Ok, this is due to eth0 being now non-fonctionnal, but eth1 is. Can you substitue eth0 from eth1 in your /etc/config/network and see if it works?

comment:2 Changed 8 years ago by nico

  • Milestone set to Backfire 10.03.1

comment:3 Changed 8 years ago by rpc@…

It did not help. In compile the firmware change in the firmware that is swapped in /etc/config/network eth0 to eth1. Still after a reboot the DSL LED lights up green and the Power LED flashes red / green. It looks as if it was all right but I still can not get to the router via Ethernet. I found info (https: / / dev.openwrt.org/ticket/5927) and tried cpmac.external_switch = 1 but is also no results. Router still does not respond to ping, telnet or ssh

comment:4 Changed 8 years ago by rpc@…

One more thing. ag241v2 works without a problem. I can log on to it from the WAN (ADSL). Sending logs from the working router. Unfortunately it is not possible to increase the LAN interface.

#dmesg | grep eth
cpmac: device eth0 (regs: 08610000, irq: 27, phy: 1:1f, mac: 00:0e:0a:aa:00:00)

BusyBox v1.15.3 (2010-04-19 22:16:25 CEST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

_

| |.-----.-----.-----.| | | |.----.| |_

| - |_
_ | -| | | _ _|
|_||| ||

|| W I R E L E S S F R E E D O M

Backfire (10.03, r21032) --------------------------

  • 1/3 shot Kahlua In a shot glass, layer Kahlua
  • 1/3 shot Bailey's on the bottom, then Bailey's,
  • 1/3 shot Vodka then Vodka.

---------------------------------------------------

root@OpenWrt:~# dmesg
Linux version 2.6.32.10 (rpc@ubuntu) (gcc version 4.3.3 (GCC) ) #4 Tue Apr 20 06:38:32 CEST 2010
bootconsole [early0] enabled
CPU revision is: 00018448 (MIPS 4KEc)
TI AR7 (TNETD7200), ID: 0x002b, Revision: 0x11
Determined physical RAM map:

memory: 01000000 @ 14000000 (usable)

Initrd not found or empty - disabling initrd
Zone PFN ranges:

Normal 0x00014000 -> 0x00015000

Movable zone start PFN for each node
early_node_map[1] active PFN ranges

0: 0x00014000 -> 0x00015000

On node 0 totalpages: 4096
free_area_init_node: node 0, pgdat 94368bc0, node_mem_map 943a3000

Normal zone: 32 pages used for memmap
Normal zone: 0 pages reserved
Normal zone: 4064 pages, LIFO batch:0

Built 1 zonelists in Zone order, mobility grouping off. Total pages: 4064
Kernel command line: rootfstype=squashfs,jffs2 console=ttyS0,38400n8
PID hash table entries: 64 (order: -4, 256 bytes)
Dentry cache hash table entries: 2048 (order: 1, 8192 bytes)
Inode-cache hash table entries: 1024 (order: 0, 4096 bytes)
Primary instruction cache 16kB, VIPT, 4-way, linesize 16 bytes.
Primary data cache 8kB, 4-way, VIPT, no aliases, linesize 16 bytes
Memory: 12516k/16384k available (2130k kernel code, 3868k reserved, 338k data, 132k init, 0k highmem)
Hierarchical RCU implementation.
NR_IRQS:256
Calibrating delay loop... 149.50 BogoMIPS (lpj=747520)
Mount-cache hash table entries: 512
NET: Registered protocol family 16
Clocks: Async mode
Clocks: Setting DSP clock
Clocks: prediv: 1, postdiv: 1, mul: 5
Clocks: base = 25000000, frequency = 125000000, prediv = 1, postdiv = 2, postdiv2 = 1, mul = 10
Clocks: Setting CPU clock
Adjusted requested frequency 211000000 to 211968000
Clocks: prediv: 1, postdiv: 1, mul: 6
Clocks: base = 35328000, frequency = 211968000, prediv = 1, postdiv = 1, postdiv2 = -1, mul = 6
Clocks: Setting USB clock
Adjusted requested frequency 48000000 to 48076920
Clocks: prediv: 13, postdiv: 1, mul: 5
Clocks: base = 125000000, frequency = 48000000, prediv = 13, postdiv = 1, postdiv2 = -1, mul = 5
bio: create slab <bio-0> at 0
Switching to clocksource MIPS
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 512 (order: 0, 4096 bytes)
TCP bind hash table entries: 512 (order: -1, 2048 bytes)
TCP: Hash tables configured (established 512 bind 512)
TCP reno registered
NET: Registered protocol family 1
squashfs: version 4.0 (2009/01/31) Phillip Lougher
Registering mini_fo version $Id$
JFFS2 version 2.2. (NAND) (SUMMARY) Š 2001-2006 Red Hat, Inc.
msgmni has been set to 24
io scheduler noop registered
io scheduler deadline registered (default)
Serial: 8250/16550 driver, 2 ports, IRQ sharing disabled
serial8250: ttyS0 at MMIO 0x8610e00 (irq = 15) is a 16550A
console [ttyS0] enabled, bootconsole disabled
physmap platform flash device: 00800000 at 10000000
physmap-flash.0: Found 1 x16 devices at 0x0 in 16-bit bank
physmap-flash.0: Found an alias at 0x400000 for the chip at 0x0

Amd/Fujitsu Extended Query Table at 0x0040

physmap-flash.0: Swapping erase regions for broken CFI table.
number of CFI chips: 1
cfi_cmdset_0002: Disabling erase-suspend-program due to code brokenness.
cmdlinepart partition parsing not available
RedBoot partition parsing not available
4 ar7part partitions found on MTD device physmap-flash.0
Creating 4 MTD partitions on "physmap-flash.0":
0x000000000000-0x000000010000 : "loader"
0x000000010000-0x000000020000 : "config"
0x000000020000-0x000000400000 : "linux"
0x0000000f0000-0x000000400000 : "rootfs"
mtd: partition "rootfs" set to be root filesystem
mtd: partition "rootfs_data" created automatically, ofs=350000, len=B0000
0x000000350000-0x000000400000 : "rootfs_data"
Fixed MDIO Bus: probed
cpmac-mii: probed
cpmac: device eth0 (regs: 08610000, irq: 27, phy: 1:1f, mac: 00:0e:0a:aa:00:00)
Registered led device: status
vlynq0: regs 0x08611800, irq 29, mem 0x04000000
TCP westwood registered
NET: Registered protocol family 17
802.1Q VLAN Support v1.8 Ben Greear <greearb@…>
All bugs added by David S. Miller <davem@…>
VFS: Mounted root (squashfs filesystem) readonly on device 31:3.
Freeing unused kernel memory: 132k freed
Please be patient, while OpenWrt loads ...
mini_fo: using base directory: /
mini_fo: using storage directory: /overlay
NET: Registered protocol family 10
lo: Disabled Privacy Extensions
NET: Registered protocol family 8
NET: Registered protocol family 20
PPP generic driver version 2.4.2
tun: Universal TUN/TAP device driver, 1.6
tun: (C) 1999-2004 Max Krasnyansky <maxk@…>
IPv6 over IPv4 tunneling driver
sit0: Disabled Privacy Extensions
ip_tables: (C) 2000-2006 Netfilter Core Team
eth0: no IPv6 routers present
nf_conntrack version 0.5.0 (197 buckets, 788 max)
CONFIG_NF_CT_ACCT is deprecated and will be removed soon. Please use
nf_conntrack.acct=1 kernel parameter, acct=1 nf_conntrack module option or
sysctl net.netfilter.nf_conntrack_acct=1 to enable it.
xt_time: kernel timezone is -0000
nf_conntrack_rtsp v0.6.21 loading
nf_nat_rtsp v0.6.21 loading
ip6_tables: (C) 2000-2006 Netfilter Core Team
registered device TI Avalanche SAR
Ohio250(7200/7100A2) detected
requesting firmware image "ar0700xx.bin"

avsar: firmware: requesting ar0700xx.bin

avsar firmware released
Creating new root folder avalanche in the proc for the driver stats
Texas Instruments ATM driver: version:[7.03.01.00]
DSL in Sync
sixxs: Disabled Privacy Extensions

eth0 Link encap:Ethernet HWaddr 00:0E:0A:AA:00:00

inet addr:192.168.1.1 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: 2002:6b1:26c:1211::22/64 Scope:Global
inet6 addr: fe80::20e:aff:feaa:0/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:200 (200.0 B)
Interrupt:27

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:38 errors:0 dropped:0 overruns:0 frame:0
TX packets:38 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:4454 (4.3 KiB) TX bytes:4454 (4.3 KiB)

ppp0 Link encap:Point-to-Point Protocol

inet addr:178.36.0.198 P-t-P:195.114.190.159 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Metric:1
RX packets:152 errors:0 dropped:0 overruns:0 frame:0
TX packets:183 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:15121 (14.7 KiB) TX bytes:37454 (36.5 KiB)

comment:5 Changed 8 years ago by rpc@…

I do not know why the log so he did. How do I pasted was about to send an email to the wrong side of images.

Changed 8 years ago by rpc@…

logs

comment:6 Changed 8 years ago by anonymous

In version 8.09.2 as shown kamikaze in dmesg:

cpmac-mii: probed
cpmac: device eth0 (regs: 08610000, irq: 27, phy: , mac: 00:0e:0a:aa:44:ff)

The Backfire incorrectly identifies the MAC address

comment:7 Changed 8 years ago by anonymous

Below the result of dmesg command kamikaze 8.09.2. This version works correctly

[code]
BusyBox v1.11.2 (2010-04-18 15:29:28 CEST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

_

| |.-----.-----.-----.| | | |.----.| |_

| - |_
_ | -| | | _ _|
|_||| ||

|| W I R E L E S S F R E E D O M

KAMIKAZE (8.09.2, r18961) -------------------------

  • 10 oz Vodka Shake well with ice and strain
  • 10 oz Triple sec mixture into 10 shot glasses.
  • 10 oz lime juice Salute!

Linux version 2.6.26.8 (rpc@ubuntu) (gcc version 4.1.2) #1 Sun Apr 18 15:47:56 CEST 2010
console [early0] enabled
CPU revision is: 00018448 (MIPS 4KEc)
Clocks: Async mode
Clocks: Setting DSP clock
Clocks: prediv: 1, postdiv: 1, mul: 5
Clocks: base = 25000000, frequency = 125000000, prediv = 1, postdiv = 2, postdiv2 = 1, mul = 10
Clocks: Setting CPU clock
Adjusted requested frequency 211000000 to 211968000
Clocks: prediv: 1, postdiv: 1, mul: 6
Clocks: base = 35328000, frequency = 211968000, prediv = 1, postdiv = 1, postdiv2 = -1, mul = 6
Clocks: Setting USB clock
Adjusted requested frequency 48000000 to 48076920
Clocks: prediv: 13, postdiv: 1, mul: 5
Clocks: base = 125000000, frequency = 48000000, prediv = 13, postdiv = 1, postdiv2 = -1, mul = 5
TI AR7 (TNETD7200), ID: 0x002b, Revision: 0x11
Determined physical RAM map:

memory: 01000000 @ 14000000 (usable)

Entering add_active_range(0, 81920, 86016) 0 entries of 256 used
Initrd not found or empty - disabling initrd
Zone PFN ranges:

Normal 81920 -> 86016

Movable zone start PFN for each node
early_node_map[1] active PFN ranges

0: 81920 -> 86016

On node 0 totalpages: 4096

Normal zone: 32 pages used for memmap
Normal zone: 0 pages reserved
Normal zone: 4064 pages, LIFO batch:0
Movable zone: 0 pages used for memmap

Built 1 zonelists in Zone order, mobility grouping off. Total pages: 4064
Kernel command line: init=/etc/preinit rootfstype=squashfs,jffs2, console=ttyS0,38400n8
Primary instruction cache 16kB, VIPT, 4-way, linesize 16 bytes.
Primary data cache 8kB, 4-way, VIPT, no aliases, linesize 16 bytes
PID hash table entries: 64 (order: 6, 256 bytes)
Dentry cache hash table entries: 2048 (order: 1, 8192 bytes)
Inode-cache hash table entries: 1024 (order: 0, 4096 bytes)
Memory: 12632k/16384k available (1941k kernel code, 3752k reserved, 409k data, 120k init, 0k highmem)
SLUB: Genslabs=6, HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
Calibrating delay loop... 211.35 BogoMIPS (lpj=1056768)
Mount-cache hash table entries: 512
net_namespace: 644 bytes
NET: Registered protocol family 16
Switched to high resolution mode on CPU 0
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 512 (order: 0, 4096 bytes)
TCP bind hash table entries: 512 (order: -1, 2048 bytes)
TCP: Hash tables configured (established 512 bind 512)
TCP reno registered
NET: Registered protocol family 1
squashfs: version 3.0 (2006/03/15) Phillip Lougher
Registering mini_fo version $Id$
JFFS2 version 2.2. (NAND) (SUMMARY) © 2001-2006 Red Hat, Inc.
msgmni has been set to 24
io scheduler noop registered
io scheduler deadline registered (default)
Serial: 8250/16550 driver $Revision: 1.90 $ 2 ports, IRQ sharing disabled
serial8250: ttyS0 at MMIO 0x8610e00 (irq = 15) is a TI-AR7
console handover: boot [early0] -> real [ttyS0]
Fixed MDIO Bus: probed
cpmac-mii: probed
cpmac: device eth0 (regs: 08610000, irq: 27, phy: , mac: 00:0e:0a:aa:44:ff)
physmap platform flash device: 00800000 at 10000000
physmap-flash.0: Found 1 x16 devices at 0x0 in 16-bit bank
physmap-flash.0: Found an alias at 0x400000 for the chip at 0x0

Amd/Fujitsu Extended Query Table at 0x0040

physmap-flash.0: Swapping erase regions for broken CFI table.
number of CFI chips: 1
cfi_cmdset_0002: Disabling erase-suspend-program due to code brokenness.
cmdlinepart partition parsing not available
RedBoot partition parsing not available
4 ar7part partitions found on MTD device physmap-flash.0
Creating 4 MTD partitions on "physmap-flash.0":
0x00000000-0x00010000 : "loader"
0x00010000-0x00020000 : "config"
0x00020000-0x00400000 : "linux"
0x000f0000-0x00400000 : "rootfs"
mtd: partition "rootfs" set to be root filesystem
mtd: partition "rootfs_data" created automatically, ofs=340000, len=C0000
0x00340000-0x00400000 : "rootfs_data"
ar7_wdt: disabling watchdog timer
ar7_wdt: timer margin 59 seconds (prescale 65535, change 57180, freq 62500000)
Registered led device: status
vlynq0: regs 0x08611800, irq 29, mem 0x04000000
TCP vegas registered
NET: Registered protocol family 17
802.1Q VLAN Support v1.8 Ben Greear <greearb@…>
All bugs added by David S. Miller <davem@…>
VFS: Mounted root (squashfs filesystem) readonly.
Freeing unused kernel memory: 120k freed
Please be patient, while OpenWrt loads ...
Algorithmics/MIPS FPU Emulator v1.5
mini_fo: using base directory: /
mini_fo: using storage directory: /tmp/root
NET: Registered protocol family 10
lo: Disabled Privacy Extensions
PHY: 0:1f - Link is Down
NET: Registered protocol family 8
NET: Registered protocol family 20
PPP generic driver version 2.4.2
tun: Universal TUN/TAP device driver, 1.6
tun: (C) 1999-2004 Max Krasnyansky <maxk@…>
IPv6 over IPv4 tunneling driver
sit0: Disabled Privacy Extensions
ip_tables: (C) 2000-2006 Netfilter Core Team
nf_conntrack version 0.5.0 (1024 buckets, 4096 max)
IPP2P v0.8.1_rc1 loading
IMQ driver loaded successfully.

Hooking IMQ before NAT on PREROUTING.
Hooking IMQ after NAT on POSTROUTING.

ip6_tables: (C) 2000-2006 Netfilter Core Team
ip6_queue: failed to register queue handler
eth0: no IPv6 routers present
registered device TI Avalanche SAR
Ohio250(7200/7100A2) detected
requesting firmware image "ar0700xx.bin"
firmware: requesting ar0700xx.bin
avsar firmware released
Creating new root folder avalanche in the proc for the driver stats
Texas Instruments ATM driver: version:[7.03.01.00]
jffs2_scan_eraseblock(): End of filesystem marker found at 0x0
jffs2_build_filesystem(): unlocking the mtd device... done.
jffs2_build_filesystem(): erasing all blocks after the end marker... done.
mini_fo: using base directory: /
mini_fo: using storage directory: /jffs
DSL in Sync
ar7_wdt: enabling watchdog timer
sixxs: Disabled Privacy Extensions
[/code]

Changed 8 years ago by rpc@…

comment:8 Changed 8 years ago by florian

  • Resolution set to fixed
  • Status changed from accepted to closed

Fixed with r21312.

comment:9 Changed 8 years ago by rpc@…

florian@

config interface lan

option type bridge
option ifname eth0
option ifname "eth0 eth1"
option proto static
option ipaddr 192.168.1.1

This change will help a little. On my router based on TNETD7200 is only one Ethernet interface-eth0. There is no eth1.

The problem still exists and, unfortunately, is not resolved. Still can not log into the router. In summary OpenWrt Backfire 10.03.x still does not work with the router AG241V2-EU chipset TNETD7200ZDW.

No problem as it works with the kamikaze 8.09.x

This looks like a bug in the kernel, or the lack of a patch

comment:10 Changed 8 years ago by rpc@…

Might once again remind
The kamikaze 8.09.x in the log I have:

cpmac-mii: probed cpmac: device eth0 (regs: 08610000, irq: 27, phy: , mac: 00:0e:0a:aa:44:ff)

The Backfire 10.03.x in the log I have:

cpmac: device eth0 (regs: 08610000, irq: 27, phy: 1:1f, mac: 00:0e:0a:aa:00:00)

Bad detects the MAC address address. Differences in the entries can be seen immediately.

Valid MAC address of the router are:00:0e:0a:aa:44:ff

comment:11 Changed 8 years ago by rpc@…

Open new bug: /ticket/7330.html

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.