Modify

Opened 8 years ago

Closed 7 years ago

#7149 closed defect (fixed)

Dropbear UCI Port Does Not Allow For IP Address Binds

Reported by: marlowe@… Owned by: acinonyx
Priority: normal Milestone: Backfire 10.03.1
Component: packages Version: Trunk
Keywords: Cc: maddes

Description

According to the dropbear man page, the -p option should support the following argument [address]:port. However the uci setting, Port is set as an integer and will not allow an IP address. Attempts to set this, 192.168.16.1:22, in the port field through the web interface results in the following error message

Value "192.168.16.1:22" of option "dropbear.@dropbear[0].Port" does not validate as datatype "integer"

Setting via uci produces no errors, but dropbear will not restart.

I recommend a separate uci setting for address.

Attachments (0)

Change History (7)

comment:1 Changed 8 years ago by acinonyx

  • Owner changed from developers to acinonyx
  • Status changed from new to accepted

comment:2 Changed 8 years ago by acinonyx

  • Resolution set to fixed
  • Status changed from accepted to closed

Fixed by adding an option to bind to specific interface in r20960

comment:3 Changed 7 years ago by maddes

  • Resolution fixed deleted
  • Status changed from closed to reopened

The originally reported error is not reproducable and the option for a separate address setting is unnecessary.
The following patch will clean up the init script for trunk and allows multiple addresses/ports.
Scanning for interfaces also looks like a left over from some experiments.

uci set dropbear.@dropbear[0].Port="10.0.0.254:22"
uci set dropbear.@dropbear[0].Port="10.0.0.254:22 10.0.0.254:2222"
uci set dropbear.@dropbear[0].Port="10.0.0.254:22 *:2222 1234"

Please recheck.

comment:4 Changed 7 years ago by maddes

  • Milestone changed from Kamikaze to Backfire 10.03.1

comment:5 Changed 7 years ago by maddes

  • Cc maddes added

comment:6 Changed 7 years ago by maddes

Could talk to acinonyx on IRC, and there was a slight misunderstanding on my side.
Patch is removed.

comment:7 Changed 7 years ago by maddes

  • Resolution set to fixed
  • Status changed from reopened to closed

The original problem is a Luci problem (web interface), not a uci problem.
When adding support for multiple ports and ip addresses, then Luci must be adopted.
webif/X-Wrt should be informed and updated too.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.