Modify

Opened 8 years ago

Closed 8 years ago

Last modified 4 years ago

#7136 closed defect (fixed)

wireless-testing 2010-04-09 non-working wifi on Atheros PB44

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

...
CPU 0 Unable to handle kernel paging request at virtual address 00000000, epc == 00000000, ra == 83b45dfc
Oops[#1]:
Cpu 0
$ 0   : 00000000 802e0000 00000000 00008000
$ 4   : 83b38000 83b3812c 00000001 83b38000
$ 8   : 00000038 800643b8 00000000 00000000
$12   : 0000001c 83b13c98 00000040 83b7d310
$16   : 83b51f38 83b38000 0000000a 83bd2f24
$20   : 83b3812c 00000000 8384aa94 83b38244
$24   : 00000000 83bc1ae4                  
$28   : 83b12000 83b13da8 00000000 83b45dfc
Hi    : 00000008
Lo    : 00098d5e
epc   : 00000000 (null)
    Not tainted
ra    : 83b45dfc 0x83b45dfc
Status: 1000fc03    KERNEL EXL IE 
Cause : 10800008
BadVA : 00000000
PrId  : 00019374 (MIPS 24Kc)
Modules linked in: spi_vsc7385 usb_storage ohci_hcd nf_nat_tftp nf_conntrack_tftp nf_nat_irc nf_conntrack_irc nf_nat_ftp nf_conntrack_ftp ipt_MASQUERADE iptable_nat nf_nat xt_NOTRACK iptable_raw xt_state nf_conntrack_ipv4 nf_defrag_ipv4 nf_conntrack ehci_hcd sd_mod pppoe pppox ipt_REJECT xt_TCPMSS ipt_LOG xt_comment xt_multiport xt_mac xt_limit iptable_mangle iptable_filter ip_tables xt_tcpudp x_tables ext3 jbd ppp_async ppp_generic slhc ext4 jbd2 ath9k ath9k_common ath9k_hw ath nls_utf8 mac80211 usbcore scsi_mod nls_base mbcache crc16 crc_ccitt cfg80211 compat_firmware_class compat arc4 aes_generic deflate ecb cbc leds_gpio button_hotplug gpio_buttons input_polldev input_core
Process phy0 (pid: 508, threadinfo=83b12000, task=83884488, tls=00000000)
Stack : 83b38000 83b3812c 83b38000 83b596d8 00000036 00000036 83b38000 8384a9f8
        00000001 8384a9f8 83b38000 83b3812c 8384a200 8384a200 8384aa94 00000040
        00000000 83bc4bc8 00000000 802712dc efffffff 00000000 00000000 8384a200
        8384a9f8 83b38000 8384a9e0 83bc5140 802abe80 838868f8 fffffffc 8007820c
        80271314 83bd2f24 8384a200 8384a7ec fffffffc 8384a844 802712dc efffffff
        ...
Call Trace:[<83b596d8>] 0x83b596d8
[<83bc4bc8>] 0x83bc4bc8
[<83bc5140>] 0x83bc5140
[<8007820c>] 0x8007820c
[<83b84df8>] 0x83b84df8
[<80068c84>] 0x80068c84
[<8008e108>] 0x8008e108
[<80068c84>] 0x80068c84
[<80091f7c>] 0x80091f7c
[<8008dfe0>] 0x8008dfe0
[<80091ad0>] 0x80091ad0
[<8006c8c0>] 0x8006c8c0
[<80091a54>] 0x80091a54
[<8006c8b0>] 0x8006c8b0


Code: (Bad address in epc)

Disabling lock debugging due to kernel taint
Kernel panic - not syncing: Fatal exception in interrupt


Attachments (1)

openwrt-panic-kallsyms.txt (3.6 KB) - added by anonymous 8 years ago.
Panic with kallsyms

Download all attachments as: .zip

Change History (5)

Changed 8 years ago by anonymous

Panic with kallsyms

comment:1 Changed 8 years ago by Jochen

I am seeing the same panic on my RSPro with an AR9160 card (console dump attached) directly after configuring 802.11an. Reverting r20777 and reflashing the factory.bin helped somewhat (it doesn't panic anymore, but 802.11n doesn't work reliably either).

comment:2 Changed 8 years ago by Jochen

Hi,

I tried r20294 now and the issue is resolved (probably by r20887, but I didn't try).

Thanks!

comment:3 Changed 8 years ago by hauke

  • Resolution set to fixed
  • Status changed from new to closed

fixed

comment:4 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.